aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2015-08-19 22:18:33 +0200
committerJohannes Huber <johu@gentoo.org>2015-08-19 22:18:33 +0200
commitd5175b92723f77d8a7899df887159b9a5fa1bda3 (patch)
treef517ac4613dd232b24569c2796896f077526b1c5
parentMerge pull request #32 from johu/eapi-declaration (diff)
downloaddevmanual-d5175b92723f77d8a7899df887159b9a5fa1bda3.tar.gz
devmanual-d5175b92723f77d8a7899df887159b9a5fa1bda3.tar.bz2
devmanual-d5175b92723f77d8a7899df887159b9a5fa1bda3.zip
Update header lines
Due to git migration.
-rw-r--r--ebuild-writing/common-mistakes/text.xml14
-rw-r--r--ebuild-writing/eapi/text.xml12
-rw-r--r--ebuild-writing/file-format/text.xml8
-rw-r--r--ebuild-writing/functions/src_prepare/epatch/text.xml12
-rw-r--r--ebuild-writing/functions/src_unpack/rpm-sources/text.xml4
-rw-r--r--ebuild-writing/using-eclasses/text.xml4
-rw-r--r--eclass-writing/text.xml12
7 files changed, 32 insertions, 34 deletions
diff --git a/ebuild-writing/common-mistakes/text.xml b/ebuild-writing/common-mistakes/text.xml
index 9c6b423..1718d55 100644
--- a/ebuild-writing/common-mistakes/text.xml
+++ b/ebuild-writing/common-mistakes/text.xml
@@ -150,8 +150,7 @@ Removing "-Werror" from configure.ac can cause breakage in very rare cases where
<p>
When you submit your ebuilds, the header should be <e>exactly</e> the same as
the one in <path>/usr/portage/skel.ebuild</path>. Most importantly, do not
-modify it in any way and make sure that the <c>&#36;Header: &#36;</c> line is
-intact.
+modify it in any way and make sure that the <c>&#36;Id&#36;</c> line is intact.
</p>
<p>
@@ -159,17 +158,16 @@ The first three lines <e>must</e> look like this:
</p>
<pre caption="Valid Header">
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# &#36;Header: &#36;
+# &#36;Id&#36;
</pre>
<p>
Only if you are submitting a patched or version bumped ebuild, should you not
-need to modify the <c>&#36;Header: &#36;</c> line. But the line must be present.
-When we check the ebuild into CVS, it will modify that header with the
-appropriate version and date information. So there is no need for you to
-manually modify it.
+need to modify the <c>&#36;Id&#36;</c> line. But the line must be present.
+It will be expanded on the staging box automatically. So there is no need for you to manually modify it.
+See <uri link="::general-concepts/git-to-rsync"/>.
</p>
</body>
diff --git a/ebuild-writing/eapi/text.xml b/ebuild-writing/eapi/text.xml
index 3faab22..6d0162a 100644
--- a/ebuild-writing/eapi/text.xml
+++ b/ebuild-writing/eapi/text.xml
@@ -42,9 +42,9 @@ Most developers prefer to set the EAPI version without quotes. However, the PMS
</note>
<codesample lang="ebuild">
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: $
+# $Id$
EAPI=5
inherit eutils
@@ -120,9 +120,9 @@ src_compile() {
</important>
<codesample lang="ebuild">
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: $
+# $Id$
EAPI=1
@@ -515,9 +515,9 @@ DEPEND="
</p>
<p>Example:</p>
<codesample lang="ebuild">
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: $
+# $Id$
EAPI=4
inherit linux-info
diff --git a/ebuild-writing/file-format/text.xml b/ebuild-writing/file-format/text.xml
index b71ee74..74a623e 100644
--- a/ebuild-writing/file-format/text.xml
+++ b/ebuild-writing/file-format/text.xml
@@ -138,14 +138,14 @@ is to use <c>9999</c> as the version (or as the last version component).
<p>
All ebuilds committed to the tree should have a three line header immediately at
the start indicating copyright. This must be an exact copy of the contents of
-<c>$(portageq get_repo_path / gentoo)/header.txt</c>. Ensure that the <c>$Header: $</c> line is not
-modified manually <d/> CVS will handle this line specially.
+<c>$(portageq get_repo_path / gentoo)/header.txt</c>. Ensure that the <c>$Id$</c> line is not
+modified manually <d/> will be expanded on staging box. See <uri link="::general-concepts/git-to-rsync"/>.
</p>
<codesample lang="ebuild">
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: $
+# $Id$
</codesample>
</body>
diff --git a/ebuild-writing/functions/src_prepare/epatch/text.xml b/ebuild-writing/functions/src_prepare/epatch/text.xml
index 91d869e..2401bdc 100644
--- a/ebuild-writing/functions/src_prepare/epatch/text.xml
+++ b/ebuild-writing/functions/src_prepare/epatch/text.xml
@@ -66,14 +66,14 @@ Remember to add the patch to <c>SRC_URI</c>.
</body>
<subsection>
-<title>CVS Keyword Lines and Patches</title>
+<title>Git Keyword Expansion Lines and Patches</title>
<body>
<p>
-If your patch includes any changes to CVS <c>$Id: $</c>
-(or <c>$Header: $</c>, or <c>$Date: $</c>) lines, it cannot be
-distributed under <c>files/</c>, since CVS will clobber the patch when
-you commit. In these situations, either remove this hunk of the patch
-manually, or mirror the file.
+If your patch includes any changes to Git <c>$Id$</c>
+(or <c>$Date$</c>) lines, it cannot be
+distributed under <c>files/</c>, since Git will clobber the patch when
+keywords are expanded on the staging box. In these situations, either remove this hunk of the patch
+manually, or mirror the file. See <uri link="::general-concepts/git-to-rsync"/>.
</p>
</body>
</subsection>
diff --git a/ebuild-writing/functions/src_unpack/rpm-sources/text.xml b/ebuild-writing/functions/src_unpack/rpm-sources/text.xml
index dcf9113..0ff0def 100644
--- a/ebuild-writing/functions/src_unpack/rpm-sources/text.xml
+++ b/ebuild-writing/functions/src_unpack/rpm-sources/text.xml
@@ -52,9 +52,9 @@ patches. The filename should be <c>suse-fetchmail-6.2.5.54.1.ebuild</c>.
</p>
<codesample lang="ebuild">
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: $
+# $Id$
inherit eutils versionator rpm
diff --git a/ebuild-writing/using-eclasses/text.xml b/ebuild-writing/using-eclasses/text.xml
index 503ce34..d10f4fc 100644
--- a/ebuild-writing/using-eclasses/text.xml
+++ b/ebuild-writing/using-eclasses/text.xml
@@ -30,9 +30,9 @@ After inheriting an eclass, its provided functions can be used as normal. Here's
</p>
<codesample lang="ebuild">
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: $
+# $Id$
EAPI=2
diff --git a/eclass-writing/text.xml b/eclass-writing/text.xml
index 1914448..63aaf9c 100644
--- a/eclass-writing/text.xml
+++ b/eclass-writing/text.xml
@@ -176,9 +176,9 @@ a single function, <c>domacosapp</c>.
</p>
<codesample lang="ebuild">
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: $
+# $Id$
#
# Original Author: Ciaran McCreesh &lt;ciaranm@gentoo.org&gt;
@@ -263,9 +263,9 @@ something like the following:
</p>
<codesample lang="ebuild">
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: $
+# $Id$
# Original Author: Ciaran McCreesh &lt;ciaranm@gentoo.org&gt;
# Purpose: Demonstration of EXPORT_FUNCTIONS. Defines simple wrappers for the
@@ -306,9 +306,9 @@ for an eclass to invoke die from the global scope. For example:
</p>
<codesample lang="ebuild">
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: $
+# $Id$
# Purpose: Demonstration of die upon invalid EAPI usage.