aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGöktürk Yüksek <gokturk@gentoo.org>2019-11-25 21:52:25 -0500
committerGöktürk Yüksek <gokturk@gentoo.org>2019-11-25 22:04:16 -0500
commit427c85aeee6f8766b88e1f94a564032d050dd5a7 (patch)
treec395055aace4add347ba9c74e996ce81a0ce109c /quickstart/text.xml
parentxsl/lang.highlight.ebuild.xsl: add more EAPI keywords to highlight (diff)
downloaddevmanual-427c85aeee6f8766b88e1f94a564032d050dd5a7.tar.gz
devmanual-427c85aeee6f8766b88e1f94a564032d050dd5a7.tar.bz2
devmanual-427c85aeee6f8766b88e1f94a564032d050dd5a7.zip
quickstart/text.xml: call default in src_prepare()
It seems when converting epatch to eapply, the information about a call eapply_user being mandatory was missed. Signed-off-by: Göktürk Yüksek <gokturk@gentoo.org>
Diffstat (limited to 'quickstart/text.xml')
-rw-r--r--quickstart/text.xml7
1 files changed, 7 insertions, 0 deletions
diff --git a/quickstart/text.xml b/quickstart/text.xml
index 46435fc..24903ec 100644
--- a/quickstart/text.xml
+++ b/quickstart/text.xml
@@ -283,6 +283,7 @@ DEPEND="${RDEPEND}
src_prepare() {
eapply "${FILESDIR}"/${P}-destdir.patch \
"${FILESDIR}"/${P}-parallel_build.patch
+ eapply_user
}
src_configure() {
@@ -299,6 +300,11 @@ mirrors <d/> see <uri link="::general-concepts/mirrors#Gentoo Mirrors"/> and <ur
link="::ebuild-writing/functions/src_prepare/epatch/"/>.
</p>
+<p>
+When the <c>src_prepare</c> phase is overridden, it must be ensured
+that <c>eapply_user</c> is called.
+</p>
+
</body>
</section>
@@ -383,6 +389,7 @@ DEPEND="${RDEPEND}
src_prepare() {
eapply "${FILESDIR}"/${PN}-namespace.diff \
"${FILESDIR}"/${PN}-procmime.diff
+ eapply_user
}
src_configure() {