aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2015-10-24 14:36:56 -0400
committerAnthony G. Basile <blueness@gentoo.org>2015-10-24 14:36:56 -0400
commit4231891b2363f9028252e574cf5c53ac9547954f (patch)
treedf724fd5a936f3cf109f1305ad4bfd03ef44374d
parentscripts/paxmark.sh: default to both PT and XT. (diff)
downloadelfix-4231891b2363f9028252e574cf5c53ac9547954f.tar.gz
elfix-4231891b2363f9028252e574cf5c53ac9547954f.tar.bz2
elfix-4231891b2363f9028252e574cf5c53ac9547954f.zip
configure.ac: check for <gelf.h> only if ptpax is enabled.
Reported-by: Jory Pratt <anarchy@gentoo.org>
-rw-r--r--configure.ac7
1 files changed, 6 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 0c3c608..777c226 100644
--- a/configure.ac
+++ b/configure.ac
@@ -34,7 +34,7 @@ AC_PROG_SED
# Checks for header files.
AC_CHECK_HEADERS(
- [errno.h err.h fcntl.h gelf.h libgen.h stdio.h stdlib.h string.h \
+ [errno.h err.h fcntl.h libgen.h stdio.h stdlib.h string.h \
sys/mman.h sys/stat.h sys/types.h unistd.h],
[],
[AC_MSG_ERROR(["Missing necessary header"])]
@@ -73,6 +73,11 @@ AC_ARG_ENABLE(
AS_IF(
[test "x$enable_ptpax" != "xno"],
[
+ AC_CHECK_HEADERS(
+ [gelf.h],
+ [],
+ [AC_MSG_ERROR(["Missing necessary gelf.h"])]
+ )
AC_CHECK_LIB(
[elf],
[elf_begin],