summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile24
1 files changed, 24 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..2d92198
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,24 @@
+EMACS := emacs
+FIND := find
+
+EMACFLAGS := --batch -q --no-site-file
+EMACSCMD = $(EMACS) $(EMACFLAGS)
+
+
+.PHONY: all
+all: clean compile
+
+.PHONY: clean
+clean:
+ $(FIND) $(PWD) -iname "*.elc" -delete
+
+%.elc:
+ $(EMACSCMD) --eval "(byte-compile-file \"$(*).el\" 0)"
+
+.PHONY: compile
+compile: eix.elc
+
+.PHONY: install
+install: compile
+ $(EMACSCMD) \
+ --eval "(require 'package)" --eval "(package-install-file \"$(PWD)\")"