summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile16
1 files changed, 11 insertions, 5 deletions
diff --git a/Makefile b/Makefile
index 2d92198..ecb9ff5 100644
--- a/Makefile
+++ b/Makefile
@@ -1,7 +1,12 @@
+PWD ?= $(shell pwd)
+
+ELS = $(wildcard $(PWD)/*.el)
+ELCS = $(ELS:.el=.elc)
+
EMACS := emacs
-FIND := find
+FIND := rm -f
-EMACFLAGS := --batch -q --no-site-file
+EMACFLAGS := --batch -q --no-site-file -L $(PWD)
EMACSCMD = $(EMACS) $(EMACFLAGS)
@@ -10,15 +15,16 @@ all: clean compile
.PHONY: clean
clean:
- $(FIND) $(PWD) -iname "*.elc" -delete
+ $(RM) $(ELCS)
%.elc:
$(EMACSCMD) --eval "(byte-compile-file \"$(*).el\" 0)"
.PHONY: compile
-compile: eix.elc
+compile: $(ELCS)
.PHONY: install
install: compile
$(EMACSCMD) \
- --eval "(require 'package)" --eval "(package-install-file \"$(PWD)\")"
+ --eval "(require 'package)" \
+ --eval "(package-install-file \"$(PWD)\")"