aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2011-02-02 17:27:00 +0000
committerUlrich Müller <ulm@gentoo.org>2011-02-02 17:27:00 +0000
commit5de8096fcb2801c50e9c279ae41e046dcd70be44 (patch)
tree8fe996c7bcabc5aa965650dcd210b9726c5208d9
parentPatches for Prefix. (diff)
downloademacs-patches-emacs-22.3-patches-7.tar.gz
emacs-patches-emacs-22.3-patches-7.tar.bz2
emacs-patches-emacs-22.3-patches-7.zip
Fix an issue with duplicate items in GNU Info directory.emacs-23.2-patches-4emacs-22.3-patches-7
-rw-r--r--emacs/22.3/09_all_info-dir.patch48
-rw-r--r--emacs/23.2/05_all_info-dir.patch50
2 files changed, 98 insertions, 0 deletions
diff --git a/emacs/22.3/09_all_info-dir.patch b/emacs/22.3/09_all_info-dir.patch
new file mode 100644
index 0000000..992c105
--- /dev/null
+++ b/emacs/22.3/09_all_info-dir.patch
@@ -0,0 +1,48 @@
+http://debbugs.gnu.org/cgi/bugreport.cgi?bug=7942
+Backported to Emacs 22.
+
+--- emacs-22.3-orig/Makefile.in
++++ emacs-22.3/Makefile.in
+@@ -504,29 +504,24 @@
+ thisdir=`/bin/pwd`; \
+ if [ `(cd ${srcdir}/info && /bin/pwd)` != `(cd $(DESTDIR)${infodir} && /bin/pwd)` ]; \
+ then \
+- (cd $(DESTDIR)${infodir}; \
+- if [ -f dir ]; then true; \
+- else \
+- (cd $${thisdir}; \
+- ${INSTALL_DATA} ${srcdir}/info/dir $(DESTDIR)${infodir}/dir; \
+- chmod a+r $(DESTDIR)${infodir}/dir); \
+- fi; \
+- cd ${srcdir}/info ; \
++ (cd ${srcdir}/info ; \
+ for elt in $(INFO_FILES); do \
+ for f in `ls $$elt $$elt-[1-9] $$elt-[1-9][0-9] 2>/dev/null`; do \
+ ${INSTALL_DATA} $$f $(DESTDIR)${infodir}/$$f; \
+ chmod a+r $(DESTDIR)${infodir}/$$f; \
+ done; \
+- done); \
+- else true; fi
+- -unset CDPATH; \
+- thisdir=`/bin/pwd`; \
+- if [ `(cd ${srcdir}/info && /bin/pwd)` != `(cd $(DESTDIR)${infodir} && /bin/pwd)` ]; \
+- then \
+- for elt in $(INFO_FILES); do \
+- (cd $${thisdir}; \
+- ${INSTALL_INFO} --info-dir=$(DESTDIR)${infodir} $(DESTDIR)${infodir}/$$elt); \
+- done; \
++ done; \
++ cd $(DESTDIR)${infodir}; \
++ if [ -f dir ]; then \
++ for elt in $(INFO_FILES); do \
++ (cd $${thisdir}; \
++ ${INSTALL_INFO} --info-dir=$(DESTDIR)${infodir} $(DESTDIR)${infodir}/$$elt); \
++ done; \
++ else \
++ (cd $${thisdir}; \
++ ${INSTALL_DATA} ${srcdir}/info/dir $(DESTDIR)${infodir}/dir; \
++ chmod a+r $(DESTDIR)${infodir}/dir); \
++ fi); \
+ else true; fi
+ -chmod -R a+r $(DESTDIR)${datadir}/emacs/${version} $(DESTDIR)${datadir}/emacs/site-lisp ${COPYDESTS} $(DESTDIR)${infodir}
+ thisdir=`/bin/pwd`; \
diff --git a/emacs/23.2/05_all_info-dir.patch b/emacs/23.2/05_all_info-dir.patch
new file mode 100644
index 0000000..7e721e9
--- /dev/null
+++ b/emacs/23.2/05_all_info-dir.patch
@@ -0,0 +1,50 @@
+http://debbugs.gnu.org/cgi/bugreport.cgi?bug=7942
+
+--- emacs-23.2-orig/Makefile.in
++++ emacs-23.2/Makefile.in
+@@ -552,31 +552,26 @@
+ thisdir=`/bin/pwd`; \
+ if [ `(cd ${srcdir}/info && /bin/pwd)` != `(cd $(DESTDIR)${infodir} && /bin/pwd)` ]; \
+ then \
+- (cd $(DESTDIR)${infodir}; \
+- if [ -f dir ]; then true; \
+- else \
+- (cd $${thisdir}; \
+- ${INSTALL_DATA} ${srcdir}/info/dir $(DESTDIR)${infodir}/dir; \
+- chmod a+r $(DESTDIR)${infodir}/dir); \
+- fi; \
+- cd ${srcdir}/info ; \
++ (cd ${srcdir}/info ; \
+ for elt in $(INFO_FILES); do \
+ test "$(MAKEINFO)" = "off" && ! test -e $$elt && continue; \
+ for f in `ls $$elt $$elt-[1-9] $$elt-[1-9][0-9] 2>/dev/null`; do \
+ ${INSTALL_DATA} $$f $(DESTDIR)${infodir}/$$f; \
+ chmod a+r $(DESTDIR)${infodir}/$$f; \
+ done; \
+- done); \
+- else true; fi
+- -unset CDPATH; \
+- thisdir=`/bin/pwd`; \
+- if [ `(cd ${srcdir}/info && /bin/pwd)` != `(cd $(DESTDIR)${infodir} && /bin/pwd)` ]; \
+- then \
+- for elt in $(INFO_FILES); do \
+- test "$(MAKEINFO)" = "off" && ! test -e $$elt && continue; \
+- (cd $${thisdir}; \
+- ${INSTALL_INFO} --info-dir=$(DESTDIR)${infodir} $(DESTDIR)${infodir}/$$elt); \
+- done; \
++ done; \
++ cd $(DESTDIR)${infodir}; \
++ if [ -f dir ]; then \
++ for elt in $(INFO_FILES); do \
++ test "$(MAKEINFO)" = "off" && ! test -e $$elt && continue; \
++ (cd $${thisdir}; \
++ ${INSTALL_INFO} --info-dir=$(DESTDIR)${infodir} $(DESTDIR)${infodir}/$$elt); \
++ done; \
++ else \
++ (cd $${thisdir}; \
++ ${INSTALL_DATA} ${srcdir}/info/dir $(DESTDIR)${infodir}/dir; \
++ chmod a+r $(DESTDIR)${infodir}/dir); \
++ fi); \
+ else true; fi
+ -chmod -R a+r $(DESTDIR)${datadir}/emacs/${version} ${COPYDESTS}
+ thisdir=`/bin/pwd`; \