summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'emacs/24.1/01_all_ns-appdirs.patch')
-rw-r--r--emacs/24.1/01_all_ns-appdirs.patch41
1 files changed, 41 insertions, 0 deletions
diff --git a/emacs/24.1/01_all_ns-appdirs.patch b/emacs/24.1/01_all_ns-appdirs.patch
new file mode 100644
index 0000000..a8e3f82
--- /dev/null
+++ b/emacs/24.1/01_all_ns-appdirs.patch
@@ -0,0 +1,41 @@
+https://bugs.gentoo.org/268793
+https://bugs.gentoo.org/399059
+
+--- emacs-24.1-orig/Makefile.in
++++ emacs-24.1/Makefile.in
+@@ -476,21 +476,6 @@
+ -chmod 1755 $(DESTDIR)${bindir}/$(EMACSFULL)
+ rm -f $(DESTDIR)${bindir}/$(EMACS)
+ -ln $(DESTDIR)${bindir}/$(EMACSFULL) $(DESTDIR)${bindir}/$(EMACS)
+- if test "${ns_appresdir}" != ""; then \
+- ( cd ${ns_appresdir} ; \
+- if test -d share/emacs ; then dir=share/emacs/*/*; $(MV_DIRS); fi;\
+- if test -d share/info ; then dir=share/info; $(MV_DIRS) ; fi ; \
+- rm -fr share ) ; \
+- ( cd ${ns_appbindir} ; \
+- if cd libexec ; then dir=emacs/*/*/* ; $(MV_DIRS); \
+- rm -fr emacs; if cd ../bin; then rm -f emacs emacs-24*; \
+- ln -sf ../libexec/* . ; fi ; fi ) ; \
+- else true ; fi
+-
+-## FIXME is the emacs-24* bit above really necessary and correct?
+-## What if I have 24.1 and 24.2 installed at the same time?
+-## In any case, it should use something like echo $version | sed 's/\..*//'
+-## instead of hard-coding a version.
+
+ ## http://lists.gnu.org/archive/html/emacs-devel/2007-10/msg01672.html
+ ## Needs to be the user running install, so configure can't set it.
+--- emacs-24.1-orig/leim/Makefile.in
++++ emacs-24.1/leim/Makefile.in
+@@ -259,11 +259,6 @@
+ [ -n "$${installuser}" ] && break ; \
+ done ; \
+ find ${INSTALLDIR} -exec chown $${installuser} '{}' ';'
+- if [ "${ns_appresdir}" != "" ]; then \
+- ( cd ${ns_appresdir} ; \
+- if test -d share/emacs ; then dir=share/emacs/*/*; $(MV_DIRS); fi;\
+- rm -fr share ) ; \
+- else true ; fi
+
+ clean mostlyclean:
+ rm -f ${TIT_MISC} ${TIT_MISC:.elc=.el} \