aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakub 'cz_jc' Novák <jc.bl.dws@gmail.com>2010-06-27 03:18:53 +0200
committerJakub 'cz_jc' Novák <jc.bl.dws@gmail.com>2010-06-27 03:18:53 +0200
commit36c1b99f6b98951d1ca0fbcc13ca1116dc3dfac6 (patch)
tree43dfafce241533de3d0645528bf6421e16e46c11
parentxf86-video-glamo fixes, libdrm with glamo support (diff)
downloadembedded-cross-36c1b99f6b98951d1ca0fbcc13ca1116dc3dfac6.tar.gz
embedded-cross-36c1b99f6b98951d1ca0fbcc13ca1116dc3dfac6.tar.bz2
embedded-cross-36c1b99f6b98951d1ca0fbcc13ca1116dc3dfac6.zip
Fixed x11-drivers/xf86-video-glamo ebuild
- Now properly uses x-modular - Warning for USE="kms" converted to USE="-kms" because of broken #ifdefs in current revision that produce runtime problems. - Reformatted the DEPEND section. Sorry about that. - Removed "Experimental" from DESCRIPTION. As sleipnir says, experimental or not, this is the official way to get video output working on the Freerunner and I agree.
-rw-r--r--x11-drivers/xf86-video-glamo/Manifest2
-rw-r--r--x11-drivers/xf86-video-glamo/xf86-video-glamo-9999.ebuild31
2 files changed, 16 insertions, 17 deletions
diff --git a/x11-drivers/xf86-video-glamo/Manifest b/x11-drivers/xf86-video-glamo/Manifest
index 6cf1014..0136a72 100644
--- a/x11-drivers/xf86-video-glamo/Manifest
+++ b/x11-drivers/xf86-video-glamo/Manifest
@@ -1 +1 @@
-EBUILD xf86-video-glamo-9999.ebuild 1138 RMD160 23b37c34878c91629be8b45432441bc4b203d598 SHA1 5d835ce80c7e186e682a7354370caff0ef72751c SHA256 9badb8c3f595c443f57be4f1d6b1675ecf1e926853479b27968e4b3733d4f552
+EBUILD xf86-video-glamo-9999.ebuild 1021 RMD160 021491c646e91ef5f80c425ce18f5933e85d185e SHA1 353e1a33f78163873b104d6ca686cc162a638ad3 SHA256 168de28bc93b244a09a4683b9e322f53bb6be57b6dd53896cd1fa2c8b432b977
diff --git a/x11-drivers/xf86-video-glamo/xf86-video-glamo-9999.ebuild b/x11-drivers/xf86-video-glamo/xf86-video-glamo-9999.ebuild
index 6e93c7a..ca3e32b 100644
--- a/x11-drivers/xf86-video-glamo/xf86-video-glamo-9999.ebuild
+++ b/x11-drivers/xf86-video-glamo/xf86-video-glamo-9999.ebuild
@@ -4,9 +4,10 @@
EAPI=2
XDPVER=-1
+SNAPSHOT="yes"
inherit x-modular git
-DESCRIPTION="Experimental video driver for SMedia Glamo"
+DESCRIPTION="Video driver for SMedia Glamo"
HOMEPAGE="http://www.openmoko.org/"
EGIT_REPO_URI="git://git.openmoko.org/git/xf86-video-glamo.git"
@@ -15,23 +16,21 @@ EGIT_PROJECT="xf86-video-glamo"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~arm"
-IUSE="dri kms"
-
-use dri && EGIT_BRANCH="kms"
+IUSE="kms"
RDEPEND=">=x11-base/xorg-server-1.5"
DEPEND="${RDEPEND}
- x11-proto/randrproto
- x11-proto/renderproto
- x11-proto/xextproto
- x11-proto/xproto
+ x11-proto/randrproto
+ x11-proto/renderproto
+ x11-proto/xextproto
+ x11-proto/xproto
x11-proto/videoproto
x11-libs/libdrm[video_cards_glamo]"
pkg_setup() {
- if use kms ; then
- ewarn "If you experience build or run time difficulties, try disabling kms use flag."
+ if ! use kms ; then
+ ewarn "If you experience build or run time difficulties, try enabling kms use flag."
fi
}
@@ -43,13 +42,13 @@ src_unpack() {
eautoreconf || die "eautoreconf failed"
}
-src_compile() {
- local myconf
- myconf="${myconf} --disable-kms"
- use kms && myconf="${myconf} --enable-kms"
+src_configure() {
+ CONFIGURE_OPTIONS="$(use_enable kms )"
+ x-modular_src_configure
+}
- econf ${myconf} || die "Configuration failed"
- emake || die "Make failed"
+src_compile() {
+ x-modular_src_make
}
src_install() {