summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Sachau <tommy@gentoo.org>2010-10-03 17:20:49 +0000
committerThomas Sachau <tommy@gentoo.org>2010-10-03 17:20:49 +0000
commita2aca0b6afafd7859124d683852b4f837fa31a2c (patch)
tree2709d85352ee3a011b060798453a859c2f16110f
parentAdd beta release for embryo (diff)
downloadenlightenment-a2aca0b6afafd7859124d683852b4f837fa31a2c.tar.gz
enlightenment-a2aca0b6afafd7859124d683852b4f837fa31a2c.tar.bz2
enlightenment-a2aca0b6afafd7859124d683852b4f837fa31a2c.zip
Add beta release of edje
(Portage version: 2.2_rc88-r1/svn/Linux x86_64, RepoMan options: --force)
-rw-r--r--media-libs/edje/ChangeLog8
-rw-r--r--media-libs/edje/edje-1.0.0_beta.ebuild42
2 files changed, 49 insertions, 1 deletions
diff --git a/media-libs/edje/ChangeLog b/media-libs/edje/ChangeLog
index 8deeb98..4008855 100644
--- a/media-libs/edje/ChangeLog
+++ b/media-libs/edje/ChangeLog
@@ -1,7 +1,13 @@
# ChangeLog for media-libs/edje
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+*edje-1.0.0_beta (03 Oct 2010)
+
+ 03 Oct 2010; Thomas Sachau (Tommy[D]) <tommy@gentoo.org>
+ +edje-1.0.0_beta.ebuild:
+ Add beta release of edje
+
20 Dec 2009; Thomas Sachau (Tommy[D]) <tommy@gentoo.org>
+edje-0.9.93.063.ebuild:
Version bump for edje snapshot
diff --git a/media-libs/edje/edje-1.0.0_beta.ebuild b/media-libs/edje/edje-1.0.0_beta.ebuild
new file mode 100644
index 0000000..13d8576
--- /dev/null
+++ b/media-libs/edje/edje-1.0.0_beta.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/edje/edje-9999.ebuild,v 1.6 2006/07/16 05:29:42 vapier Exp $
+
+MY_P=${P/_beta/.beta}
+
+inherit enlightenment
+
+DESCRIPTION="graphical layout and animation library"
+HOMEPAGE="http://www.enlightenment.org/pages/edje.html"
+SRC_URI="http://download.enlightenment.org/releases/${MY_P}.tar.bz2"
+
+KEYWORDS="~amd64 ~x86"
+IUSE="debug cache static-libs vim-syntax"
+
+DEPEND="dev-lang/lua
+ >=dev-libs/eet-1.0.0_beta
+ >=dev-libs/eina-1.0.0_beta
+ >=dev-libs/embryo-1.0.0_beta
+ >=x11-libs/evas-1.0.0_beta
+ >=x11-libs/ecore-1.0.0_beta"
+RDEPEND=${DEPEND}
+
+S=${WORKDIR}/${MY_P}
+
+src_compile() {
+ export MY_ECONF="
+ $(use_enable cache edje-program-cache)
+ $(use_enable cache edje-calc-cache)
+ $(use_enable !debug amalgamation)
+ $(use_with vim-syntax vim /usr/share/vim)
+ "
+ enlightenment_src_compile
+}
+
+src_install() {
+ if use vim-syntax ; then
+ insinto /usr/share/vim/vimfiles/syntax/
+ doins data/edc.vim edc.vim
+ fi
+ enlightenment_src_install
+}