summaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorThomas Sachau <tommy@gentoo.org>2011-07-27 17:08:43 +0000
committerThomas Sachau <tommy@gentoo.org>2011-07-27 17:08:43 +0000
commitf07a2902efb532fcd2156936a20cf633d060c8b3 (patch)
treef8679f1d00643ab34c95ccfadfffd1e09b5ecae0 /x11-wm
parentDrop removed e_modules-places (diff)
downloadenlightenment-f07a2902efb532fcd2156936a20cf633d060c8b3.tar.gz
enlightenment-f07a2902efb532fcd2156936a20cf633d060c8b3.tar.bz2
enlightenment-f07a2902efb532fcd2156936a20cf633d060c8b3.zip
Update live ebuild, thanks to discomfitor for the changed ebuild and diff
(Portage version: 2.2.0_alpha46-r1/svn/Linux x86_64, RepoMan options: --force)
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/enlightenment/enlightenment-9999.ebuild4
-rw-r--r--x11-wm/enlightenment/files/quickstart.diff20
2 files changed, 12 insertions, 12 deletions
diff --git a/x11-wm/enlightenment/enlightenment-9999.ebuild b/x11-wm/enlightenment/enlightenment-9999.ebuild
index 40c598f..e451168 100644
--- a/x11-wm/enlightenment/enlightenment-9999.ebuild
+++ b/x11-wm/enlightenment/enlightenment-9999.ebuild
@@ -36,14 +36,14 @@ RDEPEND="exchange? ( >=app-misc/exchange-9999 )
pam? ( sys-libs/pam )
>=dev-libs/efreet-9999
>=dev-libs/eina-9999[mempool-chained]
- >=dev-libs/ecore-9999[X,evas,inotify]
+ || ( >=dev-libs/ecore-9999[X,evas,inotify] >=dev-libs/ecore-9999[xcb,evas,inotify] )
>=media-libs/edje-9999
>=dev-libs/e_dbus-9999[hal?,libnotify,udev?]
ukit? ( >=dev-libs/e_dbus-9999[udev] )
e_modules_connman? ( >=dev-libs/e_dbus-9999[connman] )
e_modules_ofono? ( >=dev-libs/e_dbus-9999[ofono] )
e_modules_illume? ( >=dev-libs/e_dbus-9999[hal] )
- >=media-libs/evas-9999[eet,X,jpeg,png]
+ || ( >=media-libs/evas-9999[eet,X,jpeg,png] >=media-libs/evas-9999[eet,xcb,jpeg,png] )
bluetooth? ( net-wireless/bluez )
udev? ( dev-libs/eeze )
!udev? ( !hal? ( dev-libs/eeze ) )
diff --git a/x11-wm/enlightenment/files/quickstart.diff b/x11-wm/enlightenment/files/quickstart.diff
index f7bd6d9..c7d3f38 100644
--- a/x11-wm/enlightenment/files/quickstart.diff
+++ b/x11-wm/enlightenment/files/quickstart.diff
@@ -1,13 +1,13 @@
-Index: bin/e_main.c
+Index: src/bin/e_main.c
===================================================================
---- src/bin/e_main.c (revision 50439)
+--- src/bin/e_main.c (revision 61690)
+++ src/bin/e_main.c (working copy)
-@@ -60,7 +60,7 @@
+@@ -93,7 +93,7 @@
+ static Eina_Bool _e_main_cb_startup_fake_end(void *data __UNUSED__);
- EAPI int e_precache_end = 0;
-
--static int really_know = 0;
-+static int really_know = 1;
-
- /* local subsystem functions */
- static void _e_main_shutdown_push(int (*func)(void));
+ /* local variables */
+-static Eina_Bool really_know = EINA_FALSE;
++static Eina_Bool really_know = EINA_TRUE;
+ static Eina_Bool locked = EINA_FALSE;
+ static Eina_Bool inloop = EINA_FALSE;
+ static jmp_buf x_fatal_buff;