summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2016-01-20 09:40:00 -0500
committerMichael Orlitzky <mjo@gentoo.org>2016-01-20 09:40:00 -0500
commit64f783dff3a2d62de670c8a5994d012751d2440e (patch)
treebb1ed4d9b89f6dbca8f4bd7c749d26953edf02e8
parentBump to v0.8.5 in configure.ac. (diff)
downloadeselect-php-64f783df.tar.gz
eselect-php-64f783df.tar.bz2
eselect-php-64f783df.zip
Fix cleanup up libphp[57].so symlinks.
The cleanup() action is supposed to remove the old links to libphp5.so and libphp7.so, but the pattern was accidentally quoted and thus nothing was removed. Unquote it so that those symlinks will actually be removed. Gentoo-Bug: 572436
-rw-r--r--src/php.eselect.in2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/php.eselect.in b/src/php.eselect.in
index 9970520..b2a0dd5 100644
--- a/src/php.eselect.in
+++ b/src/php.eselect.in
@@ -199,7 +199,7 @@ cleanup_sapi() {
fi
if [[ "${sapi}" == "apache2" ]] ; then
- rm -f "${EROOT}$(get_active_libdir)/apache2/modules/libphp[57].so" \
+ rm -f "${EROOT}$(get_active_libdir)"/apache2/modules/libphp[57].so \
|| die "failed to remove old libphp.so symlink"
fi