summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2017-07-11 09:50:53 -0400
committerBrian Evans <grknight@gentoo.org>2017-07-11 09:50:53 -0400
commit77dbce75a224125eb6a6540e93367294b4b5331d (patch)
tree1fc01ca284b4500ae228cc23987fd5585b81f8b3 /Makefile.am
parentBump version to 0.9.2 in configure.ac. (diff)
downloadeselect-php-77dbce75a224125eb6a6540e93367294b4b5331d.tar.gz
eselect-php-77dbce75a224125eb6a6540e93367294b4b5331d.tar.bz2
eselect-php-77dbce75a224125eb6a6540e93367294b4b5331d.zip
Make the init script directory depend on LIBDIR
We cannot rely on the assumption that /usr/lib will always point to the right location, Bug 624528 demonstrates this. There is talk in Bug 506276 of making /usr/lib a generic target for all arches and stop supporting the symlink.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 719ced1..578062e 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,5 +1,7 @@
eselectdir = $(datadir)/eselect/modules
nodist_eselect_DATA = $(srcdir)/src/php.eselect
+initdir = $(sysconfdir)/init.d
+nodist_init_DATA = $(srcdir)/doc/php-fpm.example.init
# Without EXTRA_DIST, these files don't wind up in the tarball.
EXTRA_DIST = $(srcdir)/src/70_mod_php.conf.in doc/*.*
@@ -18,7 +20,7 @@ edit = sed -e 's|@BINDIR[@]|$(bindir)|g' \
-e 's|@LIBDIR[@]|$(libdir)|g' \
-e 's|@LOCALSTATEDIR[@]|$(localstatedir)|g'
-$(nodist_eselect_DATA) $(nodist_apacheconf_DATA): Makefile
+$(nodist_eselect_DATA) $(nodist_apacheconf_DATA) $(nodist_init_DATA): Makefile
rm -f $@ $@.tmp
srcdir=''; \
test -f ./$@.in || srcdir=$(srcdir)/; \
@@ -27,3 +29,4 @@ $(nodist_eselect_DATA) $(nodist_apacheconf_DATA): Makefile
$(srcdir)/src/php.eselect: $(srcdir)/src/php.eselect.in
$(srcdir)/src/70_mod_php.conf: $(srcdir)/src/70_mod_php.conf.in
+$(srcdir)/doc/php-fpm.example.init: $(srcdir)/doc/php-fpm.example.init.in