summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2016-01-21 21:12:37 -0500
committerMichael Orlitzky <mjo@gentoo.org>2016-01-21 21:12:37 -0500
commitf4a2678217a23ce0db353173f74a556039b5b08d (patch)
treefce66759673b3ff518c52ac0fbe2c2a744c538b3 /Makefile.am
parentClean up and document find_targets(). (diff)
downloadeselect-php-f4a2678217a23ce0db353173f74a556039b5b08d.tar.gz
eselect-php-f4a2678217a23ce0db353173f74a556039b5b08d.tar.bz2
eselect-php-f4a2678217a23ce0db353173f74a556039b5b08d.zip
Use uppercase @BINDIR@, @LIBDIR@, etc. for autotools substitution.
The last few commits introduced a problem: by passing php.eselect.in.in through autoconf, we unwittingly replace things like @bindir@ with ${exec_prefix}. This is because lowercase @bindir@ gets defined for automake and is intended to be based on the other directory variables like @exec_prefix@. Since we're replacing them after the fact in the Makefile, this commit avoids the autoconf mangling by making them all uppercase.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 3 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index 9487f1b..1d1132e 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -8,9 +8,9 @@ nodist_apacheconf_DATA = $(srcdir)/src/70_mod_php.conf
# localstatedir within our script and conf file. The example is taken
# from the autoconf documentation and can be found in the
# "Installation Directory Variables" section.
-edit = sed -e 's|@bindir[@]|$(bindir)|g' \
- -e 's|@libdir[@]|$(libdir)|g' \
- -e 's|@localstatedir[@]|$(localstatedir)|g'
+edit = sed -e 's|@BINDIR[@]|$(bindir)|g' \
+ -e 's|@LIBDIR[@]|$(libdir)|g' \
+ -e 's|@LOCALSTATEDIR[@]|$(localstatedir)|g'
$(nodist_eselect_DATA) $(nodist_apacheconf_DATA): Makefile
rm -f $@ $@.tmp