summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am9
1 files changed, 7 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index f544739..e425c84 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -4,7 +4,8 @@ nodist_eselect_DATA = $(srcdir)/src/php.eselect
# Without EXTRA_DIST, these files don't wind up in the tarball.
EXTRA_DIST = $(srcdir)/openrc \
$(srcdir)/src/70_mod_php.conf.in \
- $(srcdir)/src/php-fpm-launcher.in
+ $(srcdir)/src/php-fpm-launcher.in \
+ $(srcdir)/src/php-fpm.logrotate.in
if APACHE2
# Without these set, we won't try to install the conf file.
@@ -22,6 +23,9 @@ if FPM
nodist_libexec_SCRIPTS = $(srcdir)/src/php-fpm-launcher
+ logrotatedir = $(sysconfdir)/logrotate.d
+ nodist_logrotate_DATA = $(srcdir)/src/php-fpm.logrotate
+
tmpfilesdir = $(prefix)/lib/tmpfiles.d
dist_tmpfiles_DATA = $(srcdir)/src/php-fpm.conf
endif
@@ -37,7 +41,7 @@ edit = sed -e 's|@BINDIR[@]|$(bindir)|g' \
-e 's|@SYSCONFDIR[@]|$(sysconfdir)|g'
-$(nodist_eselect_DATA) $(nodist_apacheconf_DATA) $(nodist_init_SCRIPTS) $(nodist_libexec_SCRIPTS): Makefile
+$(nodist_eselect_DATA) $(nodist_apacheconf_DATA) $(nodist_init_SCRIPTS) $(nodist_libexec_SCRIPTS) $(nodist_logrotate_DATA): Makefile
rm -f $@ $@.tmp
srcdir=''; \
test -f ./$@.in || srcdir=$(srcdir)/; \
@@ -46,5 +50,6 @@ $(nodist_eselect_DATA) $(nodist_apacheconf_DATA) $(nodist_init_SCRIPTS) $(nodist
$(srcdir)/src/php.eselect: $(srcdir)/src/php.eselect.in
$(srcdir)/src/php-fpm-launcher: $(srcdir)/src/php-fpm-launcher.in
+$(srcdir)/src/php-fpm.logrotate: $(srcdir)/src/php-fpm.logrotate.in
$(srcdir)/src/70_mod_php.conf: $(srcdir)/src/70_mod_php.conf.in
$(srcdir)/openrc/init.d/php-fpm: $(srcdir)/openrc/init.d/php-fpm.in