summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 9f8b4eb..ac55443 100644
--- a/configure.ac
+++ b/configure.ac
@@ -20,6 +20,13 @@ AC_ARG_ENABLE(
esac],[apache2=false])
AM_CONDITIONAL([APACHE2], [test x$apache2 = xtrue])
+piddir=${piddir="@LOCALSTATEDIR@"}
+AC_ARG_WITH(piddir, AC_HELP_STRING([--with-piddir=DIR],
+ [where php-fpm PID files are placed [LOCALSTATEDIR]]),
+ if test x$withval != x -a x$withval != xno -a x$withval != xyes; then
+ piddir="$withval"
+ fi)
+AC_SUBST(piddir)
# List of output files.
AC_CONFIG_FILES([Makefile src/php.eselect.in doc/php-fpm.example.init.in])