aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 6fce662..9a72546 100644
--- a/configure.ac
+++ b/configure.ac
@@ -73,7 +73,7 @@ AC_SUBST(EPREFIX)
AC_MSG_CHECKING([whether building from git])
EXTRAVERSION=""
eselect_git_dir=${GIT_DIR:-${srcdir}/.git}
-if test -d "${eselect_git_dir}"; then
+if GIT_DIR="${eselect_git_dir}" git rev-parse >/dev/null 2>&1; then
COMMIT=`GIT_DIR="${eselect_git_dir}" git describe --long --always HEAD`
if test x$COMMIT != x; then
EXTRAVERSION=", git commit $COMMIT"