summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'trunk/app-text/voikko/voikko-9999.ebuild')
-rw-r--r--trunk/app-text/voikko/voikko-9999.ebuild21
1 files changed, 10 insertions, 11 deletions
diff --git a/trunk/app-text/voikko/voikko-9999.ebuild b/trunk/app-text/voikko/voikko-9999.ebuild
index 8500a21..b2b15c8 100644
--- a/trunk/app-text/voikko/voikko-9999.ebuild
+++ b/trunk/app-text/voikko/voikko-9999.ebuild
@@ -1,24 +1,24 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
-WANT_AUTOCONF="2.5"
-WANT_AUTOMAKE="1.9"
inherit subversion autotools
DESCRIPTION="Free Finnish spellchecking and huphenation library"
-HOMEPAGE="http://www.hunspell-fi.org/"
-ESVN_REPO_URI="https://svn.sourceforge.net/svnroot/voikko/trunk/libvoikko"
+HOMEPAGE="http://voikko.sourceforge.net/"
+ESVN_REPO_URI="https://voikko.svn.sourceforge.net/svnroot/voikko/trunk/libvoikko"
#ESVN_BOOTSTRAP="autogen.sh"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="-x86 -amd64" # Live SVN not for public consumption
-IUSE=""
+IUSE="hfst"
DEPEND="sci-misc/malaga
- =sci-misc/suomi-malaga-9999
- virtual/libiconv"
+ !hfst? ( =sci-misc/suomi-malaga-9999 )
+ virtual/libiconv
+ hfst? ( sci-misc/hfst )"
+ #hfst? ( sci-misc/omorfi )
RDEPEND="${DEPEND}"
src_unpack() {
@@ -28,14 +28,13 @@ src_unpack() {
}
src_compile() {
- econf --with-malaga-path=/usr/ \
- --with-dictionary-path=/usr/lib/suomi-malaga/ \
+ econf CXXFLAGS="-Wno-error -Wno-deprecated" $(use_enable hfst) \
|| die "econf failed"
emake || die "emake failed"
}
src_install() {
emake DESTDIR="${D}" install || die "install failed"
- dodoc README TODO || die "docs missing"
+ dodoc README || die "docs missing"
}