summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVadim A. Misbakh-Soloviov <git@mva.name>2018-09-04 15:00:19 +0700
committerVadim A. Misbakh-Soloviov <git@mva.name>2018-09-04 15:00:19 +0700
commit12d12d57d10be5b483a048d12114cb3ad5c487d9 (patch)
treec790407c3320f6d192aa453631ded0853dd6c4be
parentkbang: bye-bye (qt4, gcode, svn) (diff)
downloadgamerlay-12d12d57.tar.gz
gamerlay-12d12d57.tar.bz2
gamerlay-12d12d57.zip
some QA fixes. TODO: rewrite that ebuilds.
-rw-r--r--eclass/d-games.eclass17
-rw-r--r--games-action/voxatron/voxatron-0.2.3.ebuild12
-rw-r--r--games-action/zlock/zlock-0.20.ebuild7
-rw-r--r--games-util/qjoypad/qjoypad-4.3.0-r1.ebuild (renamed from games-util/qjoypad/qjoypad-4.3.0.ebuild)0
4 files changed, 11 insertions, 25 deletions
diff --git a/eclass/d-games.eclass b/eclass/d-games.eclass
index 98f2706..5e9cbe3 100644
--- a/eclass/d-games.eclass
+++ b/eclass/d-games.eclass
@@ -11,27 +11,20 @@
# in D programming language.
# base added for PATCHES=( ${FILESDIR}/patch ) support
-inherit eutils base games
-
# @ECLASS-VARIABLE: EAPI
# @DESCRIPTION:
# By default we want EAPI 2 which might be redefinable to newer versions later.
case ${EAPI:-0} in
- 2) : ;;
- *) DEPEND="EAPI-TOO-OLD" ;;
+ [2-7]) : ;;
+ *) die "d-games.eclass doesn't support your EAPI" ;;
esac
EXPORT_FUNCTIONS src_prepare
d-games_src_prepare() {
# not eapi-handled due to danger of change for sys package in future.
- if ! built_with_use sys-devel/gcc d; then
- ewarn "sys-devel/gcc must be built with d useflag"
- die "recompile gcc with USE=\"d\""
+ if ! has_version sys-devel/gcc[d]; then
+ ewarn "sys-devel/gcc must be built with d useflag (although, some new versions have no this flag anymore)"
+ die "recompile gcc with USE=\"d\" (or install the version that have this flag at all, and select this version to be used for this package"
fi
-
- # TODO: add check for correct gcc version selected in profile.
-
- base_src_prepare
- games_src_prepare
}
diff --git a/games-action/voxatron/voxatron-0.2.3.ebuild b/games-action/voxatron/voxatron-0.2.3.ebuild
index 7fba0d1..2d22e25 100644
--- a/games-action/voxatron/voxatron-0.2.3.ebuild
+++ b/games-action/voxatron/voxatron-0.2.3.ebuild
@@ -4,8 +4,6 @@
EAPI=5
-inherit games
-
DESCRIPTION="A voxelicious action adventure"
HOMEPAGE="http://www.lexaloffle.com/voxatron.php"
SRC_URI="${PN}_${PV}_i386.tar.gz"
@@ -17,9 +15,10 @@ KEYWORDS="~amd64 ~x86"
IUSE=""
DEPEND=""
-RDEPEND="${DEPEND}
- x86? ( media-libs/libsdl[opengl] )
- amd64? ( app-emulation/emul-linux-x86-sdl )"
+RDEPEND="
+ ${DEPEND}
+ media-libs/libsdl[abi_x86_32,opengl]
+"
pkg_nofetch() {
ewarn
@@ -37,7 +36,6 @@ src_install() {
doexe vox
newicon lexaloffle-vox.png ${PN}.png
make_desktop_entry ${PN} Voxatron ${PN}
- games_make_wrapper ${PN} ./vox ${dir} ${dir}
+ make_wrapper ${PN} ./vox ${dir} ${dir}
dodoc ${PN}.txt
- prepgamesdirs
}
diff --git a/games-action/zlock/zlock-0.20.ebuild b/games-action/zlock/zlock-0.20.ebuild
index 53c357d..00c9c7a 100644
--- a/games-action/zlock/zlock-0.20.ebuild
+++ b/games-action/zlock/zlock-0.20.ebuild
@@ -47,7 +47,7 @@ src_prepare(){
}
src_install() {
- dogamesbin ${PN} || die "dogamesbin failed"
+ dobin ${PN} || die "dobin failed"
local datadir="${GAMES_DATADIR}"/${PN}
@@ -56,9 +56,4 @@ src_install() {
doins -r *.xml *.bmp *.ogg *.wav || die
make_desktop_entry ${PN} ${PN}
dodoc readme*
- prepgamesdirs
-}
-
-pkg_postinst() {
- games_pkg_postinst
}
diff --git a/games-util/qjoypad/qjoypad-4.3.0.ebuild b/games-util/qjoypad/qjoypad-4.3.0-r1.ebuild
index d52c4c5..d52c4c5 100644
--- a/games-util/qjoypad/qjoypad-4.3.0.ebuild
+++ b/games-util/qjoypad/qjoypad-4.3.0-r1.ebuild