summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAzamat H. Hackimov <azamat.hackimov@gmail.com>2010-07-25 22:43:20 +0600
committerAzamat H. Hackimov <azamat.hackimov@gmail.com>2010-07-25 22:43:20 +0600
commit20e79b72d9e0048e143f9b3f740735545fa32b11 (patch)
tree579d08127cac3ad812d2686a1c00b60c0bcea8c1
parentmedia-libs/fmod-4.30.06 (diff)
downloadgamerlay-20e79b72d9e0048e143f9b3f740735545fa32b11.tar.gz
gamerlay-20e79b72d9e0048e143f9b3f740735545fa32b11.tar.bz2
gamerlay-20e79b72d9e0048e143f9b3f740735545fa32b11.zip
games-simulation/babylon5-ifh-dao-1.15
Danger & Opportunity - a prequel for Babylon 5: I've Found Her
-rw-r--r--games-simulation/babylon5-ifh-dao/Manifest3
-rw-r--r--games-simulation/babylon5-ifh-dao/babylon5-ifh-dao-1.15.ebuild47
-rw-r--r--games-simulation/babylon5-ifh-dao/metadata.xml13
3 files changed, 63 insertions, 0 deletions
diff --git a/games-simulation/babylon5-ifh-dao/Manifest b/games-simulation/babylon5-ifh-dao/Manifest
new file mode 100644
index 0000000..548f674
--- /dev/null
+++ b/games-simulation/babylon5-ifh-dao/Manifest
@@ -0,0 +1,3 @@
+DIST ifh115.tar.gz 339820980 RMD160 26fcff8d3ececc1eea632d92690d2ef67a0c41fe SHA1 7b5789ca1e92dfdedd62cfead0e7aed2de866cfa SHA256 e7330ac5217eb5443714b10f14070e1467bb57a4b8140dca11b519221818651c
+EBUILD babylon5-ifh-dao-1.15.ebuild 1046 RMD160 82fe1f03d7ad2719b14ec7556fdf6f4de31ab9e3 SHA1 b723fab152170dd56b72803aeba1c25b29d958fd SHA256 a518a85f80129768fb0d3c48e84e2223bf61f3d4830d237e3d4c675134a395e9
+MISC metadata.xml 374 RMD160 fe10efafb7cab5b96615fe44ac77eba1f153340c SHA1 f9f7c6ab3b6c2bb1fec774933cdc83dede686d83 SHA256 2936d0e72b4f40bf40e7e62f7fb9a058c2d1ae7e7713c125a5dbe37c1b43bc1b
diff --git a/games-simulation/babylon5-ifh-dao/babylon5-ifh-dao-1.15.ebuild b/games-simulation/babylon5-ifh-dao/babylon5-ifh-dao-1.15.ebuild
new file mode 100644
index 0000000..e5b4b39
--- /dev/null
+++ b/games-simulation/babylon5-ifh-dao/babylon5-ifh-dao-1.15.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=3
+
+inherit games
+
+MY_PV=${PV/./}
+DESCRIPTION="Danger and Opportunity - a prequel for Babylon 5: I've Found Her"
+HOMEPAGE="http://ifhgame.ru/main/dao-home"
+SRC_URI="http://www.b5.ru/ifh/ifh${MY_PV}.tar.gz"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=media-libs/fmod-4.30.06
+ virtual/opengl
+ x11-libs/libX11"
+DEPEND="${DEPEND}"
+
+S="${WORKDIR}"/ifh
+
+src_install() {
+ local dir=${GAMES_PREFIX_OPT}/ifh
+ if use amd64; then
+ local exefile=coreifh64
+ fi
+ if use x86; then
+ local exefile=coreifh32
+ fi
+ # useless stuff
+ rm -r "${S}"/data/music/gg/.svn/
+ insinto "${dir}"
+ doins -r data || die "doins failed"
+ insinto "${dir}"/bin
+ doins bin/{*.cfg,resource.war} || die "doins failed"
+ # Saves goes here. INSECURE!!1
+ fperms 770 "${dir}"/data/pilots
+ exeinto "${dir}"/bin
+ doexe bin/${exefile} || die "doexe failes"
+ games_make_wrapper ${PN} ./${exefile} "${dir}/bin" "${dir}/bin"
+
+ prepgamesdirs
+}
diff --git a/games-simulation/babylon5-ifh-dao/metadata.xml b/games-simulation/babylon5-ifh-dao/metadata.xml
new file mode 100644
index 0000000..d523069
--- /dev/null
+++ b/games-simulation/babylon5-ifh-dao/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>gamerlay</herd>
+<maintainer>
+<email>azamat.hackimov@gmail.com</email>
+<name>Azamat H. Hackimov</name>
+</maintainer>
+<longdescription lang="en">
+Danger and Opportunity - a prequel for Babylon 5: I've Found Her
+</longdescription>
+</pkgmetadata>
+