summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAzamat H. Hackimov <azamat.hackimov@gmail.com>2021-07-12 23:06:11 +0300
committerAzamat H. Hackimov <azamat.hackimov@gmail.com>2021-07-12 23:45:59 +0300
commit212a195a158cc7ce9fb47fdf8f5730db7422e6e0 (patch)
treeb940c776321f7245788c9d827baa4cc1e390d23b
parentgames-engines/fifechan: migrate to cmake eclass (diff)
downloadgamerlay-212a195a.tar.gz
gamerlay-212a195a.tar.bz2
gamerlay-212a195a.zip
games-engines/fifengine: migrate to cmake.eclass
Package-Manager: Portage-3.0.20, Repoman-3.0.2 Signed-off-by: Azamat H. Hackimov <azamat.hackimov@gmail.com>
-rw-r--r--games-engines/fifengine/fifengine-0.4.2.ebuild12
1 files changed, 4 insertions, 8 deletions
diff --git a/games-engines/fifengine/fifengine-0.4.2.ebuild b/games-engines/fifengine/fifengine-0.4.2.ebuild
index 8a8a6a8..81c42f3 100644
--- a/games-engines/fifengine/fifengine-0.4.2.ebuild
+++ b/games-engines/fifengine/fifengine-0.4.2.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{6,7,8} pypy3 )
+PYTHON_COMPAT=( python3_{7..9} pypy3 )
-inherit eutils python-single-r1 cmake-utils
+inherit eutils python-single-r1 cmake
DESCRIPTION="Flexible Isometric Free Engine, 2D"
HOMEPAGE="http://fifengine.de"
@@ -66,9 +66,5 @@ src_configure() {
-Dbuild-library=ON
)
- cmake-utils_src_configure
-}
-
-src_install() {
- cmake-utils_src_install
+ cmake_src_configure
}