summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <michael@xmw.de>2015-03-10 12:13:05 +0100
committerMichael Weber <michael@xmw.de>2015-03-10 12:13:05 +0100
commit3d8732be59c3698bca698dc051e106107c3b4f88 (patch)
tree2347506bddcc4e80e189af8dab59709b82733a04
parentMerge branch 'master' of git://git.overlays.gentoo.org/proj/gamerlay (diff)
downloadgamerlay-3d8732be59c3698bca698dc051e106107c3b4f88.tar.gz
gamerlay-3d8732be59c3698bca698dc051e106107c3b4f88.tar.bz2
gamerlay-3d8732be59c3698bca698dc051e106107c3b4f88.zip
Add snapshot version due broken upstream repo
-rw-r--r--games-simulation/fgrun/Manifest11
-rw-r--r--games-simulation/fgrun/fgrun-3.5.0_p20150118.ebuild49
2 files changed, 60 insertions, 0 deletions
diff --git a/games-simulation/fgrun/Manifest b/games-simulation/fgrun/Manifest
new file mode 100644
index 0000000..c19d768
--- /dev/null
+++ b/games-simulation/fgrun/Manifest
@@ -0,0 +1,11 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA256
+
+DIST fgrun-3.5.0_p20150118.tar.gz 194251 SHA256 da2296520c792172d466a481f923b493ed6afe012857eb15d2094268f0403f2b SHA512 5fbb318329401fdf3fa940e4cc073dbc2a0bd59d5a7a0d04e64cfd974aaa68637f7175d6ad172d8d2b77ff0758ec9b73cbb1606d38c9c2997c604e814b605e51 WHIRLPOOL 3057baf11338cbb492ec802b46a7ce743b6df7b36045529d5260edc3c3abaee9a979de0703016606a2bbb9c43ef093c879ba33ab098c0c788f47d75749a3aa66
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v2
+
+iF4EAREIAAYFAlT+0T4ACgkQknrdDGLu8JDg8gD/dUBS+VjkAzbpmtD+pmTQzAon
+LjROfGn3AZpRz/vVwyUA/31+h8F+zxdvSN3nPWg6Q4tB1s3RbbXkT5CkAGQrCnEn
+=sF1N
+-----END PGP SIGNATURE-----
diff --git a/games-simulation/fgrun/fgrun-3.5.0_p20150118.ebuild b/games-simulation/fgrun/fgrun-3.5.0_p20150118.ebuild
new file mode 100644
index 0000000..1ecf472
--- /dev/null
+++ b/games-simulation/fgrun/fgrun-3.5.0_p20150118.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+
+inherit games cmake-utils vcs-snapshot
+
+DESCRIPTION="A graphical frontend for the FlightGear Flight Simulator"
+HOMEPAGE="http://sourceforge.net/projects/fgrun"
+SRC_URI="https://gitorious.org/fg/fgrun/archive/a9b036105a7c519090dc8324f5a43ba89810451e.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="nls"
+
+COMMON_DEPEND="
+ >=dev-games/openscenegraph-3.0.1
+ sys-libs/zlib
+ x11-libs/fltk:1[opengl,threads]
+"
+
+DEPEND="${COMMON_DEPEND}
+ >=dev-games/simgear-2.9
+ >=dev-libs/boost-1.34
+ nls? ( virtual/libintl )
+"
+
+RDEPEND="${COMMON_DEPEND}
+ >=games-simulation/flightgear-2.9
+"
+
+DOCS=(AUTHORS NEWS)
+
+src_configure() {
+ mycmakeargs=(
+ -DCMAKE_INSTALL_PREFIX=${GAMES_PREFIX}
+ -DSIMGEAR_SHARED=ON
+ $(cmake-utils_use_enable nls)
+ )
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+ make_desktop_entry ${PN} "${PN}" flightgear
+ prepgamesdirs
+}