summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAzamat H. Hackimov <azamat.hackimov@gmail.com>2020-02-06 20:55:12 +0300
committerAzamat H. Hackimov <azamat.hackimov@gmail.com>2020-02-06 20:55:12 +0300
commit5d000297c845516fc46dfe1354ea6960d3264e8f (patch)
treed3c0c2ba8f89c1ed5484da9791a90e2964d0054f
parent2048-qt: bump&fix (diff)
downloadgamerlay-5d000297.tar.gz
gamerlay-5d000297.tar.bz2
gamerlay-5d000297.zip
games-arcade/VVVVVV: update to opensourced version
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Azamat H. Hackimov <azamat.hackimov@gmail.com>
-rw-r--r--games-arcade/VVVVVV/Manifest2
-rw-r--r--games-arcade/VVVVVV/VVVVVV-2.01.ebuild47
-rw-r--r--games-arcade/VVVVVV/VVVVVV-2.02_p20200206.ebuild33
3 files changed, 34 insertions, 48 deletions
diff --git a/games-arcade/VVVVVV/Manifest b/games-arcade/VVVVVV/Manifest
index a37af39..5302bed 100644
--- a/games-arcade/VVVVVV/Manifest
+++ b/games-arcade/VVVVVV/Manifest
@@ -1 +1 @@
-DIST VVVVVV_2.01_Linux.tar.gz 61252498 SHA256 62e068aeed514be8259970d9adb42863cee3b0687a3acbad3ac631ac89110c7a SHA512 3e92d604bc90035bc2056733627c91afc09c3c8b89d99836d03f53a23794e45e8fe1c2753baf999a5fc220bc3e7fdddbc395437471b9c7e4c22430eb67c63152 WHIRLPOOL 5d1a0d27d7239018e8f1663ed284bc5b5e889e068ceb62c1554ec108d1328328ba01c917c54fe4d5adc3757b087f192420d28310682bfa938329e3d381137106
+DIST VVVVVV-data.zip 61404595 SHA256 6fae3cdec06062d05827d4181c438153f3ea3900437a44db73bcd29799fe57e0 SHA512 3cb08ede10ea8ed41056fef1837ef85b981f2cb8fc7627da4393984b9e8045b0a8343120520c32e24ff7e97399eabaa790d1d7b35c3e5dd30e052837b2c021da WHIRLPOOL 6166356dade8219526b21d108d564c4d5ff9d3fe79957f5054153a2dfd97035d953b0930535bfbfc2088d34884511e4cff231e35acafb1a9b68703bd5c95a1c4
diff --git a/games-arcade/VVVVVV/VVVVVV-2.01.ebuild b/games-arcade/VVVVVV/VVVVVV-2.01.ebuild
deleted file mode 100644
index 72af440..0000000
--- a/games-arcade/VVVVVV/VVVVVV-2.01.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-EAPI=4
-
-inherit games
-
-DESCRIPTION="Retro-styled open-world 2D puzzle platformer"
-HOMEPAGE="http://thelettervsixtim.es/"
-SRC_URI="${PN}_${PV}_Linux.tar.gz"
-
-LICENSE="EULA"
-SLOT="0"
-KEYWORDS="~x86 ~amd64"
-RESTRICT="fetch strip"
-IUSE=""
-
-DEPEND=""
-RDEPEND="
- media-libs/sdl-mixer
- media-libs/sdl-image:0
- media-libs/libsdl:0
- "
-
-S="${WORKDIR}/${PN}"
-
-src_install() {
- local dir="${GAMES_PREFIX_OPT}/${PN}"
- if use amd64 ; then
- local exe="${PN}_64"
- else
- local exe="${PN}_32"
- fi
-
- insinto "${dir}"
- exeinto "${dir}"
- doexe "$exe"
- newicon -s 32 "data/icons/32_2.png" "${PN}.png"
- newicon -s 16 "data/icons/16.png" "${PN}.png"
- doins -r data
-
- games_make_wrapper "${PN}" "./${exe}" "${dir}"
- make_desktop_entry "${PN}" "${PN}" "${PN}"
-
- prepgamesdirs
-}
diff --git a/games-arcade/VVVVVV/VVVVVV-2.02_p20200206.ebuild b/games-arcade/VVVVVV/VVVVVV-2.02_p20200206.ebuild
new file mode 100644
index 0000000..0bc68c4
--- /dev/null
+++ b/games-arcade/VVVVVV/VVVVVV-2.02_p20200206.ebuild
@@ -0,0 +1,33 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit cmake desktop git-r3
+
+DESCRIPTION="Retro-styled open-world 2D puzzle platformer"
+HOMEPAGE="https://thelettervsixtim.es/"
+
+EGIT_REPO_URI="https://github.com/TerryCavanagh/VVVVVV"
+EGIT_COMMIT="4e378b6057cca8e994b5b3049ff8b0cdadf1ebd9"
+
+SRC_URI="https://thelettervsixtim.es/makeandplay/data.zip -> ${PN}-data.zip"
+
+RESTRICT="mirror"
+LICENSE="VVVVVV-License-1.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="media-libs/libsdl2
+ media-libs/sdl2-mixer"
+RDEPEND="${DEPEND}"
+
+CMAKE_USE_DIR="${S}/desktop_version"
+
+src_install() {
+ exeinto /opt/${PN}
+ doexe "${BUILD_DIR}/${PN}"
+ insinto /opt/${PN}
+ newins "${DISTDIR}/${PN}-data.zip" data.zip
+ make_wrapper "${PN}" "./${PN}" "/opt/${PN}"
+ dodoc README.md
+}