summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAzamat H. Hackimov <azamat.hackimov@gmail.com>2018-11-15 23:41:01 +0300
committerAzamat H. Hackimov <azamat.hackimov@gmail.com>2018-11-15 23:41:01 +0300
commit608f5ce6b879a32526697c3270f7b4b8b30bbb8f (patch)
treee8271f0f1174f66c112890eea30c8572fe69c829
parentgames-rpg/zelda3t: update ebuild (diff)
downloadgamerlay-608f5ce6b879a32526697c3270f7b4b8b30bbb8f.tar.gz
gamerlay-608f5ce6b879a32526697c3270f7b4b8b30bbb8f.tar.bz2
gamerlay-608f5ce6b879a32526697c3270f7b4b8b30bbb8f.zip
games-fps/dhewm3: bump to 1.5.0_rc1, removed live
Minor fixes to metadata Signed-off-by: Azamat H. Hackimov <azamat.hackimov@gmail.com> Package-Manager: Portage-2.3.51, Repoman-2.3.11
-rw-r--r--games-fps/dhewm3/Manifest1
-rw-r--r--games-fps/dhewm3/dhewm3-1.5.0_rc1.ebuild (renamed from games-fps/dhewm3/dhewm3-9999.ebuild)43
-rw-r--r--games-fps/dhewm3/metadata.xml5
3 files changed, 16 insertions, 33 deletions
diff --git a/games-fps/dhewm3/Manifest b/games-fps/dhewm3/Manifest
new file mode 100644
index 0000000..c5d5bb2
--- /dev/null
+++ b/games-fps/dhewm3/Manifest
@@ -0,0 +1 @@
+DIST dhewm3-1.5.0_rc1.tar.gz 5373827 SHA256 28ecaf813f2555a31870d1efa83025a3b83d891d4dfa1fb8d713ad52ae3c54e9 SHA512 bc64843e6723e19d0af68b05ae698dde849d563dd052ffee75ba742ab66d33e35b140966131694f3d2a58abc835fcf6f47448e0b8fc4e1741712cf83426ae8de WHIRLPOOL 8b76c229d13f150040f88f74e0d60d70400639df40383802323dd020d61baeeefa6b8beab10449092f948d3bff6a9c7ca38c2c43e9979e56a10986fc8d27e072
diff --git a/games-fps/dhewm3/dhewm3-9999.ebuild b/games-fps/dhewm3/dhewm3-1.5.0_rc1.ebuild
index cda76dc..d07d8f9 100644
--- a/games-fps/dhewm3/dhewm3-9999.ebuild
+++ b/games-fps/dhewm3/dhewm3-1.5.0_rc1.ebuild
@@ -1,34 +1,33 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-inherit cmake-utils git-r3
+inherit cmake-utils
+
+MY_PV=${PV/_rc/_RC}
DESCRIPTION="A Doom 3 GPL source modification."
HOMEPAGE="https://github.com/dhewm/dhewm3"
-EGIT_REPO_URI="https://github.com/dhewm/dhewm3.git"
+SRC_URI="https://github.com/dhewm/dhewm3/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
LICENSE="GPL-3"
SLOT="0"
-KEYWORDS=""
-IUSE="cdinstall dedicated roe"
+KEYWORDS="~amd64"
+IUSE="dedicated"
DEPEND="
- virtual/jpeg
+ virtual/jpeg:0
media-libs/libogg
media-libs/libsdl2
media-libs/libvorbis
media-libs/openal
net-misc/curl
- sys-libs/zlib
+ sys-libs/zlib:=
"
-RDEPEND="${DEPEND}
- cdinstall? (
- >=games-fps/doom3-data-1.1.1282-r1
- roe? ( games-fps/doom3-roe )
- )"
+RDEPEND="${DEPEND}"
+S="${WORKDIR}/${PN}-${MY_PV}"
CMAKE_USE_DIR="${S}/neo"
DATADIR=/usr/share/dhewm3
@@ -57,25 +56,11 @@ src_install() {
newicon "${CMAKE_USE_DIR}"/sys/linux/setup/image/doom3.png "${PN}".png
make_desktop_entry "${PN}" "Doom 3 - dhewm"
-
- # TODO: roe desktop file
}
pkg_postinst() {
- if ! use cdinstall; then
- elog "You need to copy *.pk4 from either your installation media or your hard drive to"
- elog "${DATADIR}/base before running the game,"
- elog "or 'emerge games-fps/doom3-data' to install from CD."
- echo
- if use roe ; then
- elog "To use the Resurrection of Evil expansion pack, you also need to copy *.pk4"
- elog "to ${DATADIR}/d3xp from the RoE CD before running the game,"
- elog "or 'emerge doom3-roe' to install from CD."
- fi
- fi
-
- echo
- elog "To play the game, run:"
- elog " ${PN}"
+ elog "You need to copy *.pk4 from either your installation media or your hard drive to"
+ elog "${DATADIR}/base before running the game,"
+ elog "or 'emerge games-fps/doom3-data' to install from CD."
echo
}
diff --git a/games-fps/dhewm3/metadata.xml b/games-fps/dhewm3/metadata.xml
index c1e1824..b74872d 100644
--- a/games-fps/dhewm3/metadata.xml
+++ b/games-fps/dhewm3/metadata.xml
@@ -1,7 +1,7 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<maintainer>
+<maintainer type="person">
<email>azamat.hackimov@gmail.com</email>
<name>Azamat H. Hackimov</name>
</maintainer>
@@ -15,7 +15,4 @@ Compared to the original DOOM 3, the changes of dhewm 3 worth mentioning are:
* A portable build system based on CMake
* (Cross-)compilation with mingw-w64
</longdescription>
-<use>
- <flag name="roe">Adds support for the Resurrection of Evil expansion</flag>
-</use>
</pkgmetadata>