summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAzamat H. Hackimov <azamat.hackimov@gmail.com>2020-02-29 03:51:22 +0300
committerAzamat H. Hackimov <azamat.hackimov@gmail.com>2020-02-29 03:51:22 +0300
commit6e70a80f7b54fdff3cbe45bea13b5625490846af (patch)
tree8b3a68d62f123d98fae7551321c1c3bdd8014631
parentgames-arcade/rush: update package (diff)
downloadgamerlay-6e70a80f7b54fdff3cbe45bea13b5625490846af.tar.gz
gamerlay-6e70a80f7b54fdff3cbe45bea13b5625490846af.tar.bz2
gamerlay-6e70a80f7b54fdff3cbe45bea13b5625490846af.zip
games-arcade/tokitori: update package
Migrated from deprecated eclass. Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Azamat H. Hackimov <azamat.hackimov@gmail.com>
-rw-r--r--games-arcade/tokitori/metadata.xml4
-rw-r--r--games-arcade/tokitori/tokitori-20130703.ebuild25
2 files changed, 17 insertions, 12 deletions
diff --git a/games-arcade/tokitori/metadata.xml b/games-arcade/tokitori/metadata.xml
new file mode 100644
index 0000000..097975e
--- /dev/null
+++ b/games-arcade/tokitori/metadata.xml
@@ -0,0 +1,4 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+</pkgmetadata>
diff --git a/games-arcade/tokitori/tokitori-20130703.ebuild b/games-arcade/tokitori/tokitori-20130703.ebuild
index eece263..bd00381 100644
--- a/games-arcade/tokitori/tokitori-20130703.ebuild
+++ b/games-arcade/tokitori/tokitori-20130703.ebuild
@@ -1,6 +1,9 @@
-EAPI="5"
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
-inherit base games unpacker-nixstaller
+EAPI=7
+
+inherit desktop eutils unpacker-nixstaller
MY_PN="${PN^^t}"
TS="1372878397"
@@ -11,13 +14,12 @@ HOMEPAGE="http://www.tokitori.com/"
SRC_URI="${MY_P}.sh"
RESTRICT="fetch"
-LICENSE="as-is"
+LICENSE="all-rights-reserved"
SLOT="0"
KEYWORDS="-* ~amd64 ~x86"
IUSE=""
-DEPEND=""
-RDEPEND="${DEPEND}
+RDEPEND="
media-libs/libsdl2
media-libs/openal
sys-libs/zlib
@@ -34,21 +36,23 @@ S="${WORKDIR}"
DOCS=( "README.linux" )
src_unpack() {
- local arch=x86
+ local arch
use amd64 && arch=x86_64
+ use x86 && arch=x86
nixstaller_unpack "instarchive_all" "instarchive_all_${arch}"
}
src_install() {
- local dir="${GAMES_PREFIX_OPT}/${PN}"
- local arch=x86
+ local dir="/opt/${PN}"
+ local arch
use amd64 && arch=x86_64
+ use x86 && arch=x86
exeinto "${dir}"
insinto "${dir}"
make_desktop_entry "${PN}" "${MY_PN}" "${PN}"
- games_make_wrapper "${PN}" "./${PN}" "${dir}"
+ make_wrapper "${PN}" "./${PN}" "${dir}"
newexe "${MY_PN}.bin.${arch}" "${PN}"
newicon "${MY_PN}.png" "${PN}.png"
@@ -69,8 +73,5 @@ src_install() {
"menu" \
"splash" \
"textures"
-
- prepgamesdirs
-
base_src_install_docs
}