summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarcel Unbehaun <frostworks@gmx.de>2009-07-29 14:06:42 +0200
committerMarcel Unbehaun <frostworks@gmx.de>2009-07-29 14:06:42 +0200
commit718e38c8b28c27837a0872f052aee3dcbf6b7dd6 (patch)
treeb4c1560f1d39b30b41d68d8b1a7d639cadfc54fe
parent(games-action/gunroarhi) added Manifest (diff)
downloadgamerlay-718e38c8b28c27837a0872f052aee3dcbf6b7dd6.tar.gz
gamerlay-718e38c8b28c27837a0872f052aee3dcbf6b7dd6.tar.bz2
gamerlay-718e38c8b28c27837a0872f052aee3dcbf6b7dd6.zip
(games-action/mucade) added Manifest
(games-action/mucade) added files/digest-mucade-0.11 (games-action/mucade) added files/mucade-0.11.diff (games-action/mucade) added files/mucade.png (games-action/mucade) added metadata.xml (games-action/mucade) added mucade-0.11.ebuild
-rw-r--r--games-action/mucade/Manifest5
-rw-r--r--games-action/mucade/files/digest-mucade-0.113
-rw-r--r--games-action/mucade/files/mucade-0.11.diff454
-rw-r--r--games-action/mucade/files/mucade.pngbin0 -> 3122 bytes
-rw-r--r--games-action/mucade/metadata.xml9
-rw-r--r--games-action/mucade/mucade-0.11.ebuild77
6 files changed, 548 insertions, 0 deletions
diff --git a/games-action/mucade/Manifest b/games-action/mucade/Manifest
new file mode 100644
index 0000000..cfdec36
--- /dev/null
+++ b/games-action/mucade/Manifest
@@ -0,0 +1,5 @@
+AUX mucade-0.11.diff 14316 RMD160 3440830b1871d9b108db4d109a2fd16ec3469acf SHA1 62f2e383ce102173363d1b1c9f05b687f081ef45 SHA256 058a14cebffc3632bb646fdda028140ad8115d6d3beef292b61ff893ebca9cbf
+AUX mucade.png 3122 RMD160 6a96d66ad64836ffc387daaf6003fcaee0db2f0e SHA1 8a583e274e921e19c77f715e2932f9fba9cae234 SHA256 356711fccdad5cd3f1738381b090db9db7054cb24fc608e7a5a8f30e0b9029c6
+DIST mcd0_11.zip 6315975 RMD160 da94578f49e401f8503aa9ab11b40730ecd15e36 SHA1 cdd326b85eaa3af17c60e4adb629d5076e8c9a4f SHA256 e5acd67e06d765c63ea7dc7df6488ca3edd3410a05bd995b3842fe8e3b78451e
+EBUILD mucade-0.11.ebuild 2034 RMD160 68aa475ec3d25cb7c7172bce1e709c46e08ee681 SHA1 0be6b9088c2f6e89de05517984bcd29fd1bac812 SHA256 b77f9bc63943a6cbd9b3a92011d61660d15541e583460508217740f44c4024e2
+MISC metadata.xml 249 RMD160 220cde0fc1a8d7d355705f0f6772bd8d77cdc17a SHA1 34b33eb8d24cd8bfef2ddfb8e80334fd77cc9488 SHA256 3875fd5008d7f5bfe7f3cf7bf330c209a5034f5988d37c1699fb3be35a7be906
diff --git a/games-action/mucade/files/digest-mucade-0.11 b/games-action/mucade/files/digest-mucade-0.11
new file mode 100644
index 0000000..e550e2f
--- /dev/null
+++ b/games-action/mucade/files/digest-mucade-0.11
@@ -0,0 +1,3 @@
+MD5 59915ec27f7899cdf1e417987ead4ace mcd0_11.zip 6315975
+RMD160 da94578f49e401f8503aa9ab11b40730ecd15e36 mcd0_11.zip 6315975
+SHA256 e5acd67e06d765c63ea7dc7df6488ca3edd3410a05bd995b3842fe8e3b78451e mcd0_11.zip 6315975
diff --git a/games-action/mucade/files/mucade-0.11.diff b/games-action/mucade/files/mucade-0.11.diff
new file mode 100644
index 0000000..e06ea81
--- /dev/null
+++ b/games-action/mucade/files/mucade-0.11.diff
@@ -0,0 +1,454 @@
+diff -Naur mcd/import/ode/common.d mcd-gentoo/import/ode/common.d
+--- mcd/import/ode/common.d 2006-02-19 05:57:26.000000000 +0100
++++ mcd-gentoo/import/ode/common.d 2007-09-20 08:21:23.000000000 +0200
+@@ -24,7 +24,8 @@
+ private import std.c.math;
+ private import std.c.stdlib;
+ import ode.config;
+-import ode.error;
++import ode.error;
++import ode.objects;
+
+ extern(C):
+
+@@ -68,8 +69,8 @@
+
+ /* floating point data type, vector, matrix and quaternion types */
+
+-alias double dReal;
+-
++//alias double dReal;
++alias float dReal;
+
+ /* round an integer up to a multiple of 4, except that 0 and 1 are unmodified
+ * (used to compute matrix leading dimensions)
+@@ -119,8 +120,8 @@
+ struct dxWorld; /* dynamics world */
+ struct dxSpace; /* collision space */
+ struct dxBody; /* rigid body (dynamics object) */
+-struct dxGeom; /* geometry (collision object) */
+-struct dxJoint;
++struct dxGeom { };
++struct dxJoint { };
+ struct dxJointNode;
+ struct dxJointGroup;
+
+diff -Naur mcd/import/ode/ode.d mcd-gentoo/import/ode/ode.d
+--- mcd/import/ode/ode.d 2006-02-19 05:57:26.000000000 +0100
++++ mcd-gentoo/import/ode/ode.d 2007-09-20 08:21:23.000000000 +0200
+@@ -23,21 +23,21 @@
+
+ /* include *everything* here */
+
+-import ode.config;
+-import ode.compatibility;
+-import ode.common;
+-import ode.contact;
+-import ode.error;
+-import ode.memory;
+-import ode.odemath;
+-import ode.matrix;
+-import ode.timer;
+-import ode.rotation;
+-import ode.mass;
+-import ode.misc;
+-import ode.objects;
++public import ode.config;
++public import ode.compatibility;
++public import ode.common;
++public import ode.contact;
++public import ode.error;
++public import ode.memory;
++public import ode.odemath;
++public import ode.matrix;
++public import ode.timer;
++public import ode.rotation;
++public import ode.mass;
++public import ode.misc;
++public import ode.objects;
+ //import ode.odecpp;
+-import ode.collision_space;
+-import ode.collision;
++public import ode.collision_space;
++public import ode.collision;
+ //import ode.odecpp_collision;
+-import ode.export_dif;
++public import ode.export_dif;
+diff -Naur mcd/import/opengl.d mcd-gentoo/import/opengl.d
+--- mcd/import/opengl.d 2006-02-19 05:57:25.000000000 +0100
++++ mcd-gentoo/import/opengl.d 2007-09-20 08:21:54.000000000 +0200
+@@ -1,10 +1,4 @@
+-version (Win32) {
+- private import std.c.windows.windows;
+- extern(Windows):
+-}
+-version (linux) {
+ extern(C):
+-}
+
+ alias uint GLenum;
+ alias ubyte GLboolean;
+@@ -1116,7 +1110,7 @@
+ /*************************************************************/
+
+ void /*APIENTRY*/glAccum (GLenum op, GLfloat value);
+-void /*APIENTRY*/glAlphaFunc (GLenum func, GLclampf ref);
++void /*APIENTRY*/glAlphaFunc (GLenum func, GLclampf);
+ GLboolean /*APIENTRY*/glAreTexturesResident (GLsizei n, GLuint *textures, GLboolean *residences);
+ void /*APIENTRY*/glArrayElement (GLint i);
+ void /*APIENTRY*/glBegin (GLenum mode);
+@@ -1369,7 +1363,7 @@
+ void /*APIENTRY*/glScissor (GLint x, GLint y, GLsizei width, GLsizei height);
+ void /*APIENTRY*/glSelectBuffer (GLsizei size, GLuint *buffer);
+ void /*APIENTRY*/glShadeModel (GLenum mode);
+-void /*APIENTRY*/glStencilFunc (GLenum func, GLint ref, GLuint mask);
++void /*APIENTRY*/glStencilFunc (GLenum func, GLint, GLuint mask);
+ void /*APIENTRY*/glStencilMask (GLuint mask);
+ void /*APIENTRY*/glStencilOp (GLenum fail, GLenum zfail, GLenum zpass);
+ void /*APIENTRY*/glTexCoord1d (GLdouble s);
+diff -Naur mcd/import/openglu.d mcd-gentoo/import/openglu.d
+--- mcd/import/openglu.d 2006-02-19 05:57:25.000000000 +0100
++++ mcd-gentoo/import/openglu.d 2007-09-20 08:22:01.000000000 +0200
+@@ -1,11 +1,6 @@
+ import opengl;
+
+-version (Win32) {
+- extern(Windows):
+-}
+-version (linux) {
+ extern(C):
+-}
+
+ GLubyte* gluErrorString (
+ GLenum errCode);
+diff -Naur mcd/import/SDL.d mcd-gentoo/import/SDL.d
+--- mcd/import/SDL.d 2006-02-19 05:57:25.000000000 +0100
++++ mcd-gentoo/import/SDL.d 2007-09-20 08:21:23.000000000 +0200
+@@ -20,18 +20,28 @@
+ slouken@devolution.com
+ */
+
+-import SDL_types;
+-import SDL_getenv;
+-import SDL_error;
+-import SDL_rwops;
+-import SDL_timer;
+-import SDL_audio;
+-import SDL_cdrom;
+-import SDL_joystick;
+-import SDL_events;
+-import SDL_video;
+-import SDL_byteorder;
+-import SDL_Version;
++public import SDL_Keysym;
++public import SDL_Version;
++public import SDL_active;
++public import SDL_audio;
++public import SDL_byteorder;
++public import SDL_cdrom;
++public import SDL_copying;
++public import SDL_endian;
++public import SDL_error;
++public import SDL_events;
++public import SDL_getenv;
++public import SDL_joystick;
++public import SDL_keyboard;
++public import SDL_mouse;
++public import SDL_mutex;
++public import SDL_quit;
++public import SDL_rwops;
++public import SDL_syswm;
++public import SDL_thread;
++public import SDL_timer;
++public import SDL_types;
++public import SDL_video;
+
+ extern(C):
+
+diff -Naur mcd/Makefile mcd-gentoo/Makefile
+--- mcd/Makefile 1970-01-01 01:00:00.000000000 +0100
++++ mcd-gentoo/Makefile 2007-09-20 08:21:23.000000000 +0200
+@@ -0,0 +1,26 @@
++DC=gdmd
++#DC=gdc
++ifeq ($(DC), gdmd)
++DFLAGS=-O -g -debug -d -release -Iimport -Isrc
++#DFLAGS=-g -debug -Iimport -Isrc
++DOUT=-of
++else
++DFLAGS=-O -frelease -Iimport -Isrc
++#DFLAGS=-g -fdebug -Iimport -Isrc
++DOUT=-o
++endif
++
++DSRC=$(shell find src/abagames -name "*.d")
++SOURCES=$(DSRC) import/SDL_video.d import/SDL_mixer.d $(wildcard import/ode/*.d)
++OBJS=$(SOURCES:.d=.o)
++EXE=mucade
++
++all: $(EXE)
++
++$(EXE): $(OBJS)
++ gcc -o $@ $(OBJS) -lbulletml_d -lgphobos -lpthread -lm -lSDL -lGL -lGLU -lSDL_mixer -lstdc++ -lode
++
++$(OBJS): %.o: %.d
++ $(DC) -c $(DOUT)$@ $(DFLAGS) $<
++
++
+diff -Naur mcd/src/abagames/mcd/barrage.d mcd-gentoo/src/abagames/mcd/barrage.d
+--- mcd/src/abagames/mcd/barrage.d 2006-03-18 03:42:50.000000000 +0100
++++ mcd-gentoo/src/abagames/mcd/barrage.d 2007-09-20 08:21:23.000000000 +0200
+@@ -62,7 +62,8 @@
+
+ public static void load() {
+ char[][] dirs = listdir(BARRAGE_DIR_NAME);
+- foreach (char[] dirName; dirs) {
++ foreach (char[] dirName; dirs) {
++ parser[dirName] = null;
+ char[][] files = listdir(BARRAGE_DIR_NAME ~ "/" ~ dirName);
+ foreach (char[] fileName; files) {
+ if (getExt(fileName) != "xml")
+diff -Naur mcd/src/abagames/mcd/enemy.d mcd-gentoo/src/abagames/mcd/enemy.d
+--- mcd/src/abagames/mcd/enemy.d 2006-03-18 03:42:50.000000000 +0100
++++ mcd-gentoo/src/abagames/mcd/enemy.d 2007-09-20 08:21:23.000000000 +0200
+@@ -7,7 +7,20 @@
+
+ private import std.math;
+ private import opengl;
+-private import ode.ode;
++private import ode.ode;
++import ode.config;
++import ode.compatibility;
++import ode.common;
++import ode.contact;
++import ode.error;
++import ode.memory;
++import ode.odemath;
++import ode.matrix;
++import ode.timer;
++import ode.rotation;
++import ode.mass;
++import ode.misc;
++import ode.objects;
+ private import abagames.util.vector;
+ private import abagames.util.rand;
+ private import abagames.util.math;
+diff -Naur mcd/src/abagames/mcd/shape.d mcd-gentoo/src/abagames/mcd/shape.d
+--- mcd/src/abagames/mcd/shape.d 2006-02-19 05:57:26.000000000 +0100
++++ mcd-gentoo/src/abagames/mcd/shape.d 2007-09-20 08:21:23.000000000 +0200
+@@ -6,7 +6,20 @@
+ module abagames.mcd.shape;
+
+ private import opengl;
+-private import ode.ode;
++private import ode.ode;
++import ode.config;
++import ode.compatibility;
++import ode.common;
++import ode.contact;
++import ode.error;
++import ode.memory;
++import ode.odemath;
++import ode.matrix;
++import ode.timer;
++import ode.rotation;
++import ode.mass;
++import ode.misc;
++import ode.objects;
+ private import abagames.util.vector;
+ private import abagames.util.sdl.displaylist;
+ private import abagames.util.ode.odeactor;
+@@ -34,7 +47,7 @@
+ }
+
+ public void setMass(OdeActor oa, Vector3 sizeScale = null, float massScale = 1) {
+- dMass m;
++ dMass m = void;
+ dMassSetZero(&m);
+ addMass(&m, sizeScale, massScale);
+ oa.setMass(m);
+@@ -87,7 +100,7 @@
+ }
+
+ public void addMass(dMass* m, Vector3 sizeScale = null, float massScale = 1) {
+- dMass sm;
++ dMass sm = void;
+ if (sizeScale) {
+ dMassSetBox(&sm, 1, size.x * sizeScale.x, size.y * sizeScale.y, size.z * sizeScale.z);
+ dMassTranslate(&sm, pos.x * sizeScale.x, pos.y * sizeScale.y, pos.z * sizeScale.z);
+@@ -436,7 +449,7 @@
+
+ public void beginRecord() {
+ posIdx = 0;
+- glGetFloatv(GL_MODELVIEW_MATRIX, m);
++ glGetFloatv(GL_MODELVIEW_MATRIX, m.ptr);
+ }
+
+ public void setPos(Vector3 p) {
+diff -Naur mcd/src/abagames/mcd/ship.d mcd-gentoo/src/abagames/mcd/ship.d
+--- mcd/src/abagames/mcd/ship.d 2006-03-18 03:42:50.000000000 +0100
++++ mcd-gentoo/src/abagames/mcd/ship.d 2007-09-20 08:21:23.000000000 +0200
+@@ -7,7 +7,20 @@
+
+ private import std.math;
+ private import opengl;
+-private import ode.ode;
++private import ode.ode;
++import ode.config;
++import ode.compatibility;
++import ode.common;
++import ode.contact;
++import ode.error;
++import ode.memory;
++import ode.odemath;
++import ode.matrix;
++import ode.timer;
++import ode.rotation;
++import ode.mass;
++import ode.misc;
++import ode.objects;
+ private import abagames.util.vector;
+ private import abagames.util.rand;
+ private import abagames.util.math;
+@@ -520,7 +533,7 @@
+ Ship ship;
+ ParticlePool particles;
+ ConnectedParticlePool connectedParticles;
+- dMass m;
++ dMass m = void;
+ Shape shape;
+ LinePoint linePoint;
+ dJointID joint;
+diff -Naur mcd/src/abagames/mcd/spec.d mcd-gentoo/src/abagames/mcd/spec.d
+--- mcd/src/abagames/mcd/spec.d 2006-03-18 03:42:50.000000000 +0100
++++ mcd-gentoo/src/abagames/mcd/spec.d 2007-09-20 08:21:23.000000000 +0200
+@@ -7,7 +7,21 @@
+
+ private import std.math;
+ private import opengl;
+-private import ode.ode;
++private import ode.ode;
++import ode.objects;
++import ode.config;
++import ode.compatibility;
++import ode.common;
++import ode.contact;
++import ode.error;
++import ode.memory;
++import ode.odemath;
++import ode.matrix;
++import ode.timer;
++import ode.rotation;
++import ode.mass;
++import ode.misc;
++import ode.objects;
+ private import abagames.util.vector;
+ private import abagames.util.math;
+ private import abagames.util.ode.odeactor;
+diff -Naur mcd/src/abagames/mcd/stagemanager.d mcd-gentoo/src/abagames/mcd/stagemanager.d
+--- mcd/src/abagames/mcd/stagemanager.d 2006-03-18 03:42:50.000000000 +0100
++++ mcd-gentoo/src/abagames/mcd/stagemanager.d 2007-09-20 08:21:23.000000000 +0200
+@@ -9,7 +9,20 @@
+ private import std.string;
+ private import std.stream;
+ private import opengl;
+-private import ode.ode;
++private import ode.ode;
++import ode.config;
++import ode.compatibility;
++import ode.common;
++import ode.contact;
++import ode.error;
++import ode.memory;
++import ode.odemath;
++import ode.matrix;
++import ode.timer;
++import ode.rotation;
++import ode.mass;
++import ode.misc;
++import ode.objects;
+ private import abagames.util.tokenizer;
+ private import abagames.util.iterator;
+ private import abagames.util.rand;
+diff -Naur mcd/src/abagames/util/ode/odeactor.d mcd-gentoo/src/abagames/util/ode/odeactor.d
+--- mcd/src/abagames/util/ode/odeactor.d 2006-02-19 05:57:26.000000000 +0100
++++ mcd-gentoo/src/abagames/util/ode/odeactor.d 2007-09-20 08:21:23.000000000 +0200
+@@ -7,7 +7,20 @@
+
+ private import std.math;
+ private import opengl;
+-private import ode.ode;
++private import ode.ode;
++import ode.config;
++import ode.compatibility;
++import ode.common;
++import ode.contact;
++import ode.error;
++import ode.memory;
++import ode.odemath;
++import ode.matrix;
++import ode.timer;
++import ode.rotation;
++import ode.mass;
++import ode.misc;
++import ode.objects;
+ private import abagames.util.actor;
+ private import abagames.util.vector;
+ private import abagames.util.ode.world;
+diff -Naur mcd/src/abagames/util/ode/world.d mcd-gentoo/src/abagames/util/ode/world.d
+--- mcd/src/abagames/util/ode/world.d 2006-02-22 23:27:47.000000000 +0100
++++ mcd-gentoo/src/abagames/util/ode/world.d 2007-09-20 08:21:23.000000000 +0200
+@@ -5,7 +5,20 @@
+ */
+ module abagames.util.ode.world;
+
+-private import ode.ode;
++private import ode.ode;
++import ode.config;
++import ode.compatibility;
++import ode.common;
++import ode.contact;
++import ode.error;
++import ode.memory;
++import ode.odemath;
++import ode.matrix;
++import ode.timer;
++import ode.rotation;
++import ode.mass;
++import ode.misc;
++import ode.objects;
+ private import abagames.util.ode.odeactor;
+
+ /**
+diff -Naur mcd/src/abagames/util/sdl/texture.d mcd-gentoo/src/abagames/util/sdl/texture.d
+--- mcd/src/abagames/util/sdl/texture.d 2006-02-19 05:57:26.000000000 +0100
++++ mcd-gentoo/src/abagames/util/sdl/texture.d 2007-09-20 08:21:23.000000000 +0200
+@@ -103,13 +103,13 @@
+ }
+ glBindTexture(GL_TEXTURE_2D, num + ti);
+ gluBuild2DMipmaps(GL_TEXTURE_2D, 4, panelWidth, panelHeight,
+- GL_RGBA, GL_UNSIGNED_BYTE, pixels);
++ GL_RGBA, GL_UNSIGNED_BYTE, pixels.ptr);
+ glTexParameteri(GL_TEXTURE_2D,GL_TEXTURE_MIN_FILTER,GL_LINEAR_MIPMAP_NEAREST);
+ glTexParameteri(GL_TEXTURE_2D,GL_TEXTURE_MAG_FILTER,GL_LINEAR);
+ if (maskColor != 0xffffffffu) {
+ glBindTexture(GL_TEXTURE_2D, maskNum + ti);
+ gluBuild2DMipmaps(GL_TEXTURE_2D, 4, panelWidth, panelHeight,
+- GL_RGBA, GL_UNSIGNED_BYTE, maskPixels);
++ GL_RGBA, GL_UNSIGNED_BYTE, maskPixels.ptr);
+ glTexParameteri(GL_TEXTURE_2D,GL_TEXTURE_MIN_FILTER,GL_LINEAR_MIPMAP_NEAREST);
+ glTexParameteri(GL_TEXTURE_2D,GL_TEXTURE_MAG_FILTER,GL_LINEAR);
+ }
+diff -Naur mcd/src/abagames/util/sdl/twinstickpad.d mcd-gentoo/src/abagames/util/sdl/twinstickpad.d
+--- mcd/src/abagames/util/sdl/twinstickpad.d 2006-03-18 04:36:00.000000000 +0100
++++ mcd-gentoo/src/abagames/util/sdl/twinstickpad.d 2007-09-20 08:21:23.000000000 +0200
+@@ -8,7 +8,8 @@
+ private import std.string;
+ private import std.stream;
+ private import std.math;
+-private import SDL;
++private import SDL;
++private import SDL_keyboard;
+ private import abagames.util.vector;
+ private import abagames.util.sdl.input;
+ private import abagames.util.sdl.recordableinput;
diff --git a/games-action/mucade/files/mucade.png b/games-action/mucade/files/mucade.png
new file mode 100644
index 0000000..a108c7c
--- /dev/null
+++ b/games-action/mucade/files/mucade.png
Binary files differ
diff --git a/games-action/mucade/metadata.xml b/games-action/mucade/metadata.xml
new file mode 100644
index 0000000..4e4714e
--- /dev/null
+++ b/games-action/mucade/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+ <email>frostworks@gmx.de</email>
+ <name>Marcel Unbehaun</name>
+</maintainer>
+<herd>games</herd>
+</pkgmetadata>
diff --git a/games-action/mucade/mucade-0.11.ebuild b/games-action/mucade/mucade-0.11.ebuild
new file mode 100644
index 0000000..f685c46
--- /dev/null
+++ b/games-action/mucade/mucade-0.11.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit eutils games
+
+MY_PN=mcd
+MY_PV=${PV//./_}
+
+DESCRIPTION="The Physics Centipede Invasion. Smashup waggly shmup, 'Mu-cade'."
+HOMEPAGE="http://www.asahi-net.or.jp/~cs8k-cyu/windows/mcd_e.html"
+SRC_URI="http://www.asahi-net.or.jp/~cs8k-cyu/windows/${MY_PN}${MY_PV}.zip"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~ppc ~x86"
+IUSE=""
+
+DEPEND="media-libs/libsdl
+ media-libs/mesa
+ media-libs/sdl-mixer
+ <dev-games/ode-10.1
+ dev-libs/bulletss"
+RDEPEND=""
+
+S=${WORKDIR}/${MY_PN}
+
+pkg_setup() {
+ games_pkg_setup
+
+ # gcc must be built with "d" USE-FLAG
+ if ! built_with_use sys-devel/gcc:4.1 d; then
+ ewarn "sys-devel/gcc must be built with d for this package"
+ ewarn "to function."
+ die "recompile gcc with USE=\"d\""
+ fi
+ if [ "$(gcc-major-version)" == "4" ] && [ "$(gcc-minor-version)" == "2" ] ; then
+ die "gdc doesn't work with sys-devel/gcc-4.2 currently - use 4.1 instead"
+ fi
+}
+
+src_unpack(){
+ unpack ${A}
+ epatch "${FILESDIR}"/${P}.diff
+ sed -i \
+ -e 's:"\(images/[^"]*\)":"'${GAMES_DATADIR}'/'${PN}'/\1":g' -i mcd/src/abagames/util/sdl/texture.d \
+ -e 's:"\(barrage[^"]*\)":"'${GAMES_DATADIR}'/'${PN}'/\1":g' -i mcd/src/abagames/mcd/barrage.d \
+ -e 's:"\(sounds/[^"]*\)":"'${GAMES_DATADIR}'/'${PN}'/\1":g' -i mcd/src/abagames/util/sdl/sound.d \
+ -e 's:"\(mcd.prf[^"]*\)":"'${GAMES_STATEDIR}'/'${PN}'/\1":g' -i mcd/src/abagames/mcd/prefmanager.d \
+ || die "sed failed"
+}
+
+
+src_install() {
+ dogamesbin ${PN}
+ dodir "${GAMES_STATEDIR}/${PN}" "${GAMES_STATEDIR}/${PN}/replay"
+
+ if [ ! -e ${D}"${GAMES_STATEDIR}"/${PN}/mcd.prf ]; then
+ touch ${D}"${GAMES_STATEDIR}"/${PN}/mcd.prf
+ chmod ug+rw ${D}"${GAMES_STATEDIR}"/${PN}/mcd.prf
+ fi
+
+ local datadir="${GAMES_DATADIR}"/${PN}
+ dodir ${datadir}
+ insinto "${GAMES_DATADIR}"/${PN}
+ doins -r barrage images sounds || die
+ newicon "${FILESDIR}"/${PN}.png ${PN}.png
+ make_desktop_entry ${PN} ${PN}
+ dodoc readme*
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+}
+
+