summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authoreegorov <egor.y.egorov@gmail.com>2013-01-27 10:08:48 +0700
committerAzamat H. Hackimov <azamat.hackimov@gmail.com>2013-03-06 19:51:56 +0600
commit826f337a4b8a8f713b2f71c0040aa50d8bf820bb (patch)
tree3f29fafd4f09472a87de10573d4584800afe6dc7
parent[games-strategy/beathazard] added (as part of HiB A5) (diff)
downloadgamerlay-826f337a4b8a8f713b2f71c0040aa50d8bf820bb.tar.gz
gamerlay-826f337a4b8a8f713b2f71c0040aa50d8bf820bb.tar.bz2
gamerlay-826f337a4b8a8f713b2f71c0040aa50d8bf820bb.zip
xonotic-data depend on dev-games/gmqcc now
-rw-r--r--dev-games/gmqcc/gmqcc-9999.ebuild20
-rw-r--r--games-fps/xonotic-data/xonotic-data-9999.ebuild9
2 files changed, 23 insertions, 6 deletions
diff --git a/dev-games/gmqcc/gmqcc-9999.ebuild b/dev-games/gmqcc/gmqcc-9999.ebuild
new file mode 100644
index 0000000..e0366c1
--- /dev/null
+++ b/dev-games/gmqcc/gmqcc-9999.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: Exp $
+
+EGIT_REPO_URI="git://github.com/graphitemaster/gmqcc.git"
+EGIT_BRANCH="master"
+
+inherit git-2
+
+DESCRIPTION="An Improved Quake C Compiler"
+HOMEPAGE="http://graphitemaster.github.com/gmqcc/"
+LICENSE="as-is"
+
+SLOT="0"
+IUSE=""
+KEYWORDS="~amd64"
+
+src_install() {
+ emake install PREFIX="${D}/usr" || die
+}
diff --git a/games-fps/xonotic-data/xonotic-data-9999.ebuild b/games-fps/xonotic-data/xonotic-data-9999.ebuild
index a00eb14..06b9354 100644
--- a/games-fps/xonotic-data/xonotic-data-9999.ebuild
+++ b/games-fps/xonotic-data/xonotic-data-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
@@ -19,7 +19,7 @@ IUSE="+client +convert low +maps +zip"
RDEPEND=""
DEPEND="
- ~games-util/fteqcc-xonotic-9999
+ ~dev-games/gmqcc-9999
convert? (
media-gfx/imagemagick[jpeg,png]
low? ( media-sound/vorbis-tools )
@@ -119,10 +119,7 @@ src_compile() {
# Data
cd data
pushd xonotic-data.pk3dir
- emake \
- FTEQCC="/usr/bin/fteqcc-xonotic" \
- FTEQCCFLAGS_WATERMARK='' \
- || die "emake data.pk3 failed"
+ emake || die "emake data.pk3 failed"
popd
rm -rf \