summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAzamat H. Hackimov <azamat.hackimov@gmail.com>2021-07-12 22:57:41 +0300
committerAzamat H. Hackimov <azamat.hackimov@gmail.com>2021-07-12 23:45:59 +0300
commita021a17ceda3a1dcde4fac55e171a6999ba58613 (patch)
tree3db79a40929d8d0fd3b265033c02161a4219c091
parentgames-engines/ags: remove old (diff)
downloadgamerlay-a021a17c.tar.gz
gamerlay-a021a17c.tar.bz2
gamerlay-a021a17c.zip
games-engines/openxcom: update ebuild
Package-Manager: Portage-3.0.20, Repoman-3.0.2 Signed-off-by: Azamat H. Hackimov <azamat.hackimov@gmail.com>
-rw-r--r--games-engines/openxcom/openxcom-1.0.0_p20210611.ebuild (renamed from games-engines/openxcom/openxcom-1.0.0_p20171215.ebuild)26
1 files changed, 14 insertions, 12 deletions
diff --git a/games-engines/openxcom/openxcom-1.0.0_p20171215.ebuild b/games-engines/openxcom/openxcom-1.0.0_p20210611.ebuild
index 114c2b0..b4d2856 100644
--- a/games-engines/openxcom/openxcom-1.0.0_p20171215.ebuild
+++ b/games-engines/openxcom/openxcom-1.0.0_p20210611.ebuild
@@ -1,16 +1,16 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-inherit cmake-utils git-r3
+inherit cmake git-r3
DESCRIPTION="An open-source reimplementation of the popular UFO: Enemy Unknown"
HOMEPAGE="http://openxcom.org/"
# For translation files
#SRC_URI="http://openxcom.org/git_builds/openxcom_git_master_2015_09_25_2120.zip"
EGIT_REPO_URI="https://github.com/SupSuper/OpenXcom.git"
-EGIT_COMMIT=19efea3da04465ddc4d61a3a6aae25d0eff105a3
+EGIT_COMMIT=8d45159bf3e27d6aef62aff6035d9f6a59caf00b
LICENSE="GPL-3"
SLOT="0"
@@ -30,21 +30,27 @@ DEPEND="${RDEPEND}
DOCS=( README.md )
+src_prepare() {
+ default
+ sed -i -e "s:/man/man6:/share/man/man6:g" docs/CMakeLists.txt
+ cmake_src_prepare
+}
+
src_configure() {
mycmakeargs=(
"-DCMAKE_INSTALL_BINDIR=/usr/bin"
"-DCMAKE_INSTALL_DATADIR=/usr/share"
)
- cmake-utils_src_configure
+ cmake_src_configure
}
src_compile() {
- use doc && cmake-utils_src_compile doxygen
- cmake-utils_src_compile
+ use doc && cmake_src_compile doxygen
+ cmake_src_compile
}
src_install() {
- cmake-utils_src_install
+ cmake_src_install
use doc && dodoc -r "${CMAKE_BUILD_DIR}/docs/html/"
# for i in "common" "standard/xcom1" "standard/xcom2" ; do
@@ -55,10 +61,6 @@ src_install() {
# doins -r "../openxcom/standard/xcom1/Language/"
# insinto "${GAMES_DATADIR}/${PN}/standard/xcom2/Language/"
# doins -r "../openxcom/standard/xcom2/Language/"
-
- doicon res/linux/icons/openxcom.svg
- domenu res/linux/openxcom.desktop
-
}
pkg_postinst() {