summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVadim A. Misbakh-Soloviov <git@mva.name>2017-06-02 16:49:23 +0700
committerVadim A. Misbakh-Soloviov <git@mva.name>2017-06-02 16:49:23 +0700
commitedd9e982ef2b381a257a4ce2c522c224b432229a (patch)
treefab31d3933a33f4cfe6e187073f069023c71acfc
parentfrostworks upstream disappeared. Author (and maintainer) last seen long time ... (diff)
downloadgamerlay-edd9e982.tar.gz
gamerlay-edd9e982.tar.bz2
gamerlay-edd9e982.zip
glpng: upstream changed traball generation scheme
-rw-r--r--media-libs/glpng/Manifest1
-rw-r--r--media-libs/glpng/glpng-1.46-r1.ebuild27
-rw-r--r--media-libs/glpng/metadata.xml9
3 files changed, 37 insertions, 0 deletions
diff --git a/media-libs/glpng/Manifest b/media-libs/glpng/Manifest
new file mode 100644
index 0000000..1ca17be
--- /dev/null
+++ b/media-libs/glpng/Manifest
@@ -0,0 +1 @@
+DIST glpng-1.46.tar.gz 41040 SHA256 19b91406f982931b15235838b7c2a6d6e63bd1e8eec4f8f0f2c7cd76d6721872 SHA512 736829bd43b04dba825dc4d5b4b2eea279dbe92263f5201c807fe59f5f215e578385ebf2a90ae0e6c3f4298ba8e7659ed5140f64450eb48e40a852ec41e21112 WHIRLPOOL d78f325221731f5d9a2c9e24dcdaa59ca98a78c3a74b084eaf64a1fac53babb1ff0738241d73cc499b1b716541c6f23376442e6bd45f7ccd462a2d7ae14ef05d
diff --git a/media-libs/glpng/glpng-1.46-r1.ebuild b/media-libs/glpng/glpng-1.46-r1.ebuild
new file mode 100644
index 0000000..a16cbf7
--- /dev/null
+++ b/media-libs/glpng/glpng-1.46-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit cmake-multilib vcs-snapshot
+
+DESCRIPTION="An OpenGL PNG image library"
+HOMEPAGE="http://repo.or.cz/glpng.git"
+SRC_URI="http://repo.or.cz/glpng.git/snapshot/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE="static-libs"
+
+RDEPEND="
+ virtual/opengl[${MULTILIB_USEDEP}]
+ virtual/glu[${MULTILIB_USEDEP}]
+ media-libs/libpng:0=[${MULTILIB_USEDEP}]
+ sys-libs/zlib:=[${MULTILIB_USEDEP}]
+"
+DEPEND=${RDEPEND}
+
+src_configure() {
+ local mycmakeargs=( -DBUILD_STATIC_LIBS=$(usex static-libs ON OFF) )
+ cmake-multilib_src_configure
+}
diff --git a/media-libs/glpng/metadata.xml b/media-libs/glpng/metadata.xml
new file mode 100644
index 0000000..90d83b9
--- /dev/null
+++ b/media-libs/glpng/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>chewi@gentoo.org</email>
+ <name>James Le Cuirot</name>
+ </maintainer>
+ <longdescription>This is a library for OpenGL to load PNG graphics files as an OpenGL texture as easily as possible. It also has a number of options for generating the alpha channel and mipmaps.</longdescription>
+</pkgmetadata>