summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMario Kicherer <dev@kicherer.org>2015-03-19 21:19:52 +0100
committerMario Kicherer <dev@kicherer.org>2015-03-19 21:19:52 +0100
commitf46f6197b580912538d087f41ebdb79b260486f4 (patch)
tree7fe9c988e503d0b5dccb69e9a825bb8006a91fdb
parentBroken upstream repo (diff)
downloadgamerlay-f46f6197b580912538d087f41ebdb79b260486f4.tar.gz
gamerlay-f46f6197b580912538d087f41ebdb79b260486f4.tar.bz2
gamerlay-f46f6197b580912538d087f41ebdb79b260486f4.zip
[games-puzzle/londonlaw] new 0.3.0_pre2 version
l---------games-puzzle/londonlaw/londonlaw-0.3.0_pre2.ebuild1
-rw-r--r--games-puzzle/londonlaw/londonlaw-9999.ebuild23
2 files changed, 18 insertions, 6 deletions
diff --git a/games-puzzle/londonlaw/londonlaw-0.3.0_pre2.ebuild b/games-puzzle/londonlaw/londonlaw-0.3.0_pre2.ebuild
new file mode 120000
index 0000000..e058002
--- /dev/null
+++ b/games-puzzle/londonlaw/londonlaw-0.3.0_pre2.ebuild
@@ -0,0 +1 @@
+londonlaw-9999.ebuild \ No newline at end of file
diff --git a/games-puzzle/londonlaw/londonlaw-9999.ebuild b/games-puzzle/londonlaw/londonlaw-9999.ebuild
index ac09482..abf7dc5 100644
--- a/games-puzzle/londonlaw/londonlaw-9999.ebuild
+++ b/games-puzzle/londonlaw/londonlaw-9999.ebuild
@@ -5,14 +5,18 @@
EAPI=5
PYTHON_COMPAT=( python2_7 )
-inherit eutils python-single-r1 games git-r3
+if [ "${PV}" == "9999" ]; then
+ MY_INHERIT=git-r3
+fi
+
+inherit eutils python-single-r1 games $MY_INHERIT
DESCRIPTION="Clone of the famous Scotland Yard board game"
HOMEPAGE="http://pessimization.com/software/londonlaw/"
if [ "${PV}" == "9999" ]; then
EGIT_REPO_URI=https://github.com/anyc/londonlaw.git
else
- SRC_URI=""
+ SRC_URI="https://github.com/anyc/londonlaw/archive/v${PV}.tar.gz"
fi
LICENSE="GPL-2"
@@ -20,7 +24,7 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="dedicated"
-DEPEND="dev-python/twisted[${PYTHON_USEDEP}]
+DEPEND="dev-python/twisted-core[${PYTHON_USEDEP}]
dev-python/zope-interface[${PYTHON_USEDEP}]
!dedicated? ( dev-python/wxpython:3.0[${PYTHON_USEDEP}] )
@@ -48,9 +52,10 @@ src_prepare() {
"${FILESDIR}/${f}" > "${T}/${f}" \
|| die "sed failed"
done
+
sed -i \
- -e "/serverdata/ s:\"$:\"\n dbDir = \"${GAMES_STATEDIR}/${PN}\":" \
- londonlaw/server/GameRegistry.py \
+ -e "s:^LONDONLAW_DBDIR=.*$:LONDONLAW_DBDIR=${GAMES_STATEDIR}/${PN}:" \
+ "${T}/londonlaw.confd" \
|| die "sed failed"
python_fix_shebang .
@@ -63,17 +68,23 @@ src_install() {
--install-lib=$(python_get_sitedir) \
--install-data="${GAMES_DATADIR}" \
|| die "install failed"
+
dodoc doc/ChangeLog README.md doc/TODO doc/manual.tex doc/readme.protocol
dohtml doc/manual.html
newinitd "${T}/londonlaw.rc" londonlaw
newconfd "${T}/londonlaw.confd" londonlaw
- keepdir "${GAMES_STATEDIR}/${PN}"
+
dodir "${GAMES_LOGDIR}"
touch "${D}/${GAMES_LOGDIR}"/${PN}.log
+
+ keepdir "${GAMES_STATEDIR}/${PN}"
fowners ${GAMES_USER_DED}:${GAMES_GROUP} \
"${GAMES_STATEDIR}/${PN}" "${GAMES_LOGDIR}"/${PN}.log
+ fperms ug+rwx "${GAMES_STATEDIR}/${PN}"
+ fperms ug+rw "${GAMES_LOGDIR}"/${PN}.log
+
prepgamesdirs
}