summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNikoli <nikoli@lavabit.com>2011-09-08 21:26:31 +0400
committerNikoli <nikoli@lavabit.com>2011-09-08 21:26:31 +0400
commit2322095fd9f9e7469459d1f55ee615930fbf69b2 (patch)
treeef7285110429fdce9e045303fdd23b7660f2ccf1 /dev-libs/d0_blind_id/d0_blind_id-0.3.ebuild
parent[dev-games/simgear-cs] ebuild is back as terragear does not compile any longer (diff)
downloadgamerlay-2322095fd9f9e7469459d1f55ee615930fbf69b2.tar.gz
gamerlay-2322095fd9f9e7469459d1f55ee615930fbf69b2.tar.bz2
gamerlay-2322095fd9f9e7469459d1f55ee615930fbf69b2.zip
d0_blind_id: version bump, add USE tommath, cosmetics
(Portage version: 2.1.10.11/git/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-libs/d0_blind_id/d0_blind_id-0.3.ebuild')
-rw-r--r--dev-libs/d0_blind_id/d0_blind_id-0.3.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-libs/d0_blind_id/d0_blind_id-0.3.ebuild b/dev-libs/d0_blind_id/d0_blind_id-0.3.ebuild
new file mode 100644
index 0000000..e9938d1
--- /dev/null
+++ b/dev-libs/d0_blind_id/d0_blind_id-0.3.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="4"
+
+DESCRIPTION="Blind-ID library for user identification using RSA blind signatures"
+HOMEPAGE="http://git.xonotic.org/?p=xonotic/d0_blind_id.git;a=summary"
+SRC_URI="https://github.com/downloads/divVerent/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="crypt openssl static-libs tommath"
+REQUIRED_USE="openssl? ( !tommath )"
+
+RDEPEND="
+ openssl? ( !tommath? ( dev-libs/gmp ) )
+ openssl? ( dev-libs/openssl )
+ tommath? ( dev-libs/libtommath )
+"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+"
+DOCS=( d0_blind_id.txt )
+
+pkg_setup() {
+ use crypt || ewarn "You will have no encryption, only authentication."
+ use openssl && ewarn "OpenSSL is for Mac OS X users only, GMP is faster."
+ use tommath && ewarn "You enabled libtommath, GMP is faster."
+}
+
+src_configure() {
+ econf \
+ $(use_enable crypt rijndael) \
+ $(use_with openssl) \
+ $(use_with tommath) \
+ $(use_enable static-libs static)
+}