summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNikoli <nikoli@lavabit.com>2010-12-30 23:07:31 +0300
committerNikoli <nikoli@lavabit.com>2010-12-30 23:07:31 +0300
commit1f5dafc5d15e1fd43e08b67e01e0c5f9b52ff5a0 (patch)
treeee2ef6944d497b47e3061d567bdea99d95ef5535 /dev-libs/d0_blind_id/d0_blind_id-9999.ebuild
parentp.masking gigi and freeorion, wait until boost-1.44. (diff)
downloadgamerlay-1f5dafc5d15e1fd43e08b67e01e0c5f9b52ff5a0.tar.gz
gamerlay-1f5dafc5d15e1fd43e08b67e01e0c5f9b52ff5a0.tar.bz2
gamerlay-1f5dafc5d15e1fd43e08b67e01e0c5f9b52ff5a0.zip
d0_blind_id: initial ebuild
Diffstat (limited to 'dev-libs/d0_blind_id/d0_blind_id-9999.ebuild')
-rw-r--r--dev-libs/d0_blind_id/d0_blind_id-9999.ebuild62
1 files changed, 62 insertions, 0 deletions
diff --git a/dev-libs/d0_blind_id/d0_blind_id-9999.ebuild b/dev-libs/d0_blind_id/d0_blind_id-9999.ebuild
new file mode 100644
index 0000000..7ef843a
--- /dev/null
+++ b/dev-libs/d0_blind_id/d0_blind_id-9999.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=2
+
+SCM=""
+if [ "${PV#9999}" != "${PV}" ] ; then
+ SCM="git"
+fi
+inherit autotools $SCM
+
+DESCRIPTION="Blind-ID library for user identification using RSA blind signatures"
+HOMEPAGE="http://git.xonotic.org/?p=xonotic/d0_blind_id.git;a=summary"
+SCM=""
+if [ "${PV#9999}" != "${PV}" ] ; then
+ EGIT_REPO_URI="git://git.xonotic.org/xonotic/${PN}.git"
+else
+ SRC_URI="http://git.xonotic.org/?p=xonotic/${PN}.git;a=snapshot;h=xonotic-v${PV/_pre/preview};sf=zip -> ${P}.zip"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+if [ "${PV#9999}" = "${PV}" ] ; then
+ KEYWORDS="~amd64 ~x86"
+fi
+IUSE="crypt openssl static-libs"
+
+RDEPEND="
+ !openssl? ( dev-libs/gmp )
+ openssl? ( dev-libs/openssl )
+"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+"
+
+pkg_setup() {
+ use crypt || ewarn "You will have no encryption, only authentication."
+ use openssl && ewarn "OpenSSL is for Mac OS X users only, GMP is faster."
+}
+
+src_prepare() {
+ if [ "${PV#9999}" = "${PV}" ] ; then
+ mv d0_blind_id-xonotic-v0.1.0preview-* ${P} || die
+ cd "${S}"
+ fi
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable crypt rijndael) \
+ $(use_with openssl) \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ dodoc d0_blind_id.txt || die
+}