summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAzamat H. Hackimov <azamat.hackimov@gmail.com>2010-11-13 03:20:02 +0500
committerAzamat H. Hackimov <azamat.hackimov@gmail.com>2010-11-13 03:20:02 +0500
commitf6c966f8aad205775b711d599591090279ed8d79 (patch)
tree6f574d9ef5dc2721939dba10287460a4d5535115 /games-action/d2x-rebirth
parent[media-libs/libmmd] Manifest new manifest (diff)
downloadgamerlay-f6c966f8aad205775b711d599591090279ed8d79.tar.gz
gamerlay-f6c966f8aad205775b711d599591090279ed8d79.tar.bz2
gamerlay-f6c966f8aad205775b711d599591090279ed8d79.zip
[games-action/d2x-rebirth] New version moved from my overaly.
See bug #167341
Diffstat (limited to 'games-action/d2x-rebirth')
-rw-r--r--games-action/d2x-rebirth/Manifest6
-rw-r--r--games-action/d2x-rebirth/d2x-rebirth-0.56.ebuild69
-rw-r--r--games-action/d2x-rebirth/files/d2x-rebirth-0.56-printf-fix.patch188
-rw-r--r--games-action/d2x-rebirth/metadata.xml18
4 files changed, 281 insertions, 0 deletions
diff --git a/games-action/d2x-rebirth/Manifest b/games-action/d2x-rebirth/Manifest
new file mode 100644
index 0000000..3d461f9
--- /dev/null
+++ b/games-action/d2x-rebirth/Manifest
@@ -0,0 +1,6 @@
+AUX d2x-rebirth-0.56-printf-fix.patch 7002 RMD160 796bd0391f6aafd54e32f2780b1fc550f674e57a SHA1 606ed950f4d82d8b44a6705cc169e1c8c2f9424c SHA256 326b7178f42268434aab066c3d6a53adf1ea83ab9aa34d097fa822ff23b9957e
+DIST d2x-rebirth_v0.56-src.tar.gz 1375668 RMD160 1be8eaa08d8507e3647d342f8af9d26f7d283957 SHA1 29118115a37d8ccfa7240aab1ab83f9576b23b84 SHA256 f49ad525d40d2ec49f9cf0add702948465ac3d65239a23ce6b7cf0f49ba1e202
+DIST d2xr-briefings-ger.zip 6111 RMD160 65ee7a6a33462e96961e65ab5f24a1cccb0b3c0f SHA1 3a00df94e561298c25aeea1ee12ccaa71ec43400 SHA256 0bf4990c29a4ca10d4236270e392ab1d5f41ad373191782f78a0f3947069d16b
+DIST d2xr-sc55-music.zip 19254153 RMD160 9b027968bfd75b254ab90dc920e58b336472995a SHA1 40bd003c804c6fa9b8f10f2379359124e3d33224 SHA256 c9a5d8764f8b7fedd7416dc125459bd13e0672b44c8118aa6d7618ebcc5d9646
+EBUILD d2x-rebirth-0.56.ebuild 1785 RMD160 b31850f41119109593caee70812da7615a498336 SHA1 b1c16735435e4fb89bf5505be19450928fc44660 SHA256 04f7e792550b3c738362f1623a698aaac158f58e7ae7891c42caee5812599a8f
+MISC metadata.xml 530 RMD160 114a741796a76345de78b5ae71d877fb8361490c SHA1 4d074a555d7dd4ba505c573c90c2893743eb3c54 SHA256 f9af6976baaeb5e2d634a21c4c8394f8122e596d928320e38d5f90080f2b867e
diff --git a/games-action/d2x-rebirth/d2x-rebirth-0.56.ebuild b/games-action/d2x-rebirth/d2x-rebirth-0.56.ebuild
new file mode 100644
index 0000000..39484d8
--- /dev/null
+++ b/games-action/d2x-rebirth/d2x-rebirth-0.56.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="3"
+
+inherit games scons-utils
+
+DESCRIPTION="Descent Rebirth - enhanced Descent 2 engine"
+HOMEPAGE="http://www.dxx-rebirth.com/"
+SRC_URI="mirror://sourceforge/dxx-rebirth/${PN}_v${PV}-src.tar.gz
+ linguas_de? ( http://www.dxx-rebirth.com/download/dxx/res/d2xr-briefings-ger.zip )
+ music? ( http://www.dxx-rebirth.com/download/dxx/res/d2xr-sc55-music.zip )"
+
+LICENSE="D1X GPL-2 as-is"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug ipv6 linguas_de music opengl"
+
+DEPEND="dev-games/physfs[hog,mvl,zip]
+ media-libs/libsdl
+ media-libs/sdl-mixer"
+RDEPEND="${DEPEND}
+ virtual/opengl
+ virtual/glu"
+
+S=${WORKDIR}/${PN}_v${PV}-src
+
+src_unpack() {
+ unpack ${PN}_v${PV}-src.tar.gz
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-printf-fix.patch
+}
+
+src_compile() {
+ scons ${MAKEOPTS} \
+ sharepath="${GAMES_DATADIR}/d2x" \
+ sdlmixer=1 \
+ $(use_scons debug) \
+ $(use_scons !opengl sdl_only) \
+ $(use_scons ipv6)
+}
+
+src_install() {
+ dodoc INSTALL.txt README.txt
+ insinto "${GAMES_DATADIR}/d2x"
+ use linguas_de && doins "${DISTDIR}"/d2xr-briefings-ger.zip
+ use music && doins "${DISTDIR}"/d2xr-sc55-music.zip
+ doicon ${PN}.xpm
+
+ if use opengl ; then
+ newgamesbin d2x-rebirth-gl d2x-rebirth
+ else
+ newgamesbin d2x-rebirth-sdl d2x-rebirth
+ fi
+ make_desktop_entry d2x-rebirth "Descent 2 Rebirth" ${PN}
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ elog "You need to copy data-files from original Descent 2 installation"
+ elog "to ${GAMES_DATADIR}/d2x. Please read "
+ elog "/usr/share/doc/${PF}/INSTALL.txt for more info."
+ elog "You can emerge games-action/descent2-demodata (for Demo) or"
+ elog "games-action/descent2-data (if you have original Descent 2 CD)."
+}
diff --git a/games-action/d2x-rebirth/files/d2x-rebirth-0.56-printf-fix.patch b/games-action/d2x-rebirth/files/d2x-rebirth-0.56-printf-fix.patch
new file mode 100644
index 0000000..bc02dab
--- /dev/null
+++ b/games-action/d2x-rebirth/files/d2x-rebirth-0.56-printf-fix.patch
@@ -0,0 +1,188 @@
+=== modified file 'arch/sdl/jukebox.c'
+--- arch/sdl/jukebox.c 2010-09-26 13:15:20 +0000
++++ arch/sdl/jukebox.c 2010-10-14 14:46:20 +0000
+@@ -164,7 +164,7 @@
+ if (PHYSFS_isDirectory(GameCfg.CMLevelMusicPath)) // it's a child of Sharepath, build full path
+ {
+ PHYSFSX_getRealPath(GameCfg.CMLevelMusicPath,abspath);
+- snprintf(GameCfg.CMLevelMusicPath,sizeof(char)*PATH_MAX,abspath);
++ snprintf(GameCfg.CMLevelMusicPath,sizeof(char)*PATH_MAX,"%s",abspath);
+ }
+ }
+
+
+=== modified file 'include/cfile.h'
+--- include/cfile.h 2010-09-25 03:35:23 +0000
++++ include/cfile.h 2010-10-14 14:46:20 +0000
+@@ -45,7 +45,7 @@
+ {
+ char hogname2[PATH_MAX], pathname[PATH_MAX];
+
+- snprintf(hogname2, strlen(hogname)+1, hogname);
++ snprintf(hogname2, strlen(hogname)+1, "%s", hogname);
+ PHYSFSEXT_locateCorrectCase(hogname2);
+
+ if (!PHYSFSX_getRealPath(hogname2, pathname))
+@@ -58,7 +58,7 @@
+ {
+ char hogname2[PATH_MAX], pathname[PATH_MAX];
+
+- snprintf(hogname2, strlen(hogname)+1, hogname);
++ snprintf(hogname2, strlen(hogname)+1, "%s", hogname);
+ PHYSFSEXT_locateCorrectCase(hogname2);
+
+ if (!PHYSFSX_getRealPath(hogname2, pathname))
+@@ -74,7 +74,7 @@
+ char hogname2[PATH_MAX];
+ int size;
+
+- snprintf(hogname2, strlen(hogname)+1, hogname);
++ snprintf(hogname2, strlen(hogname)+1, "%s", hogname);
+ PHYSFSEXT_locateCorrectCase(hogname2);
+
+ fp = PHYSFS_openRead(hogname2);
+
+=== modified file 'main/console.c'
+--- main/console.c 2010-02-08 14:28:12 +0000
++++ main/console.c 2010-10-14 14:46:20 +0000
+@@ -82,7 +82,7 @@
+ con_add_buffer_line(priority, buffer);
+
+ /* Print output to stdout */
+- printf(buffer);
++ printf("%s",buffer);
+
+ /* Print output to gamelog.txt */
+ if (gamelog_fp)
+
+=== modified file 'main/hud.c'
+--- main/hud.c 2010-08-03 15:03:56 +0000
++++ main/hud.c 2010-10-14 14:46:20 +0000
+@@ -154,7 +154,7 @@
+ {
+ HUD_nmessages++;
+ }
+- snprintf(HUD_messages[HUD_nmessages-1].message, sizeof(char)*HUD_MESSAGE_LENGTH, message);
++ snprintf(HUD_messages[HUD_nmessages-1].message, sizeof(char)*HUD_MESSAGE_LENGTH, "%s", message);
+ if (HUD_nmessages-HUD_MAX_NUM_DISP < 0)
+ HUD_messages[HUD_nmessages-1].time = F1_0*3; // one message - display 3 secs
+ else
+
+=== modified file 'main/menu.c'
+--- main/menu.c 2010-10-14 09:50:11 +0000
++++ main/menu.c 2010-10-14 14:46:20 +0000
+@@ -1606,9 +1606,9 @@
+ char old_CMLevelMusicPath[PATH_MAX+1], old_CMMiscMusic0[PATH_MAX+1];
+
+ memset(old_CMLevelMusicPath, 0, sizeof(char)*(PATH_MAX+1));
+- snprintf(old_CMLevelMusicPath, strlen(GameCfg.CMLevelMusicPath)+1, GameCfg.CMLevelMusicPath);
++ snprintf(old_CMLevelMusicPath, strlen(GameCfg.CMLevelMusicPath)+1, "%s", GameCfg.CMLevelMusicPath);
+ memset(old_CMMiscMusic0, 0, sizeof(char)*(PATH_MAX+1));
+- snprintf(old_CMMiscMusic0, strlen(GameCfg.CMMiscMusic[SONG_TITLE])+1, GameCfg.CMMiscMusic[SONG_TITLE]);
++ snprintf(old_CMMiscMusic0, strlen(GameCfg.CMMiscMusic[SONG_TITLE])+1, "%s", GameCfg.CMMiscMusic[SONG_TITLE]);
+
+ MALLOC(m, newmenu_item, SOUND_MENU_NITEMS);
+ if (!m)
+
+=== modified file 'main/mission.c'
+--- main/mission.c 2010-08-24 14:02:38 +0000
++++ main/mission.c 2010-10-14 14:46:20 +0000
+@@ -716,19 +716,19 @@
+ {
+ char *tmp, *ptr;
+ MALLOC(tmp, char, FILENAME_LEN);
+- snprintf(tmp, FILENAME_LEN, v);
++ snprintf(tmp, FILENAME_LEN, "%s", v);
+ if ((ptr = strrchr(tmp, '.'))) // if there's a filename extension, kill it. No one knows it's the right one.
+ *ptr = '\0';
+ strncat(tmp, ".tex", sizeof(char)*FILENAME_LEN); // apply tex-extenstion
+ if (cfexist(tmp)) // check if this file exists ...
+- snprintf(Briefing_text_filename, FILENAME_LEN, tmp); // ... and apply ...
++ snprintf(Briefing_text_filename, FILENAME_LEN, "%s", tmp); // ... and apply ...
+ else // ... otherwise ...
+ {
+ if ((ptr = strrchr(tmp, '.')))
+ *ptr = '\0';
+ strncat(tmp, ".txb", sizeof(char)*FILENAME_LEN); // apply txb extension
+ if (cfexist(tmp)) // check if this file exists ...
+- snprintf(Briefing_text_filename, FILENAME_LEN, tmp); // ... and apply ...
++ snprintf(Briefing_text_filename, FILENAME_LEN, "%s", tmp); // ... and apply ...
+ }
+ d_free(tmp);
+ }
+@@ -741,19 +741,19 @@
+ {
+ char *tmp, *ptr;
+ MALLOC(tmp, char, FILENAME_LEN);
+- snprintf(tmp, FILENAME_LEN, v);
++ snprintf(tmp, FILENAME_LEN, "%s", v);
+ if ((ptr = strrchr(tmp, '.'))) // if there's a filename extension, kill it. No one knows it's the right one.
+ *ptr = '\0';
+ strncat(tmp, ".tex", sizeof(char)*FILENAME_LEN); // apply tex-extenstion
+ if (cfexist(tmp)) // check if this file exists ...
+- snprintf(Briefing_text_filename, FILENAME_LEN, tmp); // ... and apply ...
++ snprintf(Briefing_text_filename, FILENAME_LEN, "%s", tmp); // ... and apply ...
+ else // ... otherwise ...
+ {
+ if ((ptr = strrchr(tmp, '.')))
+ *ptr = '\0';
+ strncat(tmp, ".txb", sizeof(char)*FILENAME_LEN); // apply txb extension
+ if (cfexist(tmp)) // check if this file exists ...
+- snprintf(Ending_text_filename, FILENAME_LEN, tmp); // ... and apply ...
++ snprintf(Ending_text_filename, FILENAME_LEN, "%s", tmp); // ... and apply ...
+ }
+ d_free(tmp);
+ }
+
+=== modified file 'main/net_ipx.c'
+--- main/net_ipx.c 2010-09-01 17:01:51 +0000
++++ main/net_ipx.c 2010-10-14 14:46:20 +0000
+@@ -5824,7 +5824,7 @@
+ if(!netgame->mission_title)
+ info+=sprintf(info,"Descent2: CounterStrike");
+ else
+- info+=sprintf(info,netgame->mission_title);
++ info+=sprintf(info,"%s",netgame->mission_title);
+
+ info+=sprintf (info," - Lvl %i",netgame->levelnum);
+ info+=sprintf (info,"\n\nDifficulty: %s",MENU_DIFFICULTY_TEXT(netgame->difficulty));
+
+=== modified file 'main/net_udp.c'
+--- main/net_udp.c 2010-09-01 17:01:51 +0000
++++ main/net_udp.c 2010-10-14 14:46:20 +0000
+@@ -5183,7 +5183,7 @@
+ if(!netgame->mission_title)
+ info+=sprintf(info,"Descent2: CounterStrike");
+ else
+- info+=sprintf(info,netgame->mission_title);
++ info+=sprintf(info,"%s",netgame->mission_title);
+
+ info+=sprintf (info," - Lvl %i",netgame->levelnum);
+ info+=sprintf (info,"\n\nDifficulty: %s",MENU_DIFFICULTY_TEXT(netgame->difficulty));
+
+=== modified file 'main/scores.c'
+--- main/scores.c 2010-07-31 12:09:38 +0000
++++ main/scores.c 2010-10-14 14:46:20 +0000
+@@ -91,7 +91,7 @@
+ int i;
+
+ // No error message needed, code will work without a scores file
+- sprintf( scores->cool_saying, COOL_SAYING );
++ sprintf( scores->cool_saying, "%s", COOL_SAYING );
+ sprintf( scores->stats[0].name, "Parallax" );
+ sprintf( scores->stats[1].name, "Matt" );
+ sprintf( scores->stats[2].name, "Mike" );
+
+=== modified file 'misc/physfsx.c'
+--- misc/physfsx.c 2010-09-25 13:55:22 +0000
++++ misc/physfsx.c 2010-10-14 14:46:20 +0000
+@@ -304,7 +304,7 @@
+ filename++;
+ }
+
+- snprintf(filename2, strlen(filename)+1, filename);
++ snprintf(filename2, strlen(filename)+1, "%s", filename);
+ PHYSFSEXT_locateCorrectCase(filename2);
+
+ fp = PHYSFS_openRead(filename2);
+
diff --git a/games-action/d2x-rebirth/metadata.xml b/games-action/d2x-rebirth/metadata.xml
new file mode 100644
index 0000000..8b980e5
--- /dev/null
+++ b/games-action/d2x-rebirth/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>gameboys</herd>
+<maintainer>
+<email>azamat.hackimov@gmail.com</email>
+<name>Azamat H. Hackimov</name>
+</maintainer>
+<longdescription lang="en">
+Descent Rebirth - enhanced Descent 2 engine
+</longdescription>
+<longdescription lang="ru">
+Descent Rebirth - улучшенный движок для Descent 2
+</longdescription>
+<use>
+<flag name="music">Enable enchansed music</flag>
+</use>
+</pkgmetadata>