summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarcel Unbehaun <frostworks@gmx.de>2009-08-28 12:29:50 +0200
committerMarcel Unbehaun <frostworks@gmx.de>2009-08-28 12:29:50 +0200
commit579d345ccb995f15e168b4c297f72752f5f84b41 (patch)
tree61c2231e55388933d29b2f870697ef3942d86e02 /games-action/gunroarhi/gunroarhi-0.30.ebuild
parent(games-action/gunroar) rm files/digest-gunroar-0.15 (diff)
downloadgamerlay-579d345ccb995f15e168b4c297f72752f5f84b41.tar.gz
gamerlay-579d345ccb995f15e168b4c297f72752f5f84b41.tar.bz2
gamerlay-579d345ccb995f15e168b4c297f72752f5f84b41.zip
(games-action/gunroarhi) using debian patches gunroarhi-0.30.ebuild
(games-action/gunroarhi) new Manifest (games-action/gunroarhi) fixed patch files/03_put_prefs_in_home_dir.diff
Diffstat (limited to 'games-action/gunroarhi/gunroarhi-0.30.ebuild')
-rw-r--r--games-action/gunroarhi/gunroarhi-0.30.ebuild35
1 files changed, 24 insertions, 11 deletions
diff --git a/games-action/gunroarhi/gunroarhi-0.30.ebuild b/games-action/gunroarhi/gunroarhi-0.30.ebuild
index 0ccd94b..609e280 100644
--- a/games-action/gunroarhi/gunroarhi-0.30.ebuild
+++ b/games-action/gunroarhi/gunroarhi-0.30.ebuild
@@ -6,12 +6,16 @@ EAPI="2"
inherit d-games
+MY_PD=gunroar
+MY_PDV=0_15
+MY_PDPV=0.15
MY_PN=gr_hi
MY_PV=${PV//./_}
DESCRIPTION="Guns, Guns, Guns! 360-degree gunboat shooter, fork of ABAs 'Gunroar'"
HOMEPAGE="http://www.edit.ne.jp/~otoyan/soft/gr_hi.html"
-SRC_URI="http://www.edit.ne.jp/~otoyan/soft/gr_hi/${MY_PN}${MY_PV}.zip"
+SRC_URI="http://www.edit.ne.jp/~otoyan/soft/gr_hi/${MY_PN}${MY_PV}.zip
+ mirror://debian/pool/main/g/${MY_PD}/${MY_PD}_${MY_PDPV}.dfsg1-3.diff.gz"
LICENSE="BSD"
SLOT="0"
@@ -21,34 +25,43 @@ IUSE=""
RDEPEND="media-libs/libsdl
media-libs/mesa
media-libs/sdl-mixer"
+
DEPEND="${RDEPEND}"
S=${WORKDIR}/${MY_PN}
src_prepare(){
- epatch "${FILESDIR}"/${P}.diff
+ # using frostworks patches with debian's cleanups and minor patches
+ epatch "${WORKDIR}"/${MY_PD}_${MY_PDPV}.dfsg1-3.diff
+ sed -i -e "s:a7xpg-0.11.dfsg1/::g" -i "${S}"/${MY_PD}-${MY_PDPV}.dfsg1/debian/patches/makefile.patch
+ sed -i -e "s:${MY_PD}:${PN}:g" -i "${S}"/${MY_PD}-${MY_PDPV}.dfsg1/debian/patches/makefile.patch
+ sed -i -e "s:${MY_PD}_${MY_PDPV}.dfsg1.orig/:old-gr:g" -i "${S}"/${MY_PD}-${MY_PDPV}.dfsg1/debian/patches/03_put_prefs_in_home_dir.diff
+ sed -i -e "s:${MY_PD}_${MY_PDPV}.dfsg1/:new-gr:g" -i "${S}"/${MY_PD}-${MY_PDPV}.dfsg1/debian/patches/03_put_prefs_in_home_dir.diff
+ sed -i -e "s:${MY_PD}_${MY_PDPV}.dfsg1.hi.orig/:old-gr:g" -i "${S}"/${MY_PD}-${MY_PDPV}.dfsg1/debian/patches/gunroar-hot-iron.patch
+ sed -i -e "s:${MY_PD}_${MY_PDPV}.dfsg1.hi/:new-gr:g" -i "${S}"/${MY_PD}-${MY_PDPV}.dfsg1/debian/patches/gunroar-hot-iron.patch
+ epatch "${S}"/${MY_PD}-${MY_PDPV}.dfsg1/debian/patches/01_sdl_fix_imports.diff
+ epatch "${S}"/${MY_PD}-${MY_PDPV}.dfsg1/debian/patches/02_d_language_changes.diff
+ epatch "${S}"/${MY_PD}-${MY_PDPV}.dfsg1/debian/patches/04_adapt_build_file_to_linux.diff
+ epatch "${S}"/${MY_PD}-${MY_PDPV}.dfsg1/debian/patches/windowed.patch
+ epatch "${S}"/${MY_PD}-${MY_PDPV}.dfsg1/debian/patches/makefile.patch
+ epatch "${S}"/${MY_PD}-${MY_PDPV}.dfsg1/debian/patches/gdc-0.24-semantics-for-version.patch
+ epatch "${S}"/${MY_PD}-${MY_PDPV}.dfsg1/debian/patches/window-resizing.patch
+ epatch "${S}"/${MY_PD}-${MY_PDPV}.dfsg1/debian/patches/avoid-segfault-when-sdl-fails.patch
+ epatch "${FILESDIR}"/03_put_prefs_in_home_dir.diff
sed -i \
-e 's:"\(images/[^"]*\)":"'${GAMES_DATADIR}'/'${PN}'/\1":g' -i src/abagames/util/sdl/texture.d \
-e 's:"\(sounds/[^"]*\)":"'${GAMES_DATADIR}'/'${PN}'/\1":g' -i src/abagames/util/sdl/sound.d \
- -e 's:"\(gr.prf[^"]*\)":"'${GAMES_STATEDIR}'/'${PN}'/\1":g' -i src/abagames/gr/prefmanager.d \
|| die "sed failed"
}
src_install() {
dogamesbin ${PN}
- dodir "${GAMES_STATEDIR}/${PN}" "${GAMES_STATEDIR}/${PN}/replay"
- local statedir="${GAMES_STATEDIR}"/${PN}
-
- if [ ! -e ${D}"${GAMES_STATEDIR}"/${PN}/gr.prf ]; then
- touch ${D}"${GAMES_STATEDIR}"/${PN}/gr.prf
- chmod ug+rw ${D}"${GAMES_STATEDIR}"/${PN}/gr.prf
- fi
local datadir="${GAMES_DATADIR}"/${PN}
dodir ${datadir}
insinto "${GAMES_DATADIR}"/${PN}
doins -r images sounds || die
- newicon "${FILESDIR}"/${PN}.png ${PN}.png
+ newicon "${S}"/${MY_PD}-${MY_PDPV}.dfsg1/debian/${MY_PD}.xpm ${PN}.xpm
make_desktop_entry ${PN} ${PN}
dodoc readme*
prepgamesdirs