summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRomain Perier <mrpouet@gentoo.org>2009-08-21 11:30:57 +0200
committerRomain Perier <mrpouet@gentoo.org>2009-08-21 11:30:57 +0200
commit69aff8438c234152ffe354ef2b308adbc12d58a0 (patch)
tree68791a55491a9f92ab7d6e4bf14315aaba9a78e0 /games-action/gunroarhi/gunroarhi-0.30.ebuild
parent(devel/games-arcade/edgar) initial edgar-0.25.ebuild (diff)
downloadgamerlay-69aff8438c234152ffe354ef2b308adbc12d58a0.tar.gz
gamerlay-69aff8438c234152ffe354ef2b308adbc12d58a0.tar.bz2
gamerlay-69aff8438c234152ffe354ef2b308adbc12d58a0.zip
Moved devel/* to ./
Diffstat (limited to 'games-action/gunroarhi/gunroarhi-0.30.ebuild')
-rw-r--r--games-action/gunroarhi/gunroarhi-0.30.ebuild59
1 files changed, 59 insertions, 0 deletions
diff --git a/games-action/gunroarhi/gunroarhi-0.30.ebuild b/games-action/gunroarhi/gunroarhi-0.30.ebuild
new file mode 100644
index 0000000..0ccd94b
--- /dev/null
+++ b/games-action/gunroarhi/gunroarhi-0.30.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="2"
+
+inherit d-games
+
+MY_PN=gr_hi
+MY_PV=${PV//./_}
+
+DESCRIPTION="Guns, Guns, Guns! 360-degree gunboat shooter, fork of ABAs 'Gunroar'"
+HOMEPAGE="http://www.edit.ne.jp/~otoyan/soft/gr_hi.html"
+SRC_URI="http://www.edit.ne.jp/~otoyan/soft/gr_hi/${MY_PN}${MY_PV}.zip"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~ppc ~x86"
+IUSE=""
+
+RDEPEND="media-libs/libsdl
+ media-libs/mesa
+ media-libs/sdl-mixer"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/${MY_PN}
+
+src_prepare(){
+ epatch "${FILESDIR}"/${P}.diff
+ sed -i \
+ -e 's:"\(images/[^"]*\)":"'${GAMES_DATADIR}'/'${PN}'/\1":g' -i src/abagames/util/sdl/texture.d \
+ -e 's:"\(sounds/[^"]*\)":"'${GAMES_DATADIR}'/'${PN}'/\1":g' -i src/abagames/util/sdl/sound.d \
+ -e 's:"\(gr.prf[^"]*\)":"'${GAMES_STATEDIR}'/'${PN}'/\1":g' -i src/abagames/gr/prefmanager.d \
+ || die "sed failed"
+}
+
+src_install() {
+ dogamesbin ${PN}
+ dodir "${GAMES_STATEDIR}/${PN}" "${GAMES_STATEDIR}/${PN}/replay"
+ local statedir="${GAMES_STATEDIR}"/${PN}
+
+ if [ ! -e ${D}"${GAMES_STATEDIR}"/${PN}/gr.prf ]; then
+ touch ${D}"${GAMES_STATEDIR}"/${PN}/gr.prf
+ chmod ug+rw ${D}"${GAMES_STATEDIR}"/${PN}/gr.prf
+ fi
+
+ local datadir="${GAMES_DATADIR}"/${PN}
+ dodir ${datadir}
+ insinto "${GAMES_DATADIR}"/${PN}
+ doins -r images sounds || die
+ newicon "${FILESDIR}"/${PN}.png ${PN}.png
+ make_desktop_entry ${PN} ${PN}
+ dodoc readme*
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+}