summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVadim A. Misbakh-Soloviov <mva@mva.name>2013-06-15 19:52:17 +0700
committerVadim A. Misbakh-Soloviov <mva@mva.name>2013-06-15 19:52:17 +0700
commitb0b653a7c9a520a8a3a2f899dba1a7aee6b70dd0 (patch)
tree708ae6b19d038b3fc19d63a87cce15405426edd3 /games-action
parent[games-arcade/funkysmugglers] Added. (diff)
downloadgamerlay-b0b653a7c9a520a8a3a2f899dba1a7aee6b70dd0.tar.gz
gamerlay-b0b653a7c9a520a8a3a2f899dba1a7aee6b70dd0.tar.bz2
gamerlay-b0b653a7c9a520a8a3a2f899dba1a7aee6b70dd0.zip
[global/part] moving "unzip -q" to unpacker behaviour (preparation to eclass integration)
Signed-off-by: Vadim A. Misbakh-Soloviov <mva@mva.name>
Diffstat (limited to 'games-action')
-rw-r--r--games-action/shadowgrounds-bin/shadowgrounds-bin-1.ebuild10
-rw-r--r--games-action/shadowgrounds-survivor-bin/shadowgrounds-survivor-bin-1.ebuild10
2 files changed, 11 insertions, 9 deletions
diff --git a/games-action/shadowgrounds-bin/shadowgrounds-bin-1.ebuild b/games-action/shadowgrounds-bin/shadowgrounds-bin-1.ebuild
index 9dd0237..2c3ed4b 100644
--- a/games-action/shadowgrounds-bin/shadowgrounds-bin-1.ebuild
+++ b/games-action/shadowgrounds-bin/shadowgrounds-bin-1.ebuild
@@ -2,9 +2,9 @@
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/games-action/shadowgrounds-bin/shadowgrounds-bin-0_beta12.ebuild,v 1.2 2011/04/21 08:49:37 vapier Exp $
-EAPI="4"
+EAPI="5"
-inherit games eutils
+inherit unpacker games eutils
DESCRIPTION="an epic action experience combining modern technology with addictive playability"
HOMEPAGE="http://shadowgroundsgame.com/"
@@ -28,11 +28,11 @@ RDEPEND=">=sys-libs/glibc-2.4
REQUIRED_USE="amd64? ( multilib )"
-S=${WORKDIR}
+S="${WORKDIR}"
d="${GAMES_PREFIX_OPT}/${PN}"
QA_TEXTRELS_x86="`echo ${d#/}/lib32/lib{avcodec.so.51,avformat.so.52,avutil.so.49,FLAC.so.8}`"
-QA_TEXTRELS_amd64=${QA_TEXTRELS_x86}
+QA_TEXTRELS_amd64="${QA_TEXTRELS_x86}"
pkg_nofetch() {
einfo "Fetch ${SRC_URI} and put it into ${DISTDIR}"
@@ -41,7 +41,7 @@ pkg_nofetch() {
src_unpack() {
# manually run unzip as the initial seek causes it to exit(1)
- unzip -q "${DISTDIR}/${A}"
+ unpack_zip "${A}"
rm lib*/lib{gcc_s,m,rt,selinux}.so.?
}
diff --git a/games-action/shadowgrounds-survivor-bin/shadowgrounds-survivor-bin-1.ebuild b/games-action/shadowgrounds-survivor-bin/shadowgrounds-survivor-bin-1.ebuild
index 707081b..46c911c 100644
--- a/games-action/shadowgrounds-survivor-bin/shadowgrounds-survivor-bin-1.ebuild
+++ b/games-action/shadowgrounds-survivor-bin/shadowgrounds-survivor-bin-1.ebuild
@@ -2,7 +2,9 @@
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/games-action/shadowgrounds-survivor-bin/shadowgrounds-survivor-bin-0_beta11.ebuild,v 1.2 2011/04/21 08:50:11 vapier Exp $
-inherit games eutils
+EAPI="5"
+
+inherit unpacker games eutils
DESCRIPTION="human survivors who battle against the ongoing alien onslaught"
HOMEPAGE="http://shadowgroundsgame.com/survivor/"
@@ -24,11 +26,11 @@ RDEPEND=">=sys-libs/glibc-2.4
app-emulation/emul-linux-x86-gtklibs
)"
-S=${WORKDIR}
+S="${WORKDIR}"
d="${GAMES_PREFIX_OPT}/${PN}"
QA_TEXTRELS_x86="`echo ${d#/}/lib32/lib{avcodec.so.51,avformat.so.52,avutil.so.49,FLAC.so.8}`"
-QA_TEXTRELS_amd64=${QA_TEXTRELS_x86}
+QA_TEXTRELS_amd64="${QA_TEXTRELS_x86}"
pkg_nofetch() {
einfo "Fetch ${SRC_URI} and put it into ${DISTDIR}"
@@ -37,7 +39,7 @@ pkg_nofetch() {
src_unpack() {
# manually run unzip as the initial seek causes it to exit(1)
- unzip -q "${DISTDIR}/${A}"
+ unpack_zip "${A}"
rm lib*/lib{gcc_s,m,rt,selinux}.so.?
}