summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarcel Unbehaun <frostworks@gmx.de>2010-07-15 18:14:57 +0200
committerMarcel Unbehaun <frostworks@gmx.de>2010-07-15 18:14:57 +0200
commit6543e5c226280bc09c90a39f2f3b53485a74b9a4 (patch)
tree2db6d6e3a685cff8335d5a6c49c19c61284b4c35 /games-arcade/frogatto
parentFreeorion update deps (diff)
downloadgamerlay-6543e5c226280bc09c90a39f2f3b53485a74b9a4.tar.gz
gamerlay-6543e5c226280bc09c90a39f2f3b53485a74b9a4.tar.bz2
gamerlay-6543e5c226280bc09c90a39f2f3b53485a74b9a4.zip
[games-arcade/frogatto] initial frogatto-1.0.ebuild
[games-arcade/frogatto] new Manifest [games-arcade/frogatto] new metadata.xml
Diffstat (limited to 'games-arcade/frogatto')
-rw-r--r--games-arcade/frogatto/Manifest3
-rw-r--r--games-arcade/frogatto/frogatto-1.0.ebuild49
-rw-r--r--games-arcade/frogatto/metadata.xml5
3 files changed, 57 insertions, 0 deletions
diff --git a/games-arcade/frogatto/Manifest b/games-arcade/frogatto/Manifest
new file mode 100644
index 0000000..ccd277e
--- /dev/null
+++ b/games-arcade/frogatto/Manifest
@@ -0,0 +1,3 @@
+DIST frogatto-1.0.tar.bz2 136213969 RMD160 7e4443d99f7fa8f5328ef07b01c4167874189dd7 SHA1 e277bf4ffb49dce7c9c25a242f0b9c5073f5fa3b SHA256 7a3dab049df8d4cd38a4fa0ab98ea001d5bae1d373d134fbd4e773132fb68c59
+EBUILD frogatto-1.0.ebuild 1907 RMD160 69f0bbe7be7798e48edfc2af5bfc5bedd4f25d2c SHA1 18e2234562ed947e46f5a1c3766b0818073f4a54 SHA256 b1b66fd7a3262552a72fc36066edd9e0fc79d052cd117e3017f261927db5ab6b
+MISC metadata.xml 161 RMD160 734c72757bdba2e93d5c7cfa946fd9eb69e01681 SHA1 e721608e30cdca8dd809c1024687fe4887c49293 SHA256 5102a957a119374da719ca711f473e89fd4183d4e91e86f59e2fc4dce7e607dc
diff --git a/games-arcade/frogatto/frogatto-1.0.ebuild b/games-arcade/frogatto/frogatto-1.0.ebuild
new file mode 100644
index 0000000..056fe1b
--- /dev/null
+++ b/games-arcade/frogatto/frogatto-1.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: games-arcade/frogatto/frogatto-1.0.ebuild frostwork Exp $
+
+inherit eutils games flag-o-matic
+
+EAPI="2"
+
+DESCRIPTION="a frog, and a platform game"
+HOMEPAGE="http://frogatto.com/"
+SRC_URI="http://www.frogatto.com/files/${P}.tar.bz2"
+
+LICENSE="GPL-3 free-noncomm"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+
+DEPEND="media-libs/sdl-image
+ media-libs/libsdl
+ media-libs/sdl-mixer
+ media-libs/sdl-ttf
+ media-libs/glew
+ dev-libs/boost
+ virtual/opengl
+ virtual/glu"
+
+src_prepare(){
+ sed -i -e "s/-O2 -fno-inline-functions/${CFLAGS}/" Makefile || die
+ sed -i -e "s/-fno-inline-functions//" Makefile || die
+ sed -i -e "s/-Wnon-virtual-dtor//" Makefile || die
+ sed -i -e "s/-Wreturn-type//" Makefile || die
+ sed -i -e "s/-fthreadsafe-statics//" Makefile || die
+ sed -i -e "s/ccache//" Makefile || die
+ for i in `find src -name *.cpp`; do sed -i "$i" -e "s:.\/images/:"${GAMES_DATADIR}"/"${PN}"/images/:g"; done
+ for i in `find src -name *.cpp`; do sed -i "$i" -e "s:data/:"${GAMES_DATADIR}"/"${PN}"/data/:g"; done
+ for i in `find src -name *.cpp`; do sed -i "$i" -e "s:music/:"${GAMES_DATADIR}"/"${PN}"/music/:g"; done
+ for i in `find src -name *.cpp`; do sed -i "$i" -e "s:music_aac/:"${GAMES_DATADIR}"/"${PN}"/music_aac/:g"; done
+ for i in `find src -name *.cpp`; do sed -i "$i" -e "s:sounds/:"${GAMES_DATADIR}"/"${PN}"/sounds/:g"; done
+ for i in `find src -name *.cpp`; do sed -i "$i" -e "s:sounds_wav/:"${GAMES_DATADIR}"/"${PN}"/sounds_wav/:g"; done
+ for i in `find src -name *.cpp`; do sed -i "$i" -e "s:FreeMono.ttf:"${GAMES_DATADIR}"/"${PN}"/FreeMono.ttf:g"; done
+}
+
+src_install() {
+ newgamesbin game ${PN}
+ insinto "${GAMES_DATADIR}"/${PN}
+ doins -r data images music music_aac sounds sounds_wav FreeMono.ttf || die
+ newicon images/window-icon.png ${PN}.png
+ make_desktop_entry ${PN}
+ prepgamesdirs
+}
diff --git a/games-arcade/frogatto/metadata.xml b/games-arcade/frogatto/metadata.xml
new file mode 100644
index 0000000..4a5a466
--- /dev/null
+++ b/games-arcade/frogatto/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>playboys</herd>
+</pkgmetadata>