summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVadim A. Misbakh-Soloviov <mva@mva.name>2013-06-15 04:47:41 +0700
committerVadim A. Misbakh-Soloviov <mva@mva.name>2013-06-15 04:47:41 +0700
commit5e8730bd798f656e31e5007c447d56be7d447872 (patch)
tree316548d593fc8cb9c2dba1aa04d7535f6da429a3 /games-arcade
parent[games-puzzle/phlipple] Version bump to 0.8.5, added myself as maintainer. (diff)
downloadgamerlay-5e8730bd798f656e31e5007c447d56be7d447872.tar.gz
gamerlay-5e8730bd798f656e31e5007c447d56be7d447872.tar.bz2
gamerlay-5e8730bd798f656e31e5007c447d56be7d447872.zip
[games-arcade/capsized] bump+deps fix
Signed-off-by: Vadim A. Misbakh-Soloviov <mva@mva.name>
Diffstat (limited to 'games-arcade')
-rw-r--r--games-arcade/capsized/Manifest2
-rw-r--r--games-arcade/capsized/capsized-06102013.ebuild (renamed from games-arcade/capsized/capsized-05302013.ebuild)38
2 files changed, 23 insertions, 17 deletions
diff --git a/games-arcade/capsized/Manifest b/games-arcade/capsized/Manifest
index dc3cac1..b105788 100644
--- a/games-arcade/capsized/Manifest
+++ b/games-arcade/capsized/Manifest
@@ -1 +1 @@
-DIST capsized-05302013-bin 613175039 SHA256 539f06916b0ea75102b240848d20b4bf46491baacfd5165f0865cf9f7a717890 SHA512 a560400edd807270cc85952004f30bacbefbfb4bce8af6769463a37977895db818b3863304810eb871795e8117c451d8a00167bdcca18f47b8058c870da89599 WHIRLPOOL 99626972be1efe8c66f8e86645ec14310626bb3e013d95f4387e5ed4e94516f6cb9ae596c52740c7bf156f8b93282197599f370d33941890f822f4209b7b0660
+DIST capsized-06102013-bin 613154469 SHA256 7c4fc5186f386423665f182e47018f10950491ab61860c0493bea9194037a7e4 SHA512 dc8601e5f2efb3ffae61206a80a58340378cc1b016ccb549e82e247221493b9bd43d1844c23be5216e45e96f9ee38a52f64e082757e3d3df7db75ab820eebfd6 WHIRLPOOL 4897c1097ff545077524ca9ad57bf1943604e520a9027d89f703bae339788533e0b75d24b7914034da04a033c6bdc6a619ceed8862a8f3d901886b4460e6d38a
diff --git a/games-arcade/capsized/capsized-05302013.ebuild b/games-arcade/capsized/capsized-06102013.ebuild
index bad7f8e..26b286e 100644
--- a/games-arcade/capsized/capsized-05302013.ebuild
+++ b/games-arcade/capsized/capsized-06102013.ebuild
@@ -27,6 +27,9 @@ RDEPEND="
media-libs/openal
media-libs/libsdl:2
"
+# dev-dotnet/monogame # someday
+# dev-dotnet/monogame-theoraplay # someday
+# media-libs/sdl-mixer # when 2.0 tarball will be released
DOCS=( "Linux.README" )
@@ -50,31 +53,34 @@ src_unpack() {
}
src_install() {
- local arch;
- use x86 && arch=x86;
- use amd64 && arch=x86_64;
-
insinto "${GAMEDIR}"
- doins -r \
- Content \
- Properties \
- mono \
- "${MY_PN}.bmp" \
+ doins -r Content
+ doins "${MY_PN}.bmp" \
NePlusUltra.exe \
- *.dll *.config
+ FarseerPhysicsXNA.dll \
+ Lidgren.Network.dll \
+ MonoGame.Framework.dll \
+ ProjectMercury.dll \
+ 'SDL2#'.dll \
+ 'SDL2#'.dll.config \
+ 'TheoraPlay#'.dll \
+ 'TheoraPlay#'.dll.config
for lang in fr it es de; do
- use "linguas_${lang}" && doins "${lang}"
+ use "linguas_${lang}" && doins -r "${lang}"
done
- # Installing bundled sdl2-mixer, since it is still not released [hg only]
+ # Installing bundled sdl-mixer-2, since it is still not released as
+ # tarball [hg only].
+ # btw, can be inserted in ${GAMEDIR} without subdir.
+ #
+ # Also installing bundled theoraplay, since in is no such package in
+ # portage.
insinto "${GAMEDIR}/$(get_libdir)"
doins "$(get_libdir)/libSDL2_mixer-2.0.so.0"
+ doins "$(get_libdir)/libtheoraplay.so"
- exeinto "${GAMEDIR}"
- doexe "NePlusUltra.bin.${arch}"
-
- games_make_wrapper "${PN}" "./NePlusUltra.bin.${arch}" "${GAMEDIR}" "${GAMEDIR}/$(get_libdir)"
+ games_make_wrapper "${PN}" "mono ./NePlusUltra.exe" "${GAMEDIR}" "${GAMEDIR}/$(get_libdir)"
doicon "${FILESDIR}/${PN}.png"
make_desktop_entry "${PN}" "${MY_PN}" "${PN}"