summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAzamat H. Hackimov <azamat.hackimov@gmail.com>2012-06-20 01:18:18 +0600
committerAzamat H. Hackimov <azamat.hackimov@gmail.com>2012-06-20 01:18:18 +0600
commit6f3363a25c29a965fb866770091bace0b68f1fa2 (patch)
tree74f164cec276b26e02d41c1a722cf928e2092a5b /games-arcade
parent[games-util/terragear-cs-9999] add poco dep and increase SG dep (diff)
downloadgamerlay-6f3363a25c29a965fb866770091bace0b68f1fa2.tar.gz
gamerlay-6f3363a25c29a965fb866770091bace0b68f1fa2.tar.bz2
gamerlay-6f3363a25c29a965fb866770091bace0b68f1fa2.zip
[games-arcade/supermeatboy] A platformer where you play as an animated cube of meat.
Version from HIB V, based on ebuild from #396545 First try to use EAPI=4 for games. (Portage version: 2.1.10.49/git/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'games-arcade')
-rw-r--r--games-arcade/supermeatboy/Manifest3
-rw-r--r--games-arcade/supermeatboy/metadata.xml15
-rw-r--r--games-arcade/supermeatboy/supermeatboy-2012.06.07.ebuild59
3 files changed, 77 insertions, 0 deletions
diff --git a/games-arcade/supermeatboy/Manifest b/games-arcade/supermeatboy/Manifest
new file mode 100644
index 0000000..200734c
--- /dev/null
+++ b/games-arcade/supermeatboy/Manifest
@@ -0,0 +1,3 @@
+DIST supermeatboy-linux-06072012-bin 174416543 RMD160 6fb6b7746f5aa802abb3f036dc6ef5974a67374c SHA1 60ea7627832123987fb545322e82cc5ec5316588 SHA256 e244cc41652b528a025720b6f3405819177e289d672ac781a4a63cb8154c4905
+EBUILD supermeatboy-2012.06.07.ebuild 1337 RMD160 e4bb821030180ec98fdbe7a222b7f97ef4c25540 SHA1 ee8f4ef522957d16ce37a635020c69dff19a370c SHA256 5bcd5188bbc83bb044591640fd72b13e2f5e92eb494c169babe9523caac4829d
+MISC metadata.xml 484 RMD160 c8ee4f1a21b35513b6355b5c53d5b8a99776e547 SHA1 fae7c22a957155ee824d767068541713a7a8fa7e SHA256 2c28e4ed6c2a3b1c26ef9547175fca87c0d6ba8f91b7c07324a8ee4fe42123a9
diff --git a/games-arcade/supermeatboy/metadata.xml b/games-arcade/supermeatboy/metadata.xml
new file mode 100644
index 0000000..e1dbbcd
--- /dev/null
+++ b/games-arcade/supermeatboy/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+<email>azamat.hackimov@gmail.com</email>
+<name>Azamat H. Hackimov</name>
+</maintainer>
+<longdescription lang="en">
+A platformer where you play as an animated cube of meat
+</longdescription>
+<longdescription lang="ru">
+Платформер, в котором вы управляете мясным пацаном
+</longdescription>
+</pkgmetadata>
+
diff --git a/games-arcade/supermeatboy/supermeatboy-2012.06.07.ebuild b/games-arcade/supermeatboy/supermeatboy-2012.06.07.ebuild
new file mode 100644
index 0000000..7ab5819
--- /dev/null
+++ b/games-arcade/supermeatboy/supermeatboy-2012.06.07.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+
+inherit games versionator
+
+MY_PN=SuperMeatBoy
+MY_PV=$(version_format_string '${2}${3}${1}')
+
+DESCRIPTION="A platformer where you play as an animated cube of meat"
+HOMEPAGE="http://www.supermeatboy.com/"
+SRC_URI="${PN}-linux-${MY_PV}-bin"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE=""
+
+RESTRICT="fetch"
+
+DEPEND="app-arch/zip"
+RDEPEND="${DEPEND}
+ media-libs/openal
+ media-libs/libsdl"
+
+S="${WORKDIR}/data"
+GAMEDIR="${GAMES_PREFIX_OPT}/${PN}"
+
+pkg_nofetch() {
+ einfo "Please download ${A}"
+ einfo "from your personal page in Humble Indie Bundle site"
+ einfo "(http://www.humblebundle.com)"
+ einfo "and place it to ${DESTDIR}"
+}
+
+src_unpack() {
+ # self unpacking zip archive; unzip warns about the exe stuff
+ # (taken from lugaru ebuild)
+ local a=${DISTDIR}/${A}
+ echo ">>> Unpacking ${a} to ${PWD}"
+ unzip -q "${a}"
+ [ $? -gt 1 ] && die "unpacking failed"
+}
+
+src_install() {
+ insinto ${GAMEDIR}
+ doins -r resources Levels UserData buttonmap.cfg \
+ gameaudio.dat gamedata.dat locdb.txt
+ exeinto ${GAMEDIR}
+ newexe ${ARCH}/${MY_PN}-${ARCH} ${MY_PN}
+ games_make_wrapper ${PN} ./${MY_PN} ${GAMEDIR}
+ doicon ${PN}.png
+ make_desktop_entry ${PN} ${MY_PN} ${PN}
+ dodoc README-linux.txt
+
+ prepgamesdirs
+}