summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAzamat H. Hackimov <azamat.hackimov@gmail.com>2021-09-24 01:18:15 +0300
committerAzamat H. Hackimov <azamat.hackimov@gmail.com>2021-09-24 01:18:15 +0300
commitfef503515d33949c7b0ae6a63de8fba20eef86f0 (patch)
treea622c386d6630523949e77427757bcfb449645f4 /games-engines/openxcom/openxcom-1.0.0_p20210611.ebuild
parentmedia-sound/oaml: migrate to cmake.eclass (diff)
downloadgamerlay-fef503515d33949c7b0ae6a63de8fba20eef86f0.tar.gz
gamerlay-fef503515d33949c7b0ae6a63de8fba20eef86f0.tar.bz2
gamerlay-fef503515d33949c7b0ae6a63de8fba20eef86f0.zip
games-engines/openxcom: update version
Fixes running with newest dev-cpp/yaml-cpp Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Azamat H. Hackimov <azamat.hackimov@gmail.com>
Diffstat (limited to 'games-engines/openxcom/openxcom-1.0.0_p20210611.ebuild')
-rw-r--r--games-engines/openxcom/openxcom-1.0.0_p20210611.ebuild71
1 files changed, 0 insertions, 71 deletions
diff --git a/games-engines/openxcom/openxcom-1.0.0_p20210611.ebuild b/games-engines/openxcom/openxcom-1.0.0_p20210611.ebuild
deleted file mode 100644
index b4d2856..0000000
--- a/games-engines/openxcom/openxcom-1.0.0_p20210611.ebuild
+++ /dev/null
@@ -1,71 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit cmake git-r3
-
-DESCRIPTION="An open-source reimplementation of the popular UFO: Enemy Unknown"
-HOMEPAGE="http://openxcom.org/"
-# For translation files
-#SRC_URI="http://openxcom.org/git_builds/openxcom_git_master_2015_09_25_2120.zip"
-EGIT_REPO_URI="https://github.com/SupSuper/OpenXcom.git"
-EGIT_COMMIT=8d45159bf3e27d6aef62aff6035d9f6a59caf00b
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="debug doc"
-
-RDEPEND=">=dev-cpp/yaml-cpp-0.5.3
- media-libs/libsdl
- media-libs/sdl-gfx
- media-libs/sdl-image
- media-libs/sdl-mixer
- media-sound/timidity++"
-DEPEND="${RDEPEND}
- doc? ( app-doc/doxygen )"
-
-#S="${WORKDIR}/OpenXcom"
-
-DOCS=( README.md )
-
-src_prepare() {
- default
- sed -i -e "s:/man/man6:/share/man/man6:g" docs/CMakeLists.txt
- cmake_src_prepare
-}
-
-src_configure() {
- mycmakeargs=(
- "-DCMAKE_INSTALL_BINDIR=/usr/bin"
- "-DCMAKE_INSTALL_DATADIR=/usr/share"
- )
- cmake_src_configure
-}
-
-src_compile() {
- use doc && cmake_src_compile doxygen
- cmake_src_compile
-}
-
-src_install() {
- cmake_src_install
- use doc && dodoc -r "${CMAKE_BUILD_DIR}/docs/html/"
-
-# for i in "common" "standard/xcom1" "standard/xcom2" ; do
-# insinto "${GAMES_DATADIR}/${PN}/${i}/"
-# doins -r "../openxcom/${i}/Language/"
-# done
-# insinto "${GAMES_DATADIR}/${PN}/standard/xcom1/Language/"
-# doins -r "../openxcom/standard/xcom1/Language/"
-# insinto "${GAMES_DATADIR}/${PN}/standard/xcom2/Language/"
-# doins -r "../openxcom/standard/xcom2/Language/"
-}
-
-pkg_postinst() {
- elog "In order to play you need copy UFO or TFTD game data"
- elog "(GEODATA, GEOGRAPH, MAPS, ROUTES, SOUND, TERRAIN, UFOGRAPH,"
- elog "UFOINTRO, UNITS folders) to"
- elog "/usr/share/${PN}/UFO or /usr/share/${PN}/TFTD respectively."
-}