summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNikoli <nikoli@lavabit.com>2011-11-23 22:07:36 +0400
committerNikoli <nikoli@lavabit.com>2011-11-23 22:07:36 +0400
commit8cbf8f8ac5cdc3843ceb5ab215d677aced012a3d (patch)
tree5e32ac26601feb03ec90bb2ca2bbe0aa92fbcfe2 /games-fps
parent[games-action/voxatron] Fixing digest for voxatron (diff)
downloadgamerlay-8cbf8f8ac5cdc3843ceb5ab215d677aced012a3d.tar.gz
gamerlay-8cbf8f8ac5cdc3843ceb5ab215d677aced012a3d.tar.bz2
gamerlay-8cbf8f8ac5cdc3843ceb5ab215d677aced012a3d.zip
doom3-gpl: initial ebuild
(Portage version: 2.1.10.11/git/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'games-fps')
-rw-r--r--games-fps/doom3-gpl/ChangeLog10
-rw-r--r--games-fps/doom3-gpl/Manifest3
-rw-r--r--games-fps/doom3-gpl/doom3-gpl-9999.ebuild99
-rw-r--r--games-fps/doom3-gpl/metadata.xml9
4 files changed, 121 insertions, 0 deletions
diff --git a/games-fps/doom3-gpl/ChangeLog b/games-fps/doom3-gpl/ChangeLog
new file mode 100644
index 0000000..428c781
--- /dev/null
+++ b/games-fps/doom3-gpl/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for games-fps/doom3-gpl
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+*doom3-gpl-9999 (23 Nov 2011)
+
+ 23 Nov 2011; Nikoli <nikoli@lavabit.com> +doom3-gpl-9999.ebuild,
+ +metadata.xml:
+ initial ebuild
+
diff --git a/games-fps/doom3-gpl/Manifest b/games-fps/doom3-gpl/Manifest
new file mode 100644
index 0000000..0bef9c3
--- /dev/null
+++ b/games-fps/doom3-gpl/Manifest
@@ -0,0 +1,3 @@
+EBUILD doom3-gpl-9999.ebuild 1967 RMD160 4ed48993bb645bdd78196366dffca59cceb5cabf SHA1 27b6d3eb40b71e0dcd1d7277a36dccaf8077b1db SHA256 8d3f2826762caa742a425d41595d0c259e7a6467c13fb0e0469f101dcd6fc2ef
+MISC ChangeLog 253 RMD160 1abf8bc4b860356e1930be134aaae07827eee0b5 SHA1 4618a2dbd2ab2c868ac4d6b3b25fea3cf0c5cbdb SHA256 f107287db6e6455f53c9c228c603aa9a912233fda5706ddbd71564c451f54c96
+MISC metadata.xml 248 RMD160 2418fc56f477393d0e1091455ff5523b58c07a83 SHA1 834f92f9ff1f64ceaac6c39e835ea63873d03d51 SHA256 baa352e20702c6ad701749c41aa0a8cce9c1fc62511a96b9adefc42a788026ab
diff --git a/games-fps/doom3-gpl/doom3-gpl-9999.ebuild b/games-fps/doom3-gpl/doom3-gpl-9999.ebuild
new file mode 100644
index 0000000..1d5d5ce
--- /dev/null
+++ b/games-fps/doom3-gpl/doom3-gpl-9999.ebuild
@@ -0,0 +1,99 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="3"
+
+inherit scons-utils toolchain-funcs games git-2
+
+DESCRIPTION="3rd installment of the classic iD 3D first-person shooter"
+HOMEPAGE="https://github.com/TTimo/doom3.gpl"
+EGIT_REPO_URI="git://github.com/TTimo/doom3.gpl.git"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS=""
+IUSE="alsa debug dedicated opengl"
+
+RDEPEND="
+ opengl? (
+ virtual/opengl
+ alsa? ( media-libs/alsa-lib )
+ amd64? ( app-emulation/emul-linux-x86-xlibs[opengl] )
+ )
+"
+DEPEND="${RDEPEND}
+ sys-devel/m4
+"
+
+dir=$(games_get_libdir)/${PN}
+
+src_configure() {
+ S+="/neo"
+
+ myesconsargs=(
+ CC="$(tc-getCC)"
+ CXX="$(tc-getCXX)"
+ )
+ # FIXME build fails with JOBS=3
+ #JOBS="$(echo -j1 ${MAKEOPTS} | sed -r "s/.*(-j\s*|--jobs=)([0-9]+).*/\2/")"
+
+ if use debug; then
+ myesconsargs+=( BUILD="debug-all" )
+ else
+ myesconsargs+=( BUILD="release" )
+ fi
+
+ if use dedicated; then
+ if use opengl; then
+ myesconsargs+=( DEDICATED="2" )
+ else
+ myesconsargs+=( DEDICATED="1" )
+ fi
+ else
+ # TODO use EAPI4
+ use !opengl && die "Nothing to build"
+ myesconsargs+=( DEDICATED="0" )
+ fi
+
+ # FIXME needs 32-bit libz.a
+ myesconsargs+=( NOCURL="1" )
+}
+
+src_compile() {
+ escons
+}
+
+src_install() {
+ exeinto "${dir}"
+ doexe gamex86-base.so || die
+ doexe gamex86-d3xp.so || die
+
+ if use dedicated; then
+ doexe doomded.x86 || die
+ fi
+
+ if use opengl; then
+ doexe doom.x86 || die
+ doexe sys/linux/setup/image/openurl.sh || die
+ games_make_wrapper ${PN} ./doom.x86 "${dir}" "${dir}"
+ newicon sys/linux/setup/image/doom3.png ${PN}.png || die
+ make_desktop_entry ${PN} "Doom III GPL"
+ fi
+
+ prepgamesdirs
+
+ dodoc sys/linux/setup/image/README || die
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+
+ elog "You need to copy 'base' directory"
+ elog "from either your installation media or your hard drive to"
+ elog "${dir}/ before running the game."
+ echo
+ elog "To play the game, run:"
+ elog " ${PN}"
+ echo
+}
diff --git a/games-fps/doom3-gpl/metadata.xml b/games-fps/doom3-gpl/metadata.xml
new file mode 100644
index 0000000..b7d7b86
--- /dev/null
+++ b/games-fps/doom3-gpl/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>no-herd</herd>
+ <maintainer>
+ <email>nikoli@lavabit.com</email>
+ <name>Nikoli</name>
+ </maintainer>
+</pkgmetadata>