summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarcel Unbehaun <frostworks@gmx.de>2009-10-12 09:51:02 +0200
committerMarcel Unbehaun <frostworks@gmx.de>2009-10-12 09:51:02 +0200
commit03e25cc441eb2f516454a3d99ce3d05f13084c84 (patch)
tree1ce326adf8a953520a8823f3bff593d216d712c9 /games-puzzle/laserreaction/files/laserreaction-1.0-includes.patch
parent(games-arcade/prototype) initial wip prototype-1.0.ebuild (diff)
downloadgamerlay-03e25cc441eb2f516454a3d99ce3d05f13084c84.tar.gz
gamerlay-03e25cc441eb2f516454a3d99ce3d05f13084c84.tar.bz2
gamerlay-03e25cc441eb2f516454a3d99ce3d05f13084c84.zip
(games-puzzle/laserreaction) initial laserreaction-1.0.ebuild
(games-puzzle/laserreaction) newManifest (games-puzzle/laserreaction) new files/laserreaction-1.0-includes.patch (games-puzzle/laserreaction) new files/laserreaction-1.0-makefile.patch (games-puzzle/laserreaction) new files/laserreaction-1.0-misc.patch (games-puzzle/laserreaction) new files/laserreaction-1.0-sound.patch (games-puzzle/laserreaction) new metadata.xml
Diffstat (limited to 'games-puzzle/laserreaction/files/laserreaction-1.0-includes.patch')
-rw-r--r--games-puzzle/laserreaction/files/laserreaction-1.0-includes.patch55
1 files changed, 55 insertions, 0 deletions
diff --git a/games-puzzle/laserreaction/files/laserreaction-1.0-includes.patch b/games-puzzle/laserreaction/files/laserreaction-1.0-includes.patch
new file mode 100644
index 0000000..c48a7c3
--- /dev/null
+++ b/games-puzzle/laserreaction/files/laserreaction-1.0-includes.patch
@@ -0,0 +1,55 @@
+diff -Naur Font.cpp Font.cpp
+--- Font.cpp 2009-10-02 12:17:55.000000000 +0200
++++ Font.cpp 2009-10-02 12:28:33.000000000 +0200
+@@ -1,6 +1,7 @@
+ #include "Font.h"
+-#include <windows.h>
+-#include <gl/gl.h>
++//#include <windows.h>
++#include <GL/gl.h>
++#include <cstring>
+ Font::Font()
+ {
+ mScale = 1.0f;
+diff -Naur Game.h Game.h
+--- Game.h 2009-10-02 12:17:55.000000000 +0200
++++ Game.h 2009-10-02 12:26:36.000000000 +0200
+@@ -1,12 +1,12 @@
+ #pragma once
+-#include <sdl.h>
++#include <SDL/SDL.h>
+ #ifdef WIN32
+ #include <windows.h>
+ #endif
+-#include <gl/gl.h>
+-#include <il/il.h>
+-#include <il/ilu.h>
+-#include <il/ilut.h>
++#include <GL/gl.h>
++#include <IL/il.h>
++#include <IL/ilu.h>
++#include <IL/ilut.h>
+ #include "Timer.h"
+ #include "Button.h"
+ #include "FileIO.h"
+diff -Naur Main.cpp Main.cpp
+--- Main.cpp 2009-10-02 12:17:55.000000000 +0200
++++ Main.cpp 2009-10-02 12:26:47.000000000 +0200
+@@ -1,6 +1,6 @@
+ #include "Game.h"
+ #include <iostream>
+-#include <tchar.h>
++//#include <tchar.h>
+ /*=================================*/
+ /*= Main Entry =*/
+ /*=================================*/
+diff -Naur Timer.h Timer.h
+--- Timer.h 2009-10-02 12:17:55.000000000 +0200
++++ Timer.h 2009-10-02 12:26:12.000000000 +0200
+@@ -1,5 +1,5 @@
+ #pragma once
+-#include <sdl.h>
++#include <SDL/SDL.h>
+ class Timer
+ {
+ private: