summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVadim Misbakh-Soloviov <mva@gentoo.org>2023-04-17 01:10:46 +0700
committerVadim Misbakh-Soloviov <mva@gentoo.org>2023-04-17 01:10:58 +0700
commit46a076f749eb0101e6d39432e2f8da221e54d72d (patch)
treefeb7b05a5a1767defaaf6a8f92f7990a2452acff /games-puzzle
parent*/*: manifest regeneration, part 1. (diff)
downloadgamerlay-46a076f749eb0101e6d39432e2f8da221e54d72d.tar.gz
gamerlay-46a076f749eb0101e6d39432e2f8da221e54d72d.tar.bz2
gamerlay-46a076f749eb0101e6d39432e2f8da221e54d72d.zip
games-puzzle/phlipple: bump + add patch
TODO: make pre-release from svn tarball Closes: https://bugs.gentoo.org/900931 Signed-off-by: Vadim Misbakh-Soloviov <mva@gentoo.org>
Diffstat (limited to 'games-puzzle')
-rw-r--r--games-puzzle/phlipple/files/phlipple-0.8.5_bug857397.patch11
-rw-r--r--games-puzzle/phlipple/metadata.xml15
-rw-r--r--games-puzzle/phlipple/phlipple-0.8.5.ebuild16
3 files changed, 27 insertions, 15 deletions
diff --git a/games-puzzle/phlipple/files/phlipple-0.8.5_bug857397.patch b/games-puzzle/phlipple/files/phlipple-0.8.5_bug857397.patch
new file mode 100644
index 0000000..9f7b7ca
--- /dev/null
+++ b/games-puzzle/phlipple/files/phlipple-0.8.5_bug857397.patch
@@ -0,0 +1,11 @@
+--- a/src/engine.h 2023-03-12 18:12:42.957837900 +1100
++++ b/src/engine.h 2023-03-12 18:12:50.461155967 +1100
+@@ -44,7 +44,7 @@
+
+ #define VERTEX_DRAW_INNER_OFFSET 0.15f
+
+-char debugOutput[1024];
++extern char debugOutput[1024];
+
+ #include "renderstate.h"
+
diff --git a/games-puzzle/phlipple/metadata.xml b/games-puzzle/phlipple/metadata.xml
index 18da2d0..2703bce 100644
--- a/games-puzzle/phlipple/metadata.xml
+++ b/games-puzzle/phlipple/metadata.xml
@@ -1,12 +1,11 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<maintainer type="person">
-<email>azamat.hackimov@gmail.com</email>
-<name>Azamat H. Hackimov</name>
-</maintainer>
-<longdescription lang="en">
-An unique puzzle game with the goal to reduce a 3D shape to a single square
-</longdescription>
+ <maintainer type="person">
+ <email>azamat.hackimov@gmail.com</email>
+ <name>Azamat H. Hackimov</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">phlipple</remote-id>
+ </upstream>
</pkgmetadata>
-
diff --git a/games-puzzle/phlipple/phlipple-0.8.5.ebuild b/games-puzzle/phlipple/phlipple-0.8.5.ebuild
index 545c19a..cf1a88a 100644
--- a/games-puzzle/phlipple/phlipple-0.8.5.ebuild
+++ b/games-puzzle/phlipple/phlipple-0.8.5.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-inherit autotools eutils xdg-utils
+inherit autotools xdg-utils
DESCRIPTION="An unique puzzle game with the goal to reduce a 3D shape to a single square"
HOMEPAGE="http://phlipple.sourceforge.net/"
@@ -12,19 +12,21 @@ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
-DEPEND="media-libs/libsdl:0
+DEPEND="
+ media-libs/libsdl:0
media-libs/sdl-image:0
media-libs/sdl-mixer:0
media-libs/sdl-ttf:0
virtual/opengl
- virtual/glu"
+ virtual/glu
+"
src_prepare() {
default
- # fix fails to link on new glibc
eapply "${FILESDIR}/${P}_check-math-lib.patch"
+ # fix fails to link on new glibc
+ eapply "${FILESDIR}/${P}_bug857397.patch"
eautoreconf
}