summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVadim A. Misbakh-Soloviov <mva@mva.name>2013-03-15 11:51:31 +0700
committerVadim A. Misbakh-Soloviov <mva@mva.name>2013-03-15 11:51:31 +0700
commit78bd057b91711e5d44b9333b198f648be04c19ee (patch)
tree80103550de78b8083f6c34528719dd6739cff2b8 /games-puzzle
parent[media-libs/libsdl] 7001 revision for Steam dependency. (diff)
downloadgamerlay-78bd057b91711e5d44b9333b198f648be04c19ee.tar.gz
gamerlay-78bd057b91711e5d44b9333b198f648be04c19ee.tar.bz2
gamerlay-78bd057b91711e5d44b9333b198f648be04c19ee.zip
[games-puzzle/spirits] added. TODO: unbundle SDL2
Signed-off-by: Vadim A. Misbakh-Soloviov <mva@mva.name>
Diffstat (limited to 'games-puzzle')
-rw-r--r--games-puzzle/spirits/Manifest1
-rw-r--r--games-puzzle/spirits/spirits-1.0.1.ebuild64
2 files changed, 65 insertions, 0 deletions
diff --git a/games-puzzle/spirits/Manifest b/games-puzzle/spirits/Manifest
new file mode 100644
index 0000000..8e84010
--- /dev/null
+++ b/games-puzzle/spirits/Manifest
@@ -0,0 +1 @@
+DIST spirits-linux-1.0.1_120903-1348705231.zip 84213977 SHA256 7c3b19c3cc85f968a7b72e0b9360353cb21dacd698fdac26f1f685fd2e02329c SHA512 33396f0a059c584714783a33a3acaafbab0b1d31f6077420961a19b790da633c3fad1a2b52f962f09a67af16a34ff72ee218c830aa6cf240eccf64311221f528 WHIRLPOOL 2af78a8152e8a134f0379c0d939ffc746c557fcaf79aa27f98615edf5b2d011c790c921a1c9e382e4ba7295b7446d326cdcbeb5529624f3f0d0b2357107d86ea
diff --git a/games-puzzle/spirits/spirits-1.0.1.ebuild b/games-puzzle/spirits/spirits-1.0.1.ebuild
new file mode 100644
index 0000000..f4235ac
--- /dev/null
+++ b/games-puzzle/spirits/spirits-1.0.1.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: games-puzzle/kinetris/kinetris-1.0.0b_pre5.ebuild frostwork Exp $
+
+EAPI="5"
+MY_PN="Spirits"
+
+inherit games
+
+DESCRIPTION="a tetrominoes game (i.e.: a Tetris clone) that uses the Xbox 360 Kinect"
+HOMEPAGE="http://www.spacesofplay.com/spirits/"
+SRC_URI="${PN}-linux-${PV}_120903-1348705231.zip"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+ media-libs/openal
+"
+# media-libs/libsdl:2 #somewhy doesn't work with all latest versions of SDL2 in overlay
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_PN}"
+
+src_install() {
+ local libdir binary
+ GAMEDIR="${GAMES_PREFIX_OPT}/${MY_PN}"
+
+ use amd64 && {
+# TODO: unbundling SDL2
+ libdir=x86_64
+ binary=Spirits-64
+ }
+
+ use x86 && {
+# TODO: unbundling SDL2
+ libdir=i686
+ binary=Spirits-32
+ }
+
+ dodoc README.TXT
+
+ rm "./${libdir}/libopenal.so.1"
+
+ exeinto "${GAMEDIR}"
+ insinto "${GAMEDIR}"
+ doins -r data
+# TODO: unbundling SDL2
+ doins -r "${libdir}"
+ doexe "${binary}"
+
+ # install shortcuts
+ games_make_wrapper "${PN}" "./${binary}" "${GAMEDIR}" "${GAMEDIR}/${libdir}" || die "install shortcut"
+ make_desktop_entry "${PN}" "${MY_PN}" "${PN}"
+
+ prepgamesdirs
+}
+
+pkg_postinstall() {
+ einfo "If pre-start dialog looks ugly for you, try to remove ~/.themes"
+ einfo "At least, it helped me in such situation."
+} \ No newline at end of file