summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2014-03-09 22:09:14 +0400
committerSergey Popov <pinkbyte@gentoo.org>2014-03-09 22:09:14 +0400
commit0af49d5a016213c7507ff488717daa8c31202b7d (patch)
tree228347ddcc1d2e4cd9ff34c32f8e26a152768952 /games-rpg
parentunpacker-nixstaller.eclass: fix handling of LZMA tarballs with new sys-apps/file (diff)
downloadgamerlay-0af49d5a016213c7507ff488717daa8c31202b7d.tar.gz
gamerlay-0af49d5a016213c7507ff488717daa8c31202b7d.tar.bz2
gamerlay-0af49d5a016213c7507ff488717daa8c31202b7d.zip
games-rpg/torchlight: version bump
Diffstat (limited to 'games-rpg')
-rw-r--r--games-rpg/torchlight/Manifest1
-rw-r--r--games-rpg/torchlight/torchlight-1.15.20130521.ebuild113
2 files changed, 114 insertions, 0 deletions
diff --git a/games-rpg/torchlight/Manifest b/games-rpg/torchlight/Manifest
index a105d24..ef1d974 100644
--- a/games-rpg/torchlight/Manifest
+++ b/games-rpg/torchlight/Manifest
@@ -1 +1,2 @@
DIST Torchlight-2012-09-26.sh 471953450 SHA256 bcc7d5baf4a08d1336fe5fb46e642a1a8724803a3c8045c846e26ef0a68e8f09 SHA512 3413921d900bc39f877d4ecefb189fa532886616edb05eac2ffc38f60d248a9496c6ad3e91b346527c3280b1ca9f90bc71898da841014c6e47ef7234cc88823d WHIRLPOOL c236eb77642a148241834772650ecf9e57702ed0e25f0fe68dc383f7473d5c9d1f8a6d1b999bf359ba271bef684154afbfebeaa126b599dc6caa431a7fe3eb6f
+DIST Torchlight-2013-05-21.sh 468456344 SHA256 8503cc8e8100b3ea48cf8fd7dc294c414ff3d9b725322aa2dec02f5b3fff0667 SHA512 24ffc572cedb4a6f547bfec2ff13e316a23e83e4a0222e87064eec775815edcaec6ea9127bcfd82afb6eb270be170383ddc64442c10487c05e529ecc0939d3c5 WHIRLPOOL bcc937cc6c40de5db33a220f982db293fa1a6d47abef3507a378fccda1141242502a78e714e856506f32fa85e65ecb05aade57419bc1a11aafd8061606def423
diff --git a/games-rpg/torchlight/torchlight-1.15.20130521.ebuild b/games-rpg/torchlight/torchlight-1.15.20130521.ebuild
new file mode 100644
index 0000000..72f580f
--- /dev/null
+++ b/games-rpg/torchlight/torchlight-1.15.20130521.ebuild
@@ -0,0 +1,113 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="5"
+
+inherit games multilib unpacker-nixstaller
+
+TIMESTAMP="2013-05-21"
+
+DESCRIPTION="An action role-playing game, made by the creators of Diablo"
+HOMEPAGE="http://torchlightgame.com/"
+
+SLOT="0"
+LICENSE="as-is"
+KEYWORDS="-* ~amd64 ~x86"
+RESTRICT="fetch"
+
+SRC_URI="Torchlight-${TIMESTAMP}.sh"
+
+RDEPEND="app-arch/bzip2
+ app-arch/xz-utils
+ dev-libs/expat
+ dev-libs/zziplib
+ media-libs/fontconfig
+ media-libs/freeimage
+ media-libs/freetype
+ media-libs/ilmbase
+ media-libs/lcms
+ media-libs/libjpeg-turbo
+ media-libs/libpng
+ media-libs/libraw
+ media-libs/openexr
+ media-libs/openjpeg
+ media-libs/tiff
+ sys-apps/util-linux
+ sys-libs/zlib
+ x11-libs/libdrm
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libX11
+ x11-libs/libXau
+ x11-libs/libXaw
+ x11-libs/libxcb
+ x11-libs/libXdamage
+ x11-libs/libXdmcp
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libXft
+ x11-libs/libXi
+ x11-libs/libXinerama
+ x11-libs/libXmu
+ x11-libs/libXpm
+ x11-libs/libXrandr
+ x11-libs/libXrender
+ x11-libs/libXt
+ x11-libs/libXxf86vm"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}"
+MY_PN="Torchlight"
+
+QA_PRESTRIPPED="
+opt/torchlight/lib64/*
+opt/torchlight/lib/*
+"
+
+pkg_nofetch() {
+ ewarn
+ ewarn "Place ${A} to ${DISTDIR}"
+ ewarn
+}
+
+src_unpack() {
+ local arch;
+ use x86 && arch="x86"
+ use amd64 && arch="x86_64"
+
+ nixstaller_unpack "subarch" \
+ "instarchive_all" \
+ "instarchive_linux_${arch}" \
+ "deps/Ogre/Ogre_files_linux_${arch}" \
+ "deps/fmod/fmod_files_linux_${arch}" \
+ "deps/pcre/pcre_files_linux_${arch}" \
+ "deps/SDL2/SDL2_files_linux_${arch}" \
+ "deps/CEGUI/CEGUI_files_linux_${arch}"
+ # We just installed some crap to avoid broken depends
+}
+
+src_install() {
+ local dir="${GAMES_PREFIX_OPT}/${PN}"
+
+ insinto "${dir}"
+ doins -r icons music logo.bmp pak.zip resources.cfg "$(get_libdir)"
+ exeinto "${dir}"
+
+ local exe
+ if use amd64 ; then
+ exe="${MY_PN}".bin.x86_64
+ fi
+ if use x86 ; then
+ exe="${MY_PN}".bin.x86
+ fi
+
+ doexe "${exe}"
+
+ games_make_wrapper "${PN}" "./${exe}" "${dir}" "${dir}/$(get_libdir)"
+ doicon "${MY_PN}.png" || die
+ make_desktop_entry "${PN}" "${MY_PN}" "${MY_PN}"
+
+ dodoc README.linux
+ prepgamesdirs
+}