summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVadim A. Misbakh-Soloviov <mva@mva.name>2013-04-22 11:59:46 +0700
committerVadim A. Misbakh-Soloviov <mva@mva.name>2013-04-22 11:59:46 +0700
commita6b8785d63a324def25cf791f24d63e4ee51d3df (patch)
tree7468eb66ac9fbb75abde2d87a5543c79eebf5459 /games-sports/stuntrally
parent[games-fps/brutal-doom] New version 0.18a. (diff)
downloadgamerlay-a6b8785d63a324def25cf791f24d63e4ee51d3df.tar.gz
gamerlay-a6b8785d63a324def25cf791f24d63e4ee51d3df.tar.bz2
gamerlay-a6b8785d63a324def25cf791f24d63e4ee51d3df.zip
[games-sports/stuntrally{,-tracks}] Added
Signed-off-by: Vadim A. Misbakh-Soloviov <mva@mva.name>
Diffstat (limited to 'games-sports/stuntrally')
-rw-r--r--games-sports/stuntrally/Manifest1
-rw-r--r--games-sports/stuntrally/metadata.xml14
-rw-r--r--games-sports/stuntrally/stuntrally-1.9.ebuild63
-rw-r--r--games-sports/stuntrally/stuntrally-9999.ebuild63
4 files changed, 141 insertions, 0 deletions
diff --git a/games-sports/stuntrally/Manifest b/games-sports/stuntrally/Manifest
new file mode 100644
index 0000000..958792b
--- /dev/null
+++ b/games-sports/stuntrally/Manifest
@@ -0,0 +1 @@
+DIST StuntRally-1.9-sources.tar.xz 394374672 SHA256 dfd036c66ec9b7df4f5e3a7aa664dcc4860ebfaeedfb5c16eb6c999b4fa1715e SHA512 008871538eba089d17c9b10eec485751f180e2c488565887e04455a9fe7a4b6b010b9ea9c30d7183e15192a5cca9ea6b5f44c61857f358c94938678cbaab8245 WHIRLPOOL eef07267d42fdad0f835a1bfd15e96eda6ef0f088218c7b5b0e80df7ac311940ee0f42a8859653b6e68d142c72798fd4313c1e2623e0753d49eb10a1130e63e1
diff --git a/games-sports/stuntrally/metadata.xml b/games-sports/stuntrally/metadata.xml
new file mode 100644
index 0000000..23da526
--- /dev/null
+++ b/games-sports/stuntrally/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+ <email>mva@mva.name</email>
+ <description>
+ If you have any issues, please contact me, or try to find me in IRC on Freenode, OFTC or RusNet.
+ </description>
+ <name>Vadim A. Misbakh-Soloviov</name>
+</maintainer>
+<longdescription>FIXME</longdescription>
+<use>
+</use>
+</pkgmetadata>
diff --git a/games-sports/stuntrally/stuntrally-1.9.ebuild b/games-sports/stuntrally/stuntrally-1.9.ebuild
new file mode 100644
index 0000000..dae502b
--- /dev/null
+++ b/games-sports/stuntrally/stuntrally-1.9.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="5"
+
+[[ ${PV} = 9999* ]] && GIT="git-2"
+
+inherit games cmake-utils ${GIT}
+
+DESCRIPTION="Rally game focused on closed rally tracks with possible stunt elements (jumps, loops, pipes)."
+HOMEPAGE="http://code.google.com/p/vdrift-ogre/"
+
+SLOT="0"
+LICENSE="GPL3"
+IUSE="dedicated +game editor"
+
+if [[ ${PV} = 9999* ]]; then
+ SRC_URI=""
+ KEYWORDS=""
+ EGIT_REPO_URI="https://github.com/stuntrally/stuntrally"
+ LIVE_PDEPEND="=${CATEGORY}/${PN}-tracks-${PV}"
+else
+ MY_P="StuntRally-${PV}-sources"
+ KEYWORDS="~amd64 ~x86"
+ SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.xz"
+ S="${WORKDIR}/${MY_P}"
+fi
+
+RDEPEND="
+ game? (
+ dev-games/ogre[cg,boost,ois,freeimage,opengl,zip]
+ dev-games/mygui
+ media-libs/libsdl:0
+ media-libs/libvorbis
+ media-libs/libogg
+ )
+ dev-libs/boost
+ net-libs/enet:1.3
+ virtual/libstdc++
+ sys-devel/gcc
+"
+DEPEND="${RDEPEND}"
+PDEPEND="${LIVE_PDEPEND}"
+
+REQUIRED_USE="editor? ( game )"
+
+DOCS=( Readme.txt )
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_build dedicated MASTER_SERVER)
+ $(cmake-utils_use_build game GAME)
+ $(cmake-utils_use_build editor EDITOR)
+ )
+ cmake-utils_src_configure
+}
+
+
+src_install() {
+ cmake-utils_src_install
+ prepgamesdirs
+}
diff --git a/games-sports/stuntrally/stuntrally-9999.ebuild b/games-sports/stuntrally/stuntrally-9999.ebuild
new file mode 100644
index 0000000..dae502b
--- /dev/null
+++ b/games-sports/stuntrally/stuntrally-9999.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="5"
+
+[[ ${PV} = 9999* ]] && GIT="git-2"
+
+inherit games cmake-utils ${GIT}
+
+DESCRIPTION="Rally game focused on closed rally tracks with possible stunt elements (jumps, loops, pipes)."
+HOMEPAGE="http://code.google.com/p/vdrift-ogre/"
+
+SLOT="0"
+LICENSE="GPL3"
+IUSE="dedicated +game editor"
+
+if [[ ${PV} = 9999* ]]; then
+ SRC_URI=""
+ KEYWORDS=""
+ EGIT_REPO_URI="https://github.com/stuntrally/stuntrally"
+ LIVE_PDEPEND="=${CATEGORY}/${PN}-tracks-${PV}"
+else
+ MY_P="StuntRally-${PV}-sources"
+ KEYWORDS="~amd64 ~x86"
+ SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.xz"
+ S="${WORKDIR}/${MY_P}"
+fi
+
+RDEPEND="
+ game? (
+ dev-games/ogre[cg,boost,ois,freeimage,opengl,zip]
+ dev-games/mygui
+ media-libs/libsdl:0
+ media-libs/libvorbis
+ media-libs/libogg
+ )
+ dev-libs/boost
+ net-libs/enet:1.3
+ virtual/libstdc++
+ sys-devel/gcc
+"
+DEPEND="${RDEPEND}"
+PDEPEND="${LIVE_PDEPEND}"
+
+REQUIRED_USE="editor? ( game )"
+
+DOCS=( Readme.txt )
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_build dedicated MASTER_SERVER)
+ $(cmake-utils_use_build game GAME)
+ $(cmake-utils_use_build editor EDITOR)
+ )
+ cmake-utils_src_configure
+}
+
+
+src_install() {
+ cmake-utils_src_install
+ prepgamesdirs
+}