summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAzamat H. Hackimov <azamat.hackimov@gmail.com>2020-03-04 01:49:19 +0300
committerAzamat H. Hackimov <azamat.hackimov@gmail.com>2020-03-04 01:49:19 +0300
commitc7ca20eeeed4dcf5b1e25b0622c6d0335d891ffc (patch)
tree402ff0a67ea9a395f894e77f1b865e7bea07909f /games-strategy
parentgames-strategy/swordsandsoldiers: update package (diff)
downloadgamerlay-c7ca20eeeed4dcf5b1e25b0622c6d0335d891ffc.tar.gz
gamerlay-c7ca20eeeed4dcf5b1e25b0622c6d0335d891ffc.tar.bz2
gamerlay-c7ca20eeeed4dcf5b1e25b0622c6d0335d891ffc.zip
games-strategy/vcmi: minor fixes
Removed live ebuild Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Azamat H. Hackimov <azamat.hackimov@gmail.com>
Diffstat (limited to 'games-strategy')
-rw-r--r--games-strategy/vcmi/metadata.xml8
-rw-r--r--games-strategy/vcmi/vcmi-0.99.ebuild5
-rw-r--r--games-strategy/vcmi/vcmi-9999.ebuild81
3 files changed, 10 insertions, 84 deletions
diff --git a/games-strategy/vcmi/metadata.xml b/games-strategy/vcmi/metadata.xml
new file mode 100644
index 0000000..0fbb816
--- /dev/null
+++ b/games-strategy/vcmi/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<use>
+<flag name="erm">Enable compilation of ERM scripting module</flag>
+<flag name="launcher">Enable launcer support</flag>
+</use>
+</pkgmetadata>
diff --git a/games-strategy/vcmi/vcmi-0.99.ebuild b/games-strategy/vcmi/vcmi-0.99.ebuild
index bf28be7..82ccb57 100644
--- a/games-strategy/vcmi/vcmi-0.99.ebuild
+++ b/games-strategy/vcmi/vcmi-0.99.ebuild
@@ -1,6 +1,5 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-# $Header: $
EAPI=7
@@ -12,7 +11,7 @@ SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~x86 ~amd64"
+KEYWORDS="~amd64 ~x86"
IUSE="+debug erm +launcher"
CDEPEND="
diff --git a/games-strategy/vcmi/vcmi-9999.ebuild b/games-strategy/vcmi/vcmi-9999.ebuild
deleted file mode 100644
index ce5f4b0..0000000
--- a/games-strategy/vcmi/vcmi-9999.ebuild
+++ /dev/null
@@ -1,81 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-EAPI=5
-
-inherit eutils games cmake-utils git-r3
-
-DESCRIPTION="Heroes of Might and Magic III game engine rewrite"
-HOMEPAGE="http://forum.vcmi.eu/index.php"
-SRC_URI=""
-EGIT_REPO_URI="https://github.com/${PN}/${PN}"
-EGIT_BRANCH="develop"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS=""
-IUSE="debug editor launcher +erm"
-
-CDEPEND="
- media-libs/libsdl2[video]
- media-libs/sdl2-image
- media-libs/sdl2-mixer
- media-libs/sdl2-ttf
- virtual/ffmpeg
- sys-libs/zlib[minizip]
- editor? (
- dev-qt/qtgui
- dev-qt/qtcore
- dev-qt/qtwidgets
- )
- launcher? (
- dev-qt/qtgui
- dev-qt/qtcore
- dev-qt/qtnetwork
- dev-qt/qtwidgets
- )
- dev-libs/fuzzylite
-"
-
-DEPEND="
- >dev-libs/boost-1.48.0
- virtual/pkgconfig
- ${CDEPEND}
-"
-RDEPEND="
- ${CDEPEND}
-"
-PDEPEND="
- games-strategy/vcmi-data
-"
-
-src_configure() {
- local MY_DATADIR="${GAMES_DATADIR#/usr/}/${PN}"
- local MY_GAMESLIBDIR=$(games_get_libdir)
- local MY_LIBDIR=${MY_GAMESLIBDIR#/usr/}
- local MY_BINDIR=${GAMES_BINDIR#/usr/}
-
- use editor && ewarn "Editor seems to be broken. At least, it fails to build for me"
- use debug || ewarn "Somewhy, buildsystem don't want to use cotire (compile time reducer) generated pch (precompiled header) with disabled debug, so, you will see the warnings on each target."
-
- local mycmakeargs=(
- -DDATA_DIR="${MY_DATADIR}"
- -DLIB_DIR="${MY_LIBDIR}"
- -DBIN_DIR="${MY_BINDIR}"
- $(cmake-utils_use_enable erm ERM)
- $(cmake-utils_use_enable editor EDITOR)
- $(cmake-utils_use_enable launcher LAUNCHER)
- )
- export CCACHE_SLOPPINESS="time_macros"
- cmake-utils_src_configure
-}
-
-src_install() {
- cmake-utils_src_install
- prepgamesdirs
-}
-
-pkg_postinst() {
- games_pkg_postinst
-}