summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLocke Shinseiko <wizzleby@gmail.com>2010-08-15 16:10:56 -0400
committerLocke Shinseiko <wizzleby@gmail.com>2010-08-15 16:10:56 -0400
commit1cb3175f01ad67e96dbbd3811a6c70f0dcedfda8 (patch)
tree07a0decd59ccff169f61017c595594ef3d0e9505 /games-util
parent[games-util/nforenum] Bump 4.0.0_rc1 to released 4.0.0. (diff)
downloadgamerlay-1cb3175f01ad67e96dbbd3811a6c70f0dcedfda8.tar.gz
gamerlay-1cb3175f01ad67e96dbbd3811a6c70f0dcedfda8.tar.bz2
gamerlay-1cb3175f01ad67e96dbbd3811a6c70f0dcedfda8.zip
[games-util/grfcodec] Bump 1.0.0_rc1 to released 1.0.0.
Diffstat (limited to 'games-util')
-rw-r--r--games-util/grfcodec/Manifest4
-rw-r--r--games-util/grfcodec/grfcodec-1.0.0.ebuild (renamed from games-util/grfcodec/grfcodec-1.0.0_rc1.ebuild)30
2 files changed, 23 insertions, 11 deletions
diff --git a/games-util/grfcodec/Manifest b/games-util/grfcodec/Manifest
index 6b4eeac..ac7f437 100644
--- a/games-util/grfcodec/Manifest
+++ b/games-util/grfcodec/Manifest
@@ -1,4 +1,4 @@
-DIST grfcodec-1.0.0-RC1-source.tar.gz 81186 RMD160 fd2d20060f42d4c3ad43c3f8fcda2e760f434a92 SHA1 1a4c0451f589c39516c478e0907dfb0aff593c94 SHA256 ea39c8c4dbee81201669dc24302f8c8769c6a5fb4052a044efd081622cd09b30
-EBUILD grfcodec-1.0.0_rc1.ebuild 1078 RMD160 4e2bc4faaae54dbb621379a2245914e32b4dacac SHA1 f0d9d2c862fdf1f46570d2d28dd57f4b0cccf14f SHA256 3694396aa5a748dc2ba29cf259d54126f8468157e6c41e84031fb4aa8c5f4467
+DIST grfcodec-1.0.0-source.tar.gz 81382 RMD160 3e7f4751dae021d85dd60da37074ac11921b6362 SHA1 e022d6a57317602c4b61b7509d277b4153bff532 SHA256 477ec50682f4e904b4d920d0586e5357541630afe1a5f4876f999f96d025abda
+EBUILD grfcodec-1.0.0.ebuild 1154 RMD160 1d0cfa734f4f97d7dfd6b0056ff37526b7a45a79 SHA1 56ec73a75d93886234a35eab4b0a108d032622c1 SHA256 c4274a119aacf8bb52853a7f7b45ba71eeacb3d3e54a5361f330032edd1bd1a0
EBUILD grfcodec-9999.ebuild 1131 RMD160 985dd865b7cf30c101cf60261b69519b1c8493d5 SHA1 83c381a6d9160c43fa5ca2d9cc7e17d9711a0425 SHA256 dee6a9c126dfcfb6acbe7a8668bcddd40df887fd06f5386ed5f626e4073aab1f
MISC metadata.xml 158 RMD160 cbd9984bb6b426c8c9cee5022fe0a26261612fea SHA1 be5251fa1dacef5c41b74761bb1c8c54fb633b9e SHA256 1423a4fdd4a79b1728a2056d9e300f7e1074253095d82726218d9e9b953888a3
diff --git a/games-util/grfcodec/grfcodec-1.0.0_rc1.ebuild b/games-util/grfcodec/grfcodec-1.0.0.ebuild
index 8ca1fca..fa0bc8c 100644
--- a/games-util/grfcodec/grfcodec-1.0.0_rc1.ebuild
+++ b/games-util/grfcodec/grfcodec-1.0.0.ebuild
@@ -2,35 +2,47 @@
# Distributed under the terms of the GNU General Public License v2
# $Header: $
-EAPI=2
-inherit toolchain-funcs
+EAPI=3
+
+SCM=""
+if [ "${PV%9999}" != "${PV}" ] ; then
+ SCM=mercurial
+ EHG_REPO_URI="http://hg.openttdcoop.org/${PN}"
+fi
+
+inherit toolchain-funcs ${SCM}
MY_PV=${PV/_rc/-RC}
DESCRIPTION="A suite of programs to modify openttd/Transport Tycoon Deluxe's GRF files"
HOMEPAGE="http://dev.openttdcoop.org/projects/grfcodec"
-SRC_URI="http://binaries.openttd.org/extra/${PN}/${MY_PV}/${PN}-${MY_PV}-source.tar.gz"
+
+if [ "${PV%9999}" != "${PV}" ] ; then
+ SRC_URI=""
+else
+ SRC_URI="http://binaries.openttd.org/extra/${PN}/${MY_PV}/${PN}-${MY_PV}-source.tar.gz"
+fi
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
IUSE=""
-S=${WORKDIR}/${PN}-${MY_PV}-source
+if [ "${PV%9999}" != "${PV}" ] ; then
+ S=${WORKDIR}/${PN}
+else
+ S=${WORKDIR}/${PN}-${MY_PV}-source
+fi
DEPEND="dev-lang/perl
dev-libs/boost"
RDEPEND=""
src_prepare() {
-# workaround upstream workflow by setting CC to the C++ compiler and CFLAGS to ${CXXFLAGS}
-# This is actually what they do in Makefile now, we set CC = $(tc-getCC) previously.
+# Set up Makefile.local so that we respect CXXFLAGS/LDFLAGS
cat > Makefile.local <<-__EOF__
- CC = $(tc-getCXX)
CXX = $(tc-getCXX)
- CFLAGS = ${CXXFLAGS}
CXXFLAGS = ${CXXFLAGS}
LDOPT = ${LDFLAGS}
- STRIP = :
UPX =
V = 1
__EOF__