summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--games-puzzle/cubosphere/Manifest4
-rw-r--r--games-puzzle/cubosphere/cubosphere-0.2.ebuild (renamed from games-puzzle/cubosphere/cubosphere-0.1.ebuild)7
2 files changed, 8 insertions, 3 deletions
diff --git a/games-puzzle/cubosphere/Manifest b/games-puzzle/cubosphere/Manifest
index c60c8d0..2b3f139 100644
--- a/games-puzzle/cubosphere/Manifest
+++ b/games-puzzle/cubosphere/Manifest
@@ -1,2 +1,2 @@
-DIST cubosphere_beta_0.1_unix.tar 406374400 RMD160 0e3377c342584c39e436b24ef0f6f1df74d862ae SHA1 2cd7ef01771e27677d213b3c0d8c9298b0de92ac SHA256 9cfb79c5e80fc12d682e25defdd0d9383a62ee82aa30c710125cb64d2e21bb88
-EBUILD cubosphere-0.1.ebuild 983 RMD160 41b0603b0efc66b59d5364bfc01011ab85740793 SHA1 f933792c69e5d0745179ca88bc7b473b4a7b8f92 SHA256 c14111048068723352e16d83d0facd7f7b5e1d532b05fdaa308c6717573e7999
+DIST cubosphere_beta02_unix_src.tar 417310720 RMD160 613f080121ff50f28fc4bfce7dd7feb65915156d SHA1 510ac5a00c33d606819cb15584560997c8959495 SHA256 6b14d143be95a3136c385e58a789e7c5ee507dd4e35bf71055c4a956ef9c0c8e
+EBUILD cubosphere-0.2.ebuild 1060 RMD160 d53f0071fd6c8fb4f108b35572fac1126bf0b9f2 SHA1 0b3039c9c52c0bfd69d04e9b0acdae31a5b00089 SHA256 94b715fa9217321977b26f69a8b62155a4064ec383d0659976f074baad3cfd40
diff --git a/games-puzzle/cubosphere/cubosphere-0.1.ebuild b/games-puzzle/cubosphere/cubosphere-0.2.ebuild
index c80eac2..1104a19 100644
--- a/games-puzzle/cubosphere/cubosphere-0.1.ebuild
+++ b/games-puzzle/cubosphere/cubosphere-0.2.ebuild
@@ -4,11 +4,13 @@
EAPI="3"
+MY_PV="02"
+
inherit eutils games flag-o-matic
DESCRIPTION="game similar to the PSX game Kula World / Roll Away"
HOMEPAGE="http://cubosphere.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${PN}_beta_${PV}_unix.tar"
+SRC_URI="mirror://sourceforge/${PN}/${PN}_beta${MY_PV}_unix_src.tar"
LICENSE="GPL-3"
SLOT="0"
@@ -24,7 +26,10 @@ DEPEND="dev-lang/lua
virtual/opengl
virtual/glu"
+S="${WORKDIR}"/"${PN}"_beta"${MY_PV}"_unix_src
+
src_prepare() {
+ cd "${S}"
# respect ${GAMES_DATADIR}
sed -i -e "s:llua5.1:llua:g" -i Makefile
sed -i -e "s:PREFIX=/usr/local":PREFIX=/usr":g" -i Makefile