summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--games-simulation/kerbal-space-program/Manifest2
-rw-r--r--games-simulation/kerbal-space-program/kerbal-space-program-1.8.1.ebuild (renamed from games-simulation/kerbal-space-program/kerbal-space-program-1.6.1.ebuild)10
2 files changed, 6 insertions, 6 deletions
diff --git a/games-simulation/kerbal-space-program/Manifest b/games-simulation/kerbal-space-program/Manifest
index 96fd0df..576eb60 100644
--- a/games-simulation/kerbal-space-program/Manifest
+++ b/games-simulation/kerbal-space-program/Manifest
@@ -1 +1 @@
-DIST kerbal_space_program_1_6_1_26533.sh 1040134057 SHA256 03b32ecca26ac153a5187ed1c0202cdbee64e13d843220094f8858c333e1a95e SHA512 c17893a6fc399464f5b32493aa14491a7e7b1dfca7114e513d65ce3c7d2edc09145a5fda813cf1aa21997d325f1e939b6731f0be7ad446d0aa8299cafbd2792b WHIRLPOOL 332dc3e395dc6ee18735b140cf1a87ae202ed0b59a40c6dae0a021882ffff1452f1f4a25eb73e305fec4357c59eeaea9b5eb66a0f523bcf68b30d9a4833ce05f
+DIST kerbal_space_program_1_8_1_02694_33460.sh 1437736543 SHA256 e4086c93b500fef0afe3474da719a433c67e710fce143dc6b97f775f5e4d4e14 SHA512 8be0e7fce6d822844d96eff273af46e5bc1332f3335a563b41bc5af59759dc86e066651afa73423e9d1c577144a234619db8321f338909b14cb656b247c92f40 WHIRLPOOL df234b0f31a9484e60d8227fe8b2ef21b4a9478caeeae8ab4d4cae6a5e0c569b2d32e5aa0635bb3323a39ef084c775919e37434920012f7ce12aad87e6f30ebd
diff --git a/games-simulation/kerbal-space-program/kerbal-space-program-1.6.1.ebuild b/games-simulation/kerbal-space-program/kerbal-space-program-1.8.1.ebuild
index 772b8f1..d5f2343 100644
--- a/games-simulation/kerbal-space-program/kerbal-space-program-1.6.1.ebuild
+++ b/games-simulation/kerbal-space-program/kerbal-space-program-1.8.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -8,7 +8,7 @@ inherit eutils
DESCRIPTION="A space flight simulation"
HOMEPAGE="http://kerbalspaceprogram.com/"
-GOG_MAGIC="26533"
+GOG_MAGIC="02694_33460"
SRC_PH="${PN//-/_}@PH@_${PV//./_}_${GOG_MAGIC}.sh"
SRC_URI="
@@ -19,7 +19,7 @@ RESTRICT="fetch strip"
LICENSE="EULA"
SLOT="0"
-KEYWORDS="amd64 x86"
+KEYWORDS="amd64"
L10NS="l10n_en " #l10n_es l10n_fr l10n_it l10n_ja l10n_pt-BR l10n_ru l10n_zh-CN"
IUSE="${L10NS}"
@@ -83,9 +83,9 @@ src_install() {
exeinto "${dir}"
doins -r .
- doexe {KSP,Launcher}.x86{,_64} || die "Failed to install executables"
+ doexe {KSP,KSPLauncher}.x86_64 || die "Failed to install executables"
newbin "${T}/ksp-wrapper" "${PN}"
- newicon "Launcher_Data/Resources/UnityPlayer.png" "${PN}.png"
+ newicon "KSPLauncher_Data/Resources/UnityPlayer.png" "${PN}.png"
make_desktop_entry "${PN}" "Kerbal Space Program" "${PN}" || die "make_desktop_entry failed"
}