summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'devel/games-action/ardentryst/ardentryst-1.71.ebuild')
-rw-r--r--devel/games-action/ardentryst/ardentryst-1.71.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/devel/games-action/ardentryst/ardentryst-1.71.ebuild b/devel/games-action/ardentryst/ardentryst-1.71.ebuild
new file mode 100644
index 0000000..fc3aa2f
--- /dev/null
+++ b/devel/games-action/ardentryst/ardentryst-1.71.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit games
+
+MY_P=${P/-/}
+
+DESCRIPTION="An action/RPG sidescoller, focused not just on fighting, but on story and character development."
+HOMEPAGE="http://jordan.trudgett.com/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-python/pygame"
+
+S=${WORKDIR}/${MY_P}
+
+src_install() {
+ insinto "${GAMES_DATADIR}/${PN}"
+ doins -r Base Data Demos Fonts Levels Music Sounds OPR.txt *.py *.dig *.xml || die "doins failed"
+ games_make_wrapper ${PN} "python ./ardentryst.py" "${GAMES_DATADIR}/${PN}"
+ newicon Data/icon.png ${PN}.png
+ make_desktop_entry ${PN} Ardentryst
+ dodoc help.txt
+ prepgamesdirs
+}